Contribute
Register

Mojave 10.14.3 Very Slow Render in Final Cut Pro X with iGPU compared to 10.13.6 / 10.14.2

Joined
Dec 31, 2013
Messages
451
Motherboard
Huawei Matebook D i5-8250U 14"
CPU
Intel i5-8250U
Graphics
UHD 620
Mobile Phone
iOS
After updating to Mojave I've noticed rendering times in Final Cut Pro X (and Metal in general) became zombie.

Rendering BruceX test both exporting in ProRes and H264 take circa 7 minutes instead of 55sec on 2 of my systems, that are in fact showing the same issue after upgrading to 10.14.3
What in 10.13.6 and 101.4.2 takes 55sec circa now takes 7 minutes.

In 10.14.3 the score of OpenCL and Metal for the iGPU are really good in GeekBench 4.3 (27500 circa), but when it comes to rendering in FCPX the times are devastatingly slow.

The installation is correct and acceleration is working. I'm simply testing the same EFI and config.plis with 10.14.2 and 10.14.3 and in the last update there's something broken in 10.14.3. I tried also re-installing a 10.14.3 Combo but it didn't solve the issue. I'm using the latest FCPX 10.4.5.

Does anyone know how to fix this, is it an Apple bug? Do we need a different configuration for iGPU?
Thanks!
 
Last edited:
Joined
Jul 12, 2011
Messages
9
Motherboard
Thinkpad X1 Extreme-Clover
CPU
i7-8850H
Graphics
UHD 630 / GTX 1050Ti, 3840x2160
Having the same issues on a Lenovo X1 Extreme running the latest FCPX and Mojave. Tried Compressor and was painfully slow as well. Even background rendering during FCPX slows down the laptop so much that I can't even do anything basic in the background like browsing the internet. Looks like we both of our graphic cards is UHD630
 
Joined
Feb 15, 2019
Messages
4
After updating to Mojave I've noticed rendering times in Final Cut Pro X (and Metal in general) became zombie.

Rendering BruceX test both exporting in ProRes and H264 take circa 7 minutes instead of 55sec on 2 of my systems, that are in fact showing the same issue after upgrading to 10.14.3
What in 10.13.6 and 101.4.2 takes 55sec circa now takes 7 minutes.

In 10.14.3 the score of OpenCL and Metal for the iGPU are really good in GeekBench 4.3 (27500 circa), but when it comes to rendering in FCPX the times are devastatingly slow.

The installation is correct and acceleration is working. I'm simply testing the same EFI and config.plis with 10.14.2 and 10.14.3 and in the last update there's something broken in 10.14.3. I tried also re-installing a 10.14.3 Combo but it didn't solve the issue. I'm using the latest FCPX 10.4.5.

Does anyone know how to fix this, is it an Apple bug? Do we need a different configuration for iGPU?
Thanks!
I have the same story! Tell me you managed to solve this problem???
 
Joined
Dec 31, 2013
Messages
451
Motherboard
Huawei Matebook D i5-8250U 14"
CPU
Intel i5-8250U
Graphics
UHD 620
Mobile Phone
iOS
The only solution I found is to go back to 10.14.2
 
Joined
Feb 12, 2019
Messages
13
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
Vega 64
Mac
MacBook Pro, Mac mini
Mobile Phone
iOS
Looks like it's not just a hackintosh problem. Users with regular Macs experience the same problem after installing 10.14.3.
You can turn off background rendering and then fcpx can be used. Unfortunately, the problem arises again when the project is to be exported.
Some believe that it is the third party plugins causing the problem, which I have not verified.
 
Joined
Aug 1, 2011
Messages
28
Motherboard
Intel NUC8i5BEH
CPU
i5-8259U
Graphics
Iris Plus 655
Mac
MacBook Air
Fixed for me in the latest 10.14.4 beta (18E194d)
 
Joined
Feb 15, 2019
Messages
4
Looks like it's not just a hackintosh problem. Users with regular Macs experience the same problem after installing 10.14.3.
You can turn off background rendering and then fcpx can be used. Unfortunately, the problem arises again when the project is to be exported.
Some believe that it is the third party plugins causing the problem, which I have not verified.
I checked. All is true all third-party goods conflict. And this Bug appears. Uplil all plugins and FCPX. Now flies. But without plug-ins to work that hard
 
Top