Contribute
Register

Mojave 10.14.2 will not boot from Clover 4798 but will from 4630 or 4769

Joined
Sep 11, 2010
Messages
23
Motherboard
Gigabyte Z370N Wifi
CPU
i5 8400
Graphics
HD630
Mac
iMac, MacBook Air, MacBook Pro, Mac Pro
Mobile Phone
iOS
I had a fully working 10.14.0 install on Gigabyte Z370N wifi using HD630 video and custom SSDT for USB support. In preparation for updating to 10.14.2, I updated Clover to the latest build (4798), then installed the 14.2 update. After update reboots were complete, my system will not boot into Mojave. Verbose boot indicates that "End RandomSeed" is the last event before video sleeps, then a reboot occurs about 30 seconds later. I am sure there is boot activity occurring during that 30 seconds, but I can't see it since display is dark.

Interestingly, I have a test build on a separate SSD in this system running 10.14.2 and Clover 4769 (from Multibeast 11). If I boot into this drive, Clover 4769 can see my production build and boots into it just fine, and everything is working normally. So I know my Mojave install isn't the issue (which is why troubleshooting files are not uploaded to this post)--I'm assuming Clover 4798 is messed up in some way. I have already tried reinstalling Clover to the production SSD and this does not correct the issue. I have not yet tried rolling back to an earlier version of Clover.

Any advice for where to start trouble shooting? Thanks in advance.
 
Joined
May 26, 2018
Messages
37
Motherboard
Gigabyte H370M-DS3H
CPU
i7-8700K
Graphics
UHD 630
Mac
Mac mini
Mobile Phone
iOS
Unfortunately, I am of no help. But your information is very helpful to me as I am having the same problem on a H370M and Mojave 14.1 and Clover 4674. Of course, since my issue is with an older Clover, my problem is likely something else.

I am able to preboot through the USB, then complete the boot through the Mojave hard drive. To me that suggests the issue is in the preboot stage. That makes sense with your information that it seems to be Clover revision level sensitive. After all, what are you doing in the preboot stage, just starting clover and scanning the machine.
 
Joined
May 26, 2018
Messages
37
Motherboard
Gigabyte H370M-DS3H
CPU
i7-8700K
Graphics
UHD 630
Mac
Mac mini
Mobile Phone
iOS
I don't know if this will help you guys, but I just got through the Randomseed by checking the "kernel PM" in the Clover Configurator/Kernel and Kext Patches tab. Give it a try and see if it helps.
 
Joined
Dec 4, 2014
Messages
158
Motherboard
GA-Z170X Ultra Gaming
CPU
i7-7700K
Graphics
Vega 56
Mac
iMac, MacBook Pro, Mac Pro
Mobile Phone
Android
After updating of mojave it won't boot.
I had Clover 4630. And now I updated it to 4871 (from secondary SSD with High Sierra). But the same result.
With -v I see that End random seed and everything stops.

Any advices what to do next?
 
Joined
Dec 4, 2014
Messages
158
Motherboard
GA-Z170X Ultra Gaming
CPU
i7-7700K
Graphics
Vega 56
Mac
iMac, MacBook Pro, Mac Pro
Mobile Phone
Android
upd. Even Mac OS installer stops on End RandomSeed. And I don't know how to reinstall clover on bootable disc, because I can't start with secondary SSD now too.
 
Joined
Feb 2, 2019
Messages
3
Motherboard
Asus Rog Maximus X Code
CPU
i7-8700K 3.7GHz
Graphics
Sapphire Nitro+ Radeon RX Vega 56
Same issue here, I updated from 4862 to 4871 and when I reboot I couldn't get back to Mojave 10.14, it just boot loops.
I can get in from USB and clover shows its still at 4862 but how to change SSD version to this ?
 
Joined
Feb 2, 2019
Messages
3
Motherboard
Asus Rog Maximus X Code
CPU
i7-8700K 3.7GHz
Graphics
Sapphire Nitro+ Radeon RX Vega 56
[SOLVED]
Ok so I fixed my problem not being able to boot Mojave after updating clover to 4871, causing a constant boot loop.

WHAT I DID:
Boot from USB originally used for initial install of Mojave and purely used the USB as the Bootloader (4769).
This got me into Mojave then I created new volume (maybe not required) installed Mojave again, calling it Mojave2 and from Mojave2 I setup Bootloader and other ktext/drivers etc from multibeast.
What this done was replaced the Bootloader used for all images to older version 4769 so now I can get back into original Mojave without USB.
Maybe I didn't need to create new volume and OS setup and maybe if you load to Mojave using USB as Bootloader and save Bootloader again with older version of clover this might replace the newer version preventing it to load.

Guys I'm brand new to all this so excuse me if I'm making this sound messy but hope this helps.
 
Top