Contribute
Register

Missing resolutions

Status
Not open for further replies.
Joined
Nov 12, 2016
Messages
2
Hi,

I'll start with massive thanks to everyone who contributes to this forum, it's an incredible resource for building a Hackintosh!

I'm just getting to the end of building the CustoMac Mini Deluxe from the buyers guide. Gigabyte GA-Z170N-Gaming 5 + i7 6700k.

It's a beast and after a fix for graphics glitches on the menu bar (Skylake issue) it runs really well, however it's just been plugged into a 4k TV and I'm not getting the option to select a 4k resolution from the display settings in OSX, the max resolution is 1920x1080.

Anyone know to solve this? Is it the EDID that isn't getting read from the TV and needs hardcoding into config.plist?
Or should adding the desired graphics mode to boot.plist work?

We've tried adding a custom resolution via SwitchResX but it's showing as invalid so it won't let us select it.

HiDPI has been enabled in case it matters.
Holding down option when clicking scaled in Display doesn't show any higher than 1080 resolutions.
Inject Intel seems to working AOK.

Clover works in 4k.
The Apple boot logo seems to be in 4k, but when it gets to desktop it reverts to 1920x1080.

Any ideas??! I can dump config.plist if it helps.

Thanks in advance.

NB This is a music production machine so only needs 4k@24 Hz, which is the max over HDMI, but should be supported!

Edit - Have win10 on another ssd and 4k and multi monitor works AOK.
 
Last edited:

slim.jim

Moderator
Joined
Dec 17, 2014
Messages
4,222
Motherboard
MSI Z97 Gaming 9 AC
CPU
i7-4790K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
Use the PixelClock patch
 
Joined
Nov 12, 2016
Messages
2
Thanks Slim. Patched PixelClock yesterday but still no joy. Will try creating custom resolutions again as 30 hz wasn't working but 24 hz might.
 
Status
Not open for further replies.
Top