Contribute
Register

MiniDP Audio not working kabylake 14.3 hd630

Joined
Jan 22, 2019
Messages
101
Motherboard
Thinkpad T470p-Clover
CPU
i7-7700HQ
Graphics
HD 630, 2560 x 1440
Hello! I have a t470P thinkpad i7 7700HQ. Audio is perfectly working with lilu and applealc. Problem is that I can't get minidp audio to work. To say the truth it worked once while spoofing to skylake gpu ids but it lasted one reboot. I don't really know what is going on, and i'll be glad if some one can help me. With fakepciid I don't have any audio at all. Attached debug info, ioreg with and without minidp.
 

Attachments

Joined
Jan 22, 2019
Messages
101
Motherboard
Thinkpad T470p-Clover
CPU
i7-7700HQ
Graphics
HD 630, 2560 x 1440
@toleda I'm sorry, just looking for visibility, BTW there's not any kind of option to enable or disable HDMI audio in bios. It seems that's now working on cold boot after Skylake spoof and lost after sleep. I've been able to see it trought dcpimanager with the relative id. Any place where I should look?
 
Joined
Jan 22, 2019
Messages
101
Motherboard
Thinkpad T470p-Clover
CPU
i7-7700HQ
Graphics
HD 630, 2560 x 1440
In the attached debug , ioreg:
-Plugged
-unplugged
-after Sleep
according to DCPIManager, this is the hdmi audio address

0x8086280b

0x8086a171 is the alc298 (main one)
 

Attachments

Joined
Jan 22, 2019
Messages
101
Motherboard
Thinkpad T470p-Clover
CPU
i7-7700HQ
Graphics
HD 630, 2560 x 1440
Now I did not change anything at all and it stopped working. I don't really understand what is going on. Do you have any suggestion? After wake from sleep doesn't work either
 
Joined
Jan 22, 2019
Messages
101
Motherboard
Thinkpad T470p-Clover
CPU
i7-7700HQ
Graphics
HD 630, 2560 x 1440
Video Always playing, at restart it used to work, now it doesn't work at all.while working after sñeep, some times, audio of the TV appears but comes out of the internals.
 

toleda

Moderator
Joined
May 20, 2010
Messages
24,101
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
512K, LC, Power Mac
Mobile Phone
iOS
Post #4 attached files show HD630 HDMI audio working
now it doesn't work at all
Attach new Problem Reporting files
while working after sñeep, some times, audio of the TV appears but comes out of the internals.
To be clear, only the setting changes; correct?
Not related to above issue, an inconvenience
 
Joined
Jan 22, 2019
Messages
101
Motherboard
Thinkpad T470p-Clover
CPU
i7-7700HQ
Graphics
HD 630, 2560 x 1440
So, now it completely stopped working nor the HDMI audio interface is recognized in dcpimanager and ioreg. When it was working it would break as said after sleep. Like this:
-plugging ---work
-unplugging
Sleep---wake
Plugging--- doesn't work.
I'll attach new files this night but it's more like it randomly doesn't get enabled. I've tried almost anything and I'm running out of solutions. No way to enable or disable this through the bios.
 
Top