Contribute
Register

Micro-ATX build MSI MAG-B460M-MORTAR+i5-10500+RX470 - Open Core | Catalina/Big Sur

Joined
Dec 26, 2018
Messages
26
Motherboard
Asus H110T
CPU
i5-7600
Graphics
HD 630
dust261's Build:
MSI MAG B460M MORTAR - i5-10500 - RX 470


123.png

IMG_2874(20200602-083118).JPG

IMG_3023.jpg



Components

MSI MAG B460M MORTAR Motherboard
https://www.amazon.com/dp/B0892VYBZG/?tag=tonymacx86com-20

Intel i5-10500 3.1 GHz 6-Core Processor
https://www.amazon.com/dp/B086MN38Q2/?tag=tonymacx86com-20

TEAMGROUP T-Force Vulcan Z DDR4 16GB Kit (2 x 8GB) 2666MHz (PC4 21300) CL18 Desktop Memory Module
https://www.amazon.com/dp/B07QMM6NY3/?tag=tonymacx86com-20



Already Owned

Cool Fish S5 All-Aluminum M-ATX case
FSP MS450 SFX PSU (fullly modular)
Thermalright AK120 MINI CPU Cooler
Dataland RX560XT 4GB X-Serial Game graphics card (RX470d equivalent)
BCM943602cs+PCIE 1x adapter




Comments

Build this computer for one of my friend who lives in China and works overseas, the main purposes of this build are:
1. Small size which the case can be placed in a boarding case
2. Latest hardware which are capable of working (mainly for CAD) and gaming
3. Decent cooling which in result of lower fan rpm = silent.
4. Limited budget

Installation Notes
Insert your MacOS installation flash drive into rear USB 2.0 port

Bios Configuration
VT-D and CFG Lock must be disabled !!!!!!!

I suggest that disable intel virtualization technology(enabled for virtual machine such as parallel desktop) and IGD Multi-Monitor(enabled for iGPU) before installing MacOS, and re-enabled those after finishing installation
1.png

1607321359832.png


3.jpg


Everything Works
  1. Continuity:
    - Handoff
    - iMessage
    - Air Drop
  2. Sleep
  3. Wake
  4. Audio (select internal speakers)
  5. Ethernet
  6. Bluetooth
  7. WiFi
  8. All USB ports
Known Issue
Realtek 8125 Ethernet card required to manually set to 100baseTx(or 1000baseTx depend on your network speed) to work

Ethernet1.png


Benchmarks
Geekbench 5.1
geekbench 5.png


OpenCore Catalina 10.15.7
2020-11-6 updated the latest open core efi (0.6.3) with iMac20,1 smbios, compitable with the latest Catalina 10.15.7 version (Big sur 11.0.1 also tested working, but try it with your own risk), previous version(10.15-10.15.6) do not use the new one
I have also attached some new configs in the latest EFI file to fit NAVI video card and IGPU-only user, what do you need to do is change the config file name to Config.plist
--------------------------------------------------------------------------------------------------------------------------------
2020-12-7 update all kexts with iMac20,1 smbios. Compitable with Big Sur 11.0.1 and Catalina 10.15.7
I have also updated boot args "igfxrpsc=1" for uhd630 that works with the latest whatevergreen, which makes iGPU work at full speed under load, you can test youtube 8k 60fps vp9 video under Big sur in Safari, it works pretty well.
I have also attached some new configs in the latest EFI file to fit NAVI video card and IGPU-only user, what do you need to do is change the config file name to Config.plist
1607360314811.png
 

Attachments

  • efi.zip
    1.7 MB · Views: 1,015
  • oc-0.6.3-2020-11-6.zip
    2.2 MB · Views: 276
  • oc0.6.3-2020-12-7.zip
    2.2 MB · Views: 186
Last edited:

UtterDisbelief

Moderator
Joined
Feb 13, 2012
Messages
5,231
Motherboard
Gigabyte Z390M Gaming - Clover 5102
CPU
i5-9600K
Graphics
RX 570 1920x1080
Mac
  1. iMac
  2. Mac mini
Classic Mac
  1. eMac
  2. iBook
Mobile Phone
  1. iOS
For anyone who has the same motherboard and willing to solve the usb 3.0 issue, here is the usb mapsView attachment 476260
View attachment 476261


Hi there.

Your USB problem is caused by the USBPorts.kext you have created.

1) You have no USB3.0 ports defined. You only have USB2.0 in there - HS01-HS06, HS09-HS11. You need to define the SS** ports too.

2) Also, most of those USB2.0 ports are defined as UsbConnector type "0". This is fine for Black, USB2.0-only ports, but for Blue USB3.0 ports they should be UsbConnector type "3" as physically they have more contacts in them. Your UsbConnector type for HS11 is correct if it is Internal etc.

:)
 
Joined
May 23, 2017
Messages
1
Motherboard
B85-d3v
CPU
i5-4590
Graphics
RX560
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
thank you for share, is the board with wifi ?
 
Joined
Nov 29, 2012
Messages
119
Motherboard
Gigabyte Z490M Gaming X
CPU
i7-10700
Graphics
Radeon Pro WX 4100 4 GB
Hi there.

Your USB problem is caused by the USBPorts.kext you have created.

1) You have no USB3.0 ports defined. You only have USB2.0 in there - HS01-HS06, HS09-HS11. You need to define the SS** ports too.

2) Also, most of those USB2.0 ports are defined as UsbConnector type "0". This is fine for Black, USB2.0-only ports, but for Blue USB3.0 ports they should be UsbConnector type "3" as physically they have more contacts in them. Your UsbConnector type for HS11 is correct if it is Internal etc.

:)

I'm a Hackintosh n00b. Are the USB 3.0 ports figured out in the EFI files posted to this thread?
 
Joined
Aug 11, 2020
Messages
12
Motherboard
ASRock z490 Taichi
CPU
i7-10700k
Graphics
HD 630
I participated in the session and listened to the teacher.
 
Joined
Aug 31, 2020
Messages
1
Motherboard
B460M Mortal
CPU
i7-10700
Graphics
Intel version # > See Rules!
Can I build with B460M Mortal + i7-10700 successful like you?
 
Joined
Sep 21, 2020
Messages
1
Motherboard
MSI B460M Mortar
CPU
i5-10500
Graphics
Intel UHD 630
Nice job.
I'm looking the familiar set with yours. Your share is helpful.
 
Top