Contribute
Register

<< Solved >> MAXIMUM BRIGHTNESS GETS REDUCED BY USING -WEGNOEGPU

Status
Not open for further replies.
Joined
Jul 17, 2015
Messages
185
Motherboard
HP Pavilion 15 dk0xxx
CPU
i7-9750H
Graphics
UHD 630 + GTX 1650, 1920x1080
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
I want to disable dedicated GPU, GTX 1650 but using -wegnoegpu causes my maximum brightness to drastically get reduced. Is there a fix for this so I can disable the dGPU to maximise battery life?
 

Attachments

  • CLOVER.zip
    6.7 MB · Views: 141

Feartech

Moderator
Joined
Aug 3, 2013
Messages
25,979
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
I want to disable dedicated GPU, GTX 1650 but using -wegnoegpu causes my maximum brightness to drastically get reduced. Is there a fix for this so I can disable the dGPU to maximise battery life?
 
Joined
Jul 17, 2015
Messages
185
Motherboard
HP Pavilion 15 dk0xxx
CPU
i7-9750H
Graphics
UHD 630 + GTX 1650, 1920x1080
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
@Feartech I used the attached SSDT. It is achieving the same thing as shown in the guide. Sad thing is that my maximum brightness still got drastically reduced :(


Edit: For anyone facing the issue. Using Brightness_CFL inside ACPI/Patched along with SSDT-Disbale-DGPU fixed my issue.
 

Attachments

  • SSDT-Disable-DGPU.aml
    1.4 KB · Views: 115
  • Brightness_CFL.zip
    2.4 KB · Views: 133
Last edited:
Status
Not open for further replies.
Top