Contribute
Register

Mavericks OSX Black screen on Boot

Joined
Sep 22, 2013
Messages
8
Motherboard
Trying to Upgrade to Mavericks OSX
CPU
Intel Core 2 Quad 3.0GHz LGA 775 95W Quad-Core Processor
Graphics
GeForce 9800 GTX+ 512MB 256-bit GDDR3 PCI Express 2.0 x16
Mac
Mac Pro
Classic Mac
Mobile Phone
Tried installing Mavericks today and get a black screen after the apple logo. Used the boot flags such as -x, -v, GraphicsEnabler=Yes PCIRootUID=1 and still black screen.

i have the ff. setup
a.
GeForce 9800 GTX+ 512MB 256-bit GDDR3 PCI Express 2.0 x16
b. Intel Core 2 Quad 3.0GHz LGA 775 95W Quad-Core Processor
c. GIGABYTE GA-EP45-UD3P Intel P45 ATX Intel Motherboard

can anyone help me on this? Thanks!
 
Joined
Sep 29, 2013
Messages
2
Mac
Classic Mac
Mobile Phone
I had an 8800 GT (same G92 chipset as the 9800). Ran into the same exact problem as you. Perhaps Mavericks removed the G92 drivers?

Went to Fry's and bought a 650 TI Boost. Works like a charm.
 
Joined
Sep 22, 2013
Messages
8
Motherboard
Trying to Upgrade to Mavericks OSX
CPU
Intel Core 2 Quad 3.0GHz LGA 775 95W Quad-Core Processor
Graphics
GeForce 9800 GTX+ 512MB 256-bit GDDR3 PCI Express 2.0 x16
Mac
Mac Pro
Classic Mac
Mobile Phone
I had an 8800 GT (same G92 chipset as the 9800). Ran into the same exact problem as you. Perhaps Mavericks removed the G92 drivers?

Went to Fry's and bought a 650 TI Boost. Works like a charm.
So you're saying that this is just a graphics card issue and replacing it to a new one will correct the problem?
 
Joined
Jul 29, 2012
Messages
150
Motherboard
OSX Mavericks 10.9
CPU
Intel i5-4670K
Graphics
EVGA GTX760 2GB
Mac
Classic Mac
Mobile Phone
iOS
Have you seen this ? Maybe there is a solution for you... and i don't think that this is only a Grphicscard problem, as there are many reports of 8800GT and also 9800GT gfx cards working in Mavericks ;)
 
Joined
Sep 22, 2013
Messages
8
Motherboard
Trying to Upgrade to Mavericks OSX
CPU
Intel Core 2 Quad 3.0GHz LGA 775 95W Quad-Core Processor
Graphics
GeForce 9800 GTX+ 512MB 256-bit GDDR3 PCI Express 2.0 x16
Mac
Mac Pro
Classic Mac
Mobile Phone
Have you seen this ? Maybe there is a solution for you... and i don't think that this is only a Grphicscard problem, as there are many reports of 8800GT and also 9800GT gfx cards working in Mavericks ;)
Tried everything and still getting the same problem which is the black screen after the apple logo. last resort would really have to be upgrading to a new graphics card.
 
Joined
Oct 19, 2012
Messages
27
Motherboard
Gigabyte H55M-UD2H
CPU
Intel Core i7
Graphics
ati HD5970
Mac
Classic Mac
Mobile Phone
I have exactly the same problem with my 8800GT. (Previously running 10.7 with no problems). If any 1 has any idea how to fix it, that would be great, since I cant replace my card for now :/.
 
Joined
Feb 1, 2011
Messages
106
Mac
Classic Mac
Mobile Phone
Yup, problems on a P5K Premium Wifi/AP with 9800GTX+ as well...
 
Joined
May 23, 2010
Messages
669
Motherboard
Gigabyte Z170M-D3H
CPU
i5 6600K
Graphics
GTX 970
Mac
MacBook Pro
Classic Mac
iBook, Performa
Mobile Phone
iOS
I solved this issue on my parents' build by using "GraphicsEnabler=Yes, IGPEnabler=No" at boot. Just GraphicsEnabler=Yes was not enough to do the trick for me. Hope this helps someone else in the same situation.
 
Joined
Dec 10, 2013
Messages
1
Mac
Classic Mac
Mobile Phone
Hello,

I've got exactly the same pb:
Tried installing Mavericks today and get a black screen after the apple logo. Used the boot flags such as -x, -v, "GraphicsEnabler=Yes", "PCIRootUID=1", "GraphicsEnabler=Yes IGPEnabler=No" and still black screen.

my computer is like this:
a. Point of View 9800 GT 1GO (PCI Express 2.0)
b. Q6600
c. GIGABYTE GA-EP45T-UDL3R Intel P45 ATX Intel Motherboard

=> most importnat I'm new in this kind of stuff!

can anyone help me on this? Thanks!
 
Top