Contribute
Register

Mavericks: Native CPU/IGPU Power Management

Joined
Jan 23, 2017
Messages
27
Motherboard
Gigabyte GA-B75M-D3H
CPU
i7-3770K
Graphics
GTX 960
Mac
iMac, MacBook Air
Mobile Phone
iOS
Apologies for the delay in replying
Linked thread/Post #1
See Installation
5. Clover Settings ...

Suggestion, post in the linked thread for quicker reply.
Thanks for the help I replied there, I've already run everything I think...

I'm attaching everything that I have, I also used DarwinDunper to do a fully report since I didn't know exactly what I'm looking for
 

Attachments

Joined
Oct 7, 2010
Messages
15
Motherboard
Custom Mini
CPU
i3 3.09 MHZ HD2000
Graphics
GT 120
Mac
MacBook Pro, Mac mini, Mac Pro
Classic Mac
Mobile Phone
Other
Thanks for all your awesome work Toleda! Can this help with an older ep45 board and E9550 core 2 duo?
 
Joined
Jan 13, 2017
Messages
260
Motherboard
Gigabyte Designare Z390
CPU
i9 9900K
Graphics
RX580
Mac
iMac, Mac Pro
Classic Mac
Apple
Mobile Phone
iOS
HI Is there someone who got access to ivy bridge i5-3570K to work on mojave ?
I got only 2 options only x8 .. and only x16/x34.. I can not active more. I got it only ones and after that with same config I can not boot.
this is my only boot.
after that no luck..
this is my 3 day work about it.
So @toleda can you help ?
My machine is Asrock Z77 extreme4 . RX560 - i5-3570K
I upload last SSDT gen terminal log
 

Attachments

Joined
Jan 13, 2017
Messages
260
Motherboard
Gigabyte Designare Z390
CPU
i9 9900K
Graphics
RX580
Mac
iMac, Mac Pro
Classic Mac
Apple
Mobile Phone
iOS
I try
Instead:
  • delete SSDT.aml if you already created it
  • set config.plist/KernelAndKextPatches/KernelXCPM=true
  • set config.plist/ACPI/SSDT/Generate/PluginType=true
  • make sure you're not dropping OEM CPU SSDTs (eg. DropOem=false, no CPU SSDTs identified in DropTables)
and machine restart any time on boot
 
Last edited:
Joined
Jan 13, 2017
Messages
260
Motherboard
Gigabyte Designare Z390
CPU
i9 9900K
Graphics
RX580
Mac
iMac, Mac Pro
Classic Mac
Apple
Mobile Phone
iOS
IS I should use some form this

cpuid_set_info_rdmsr (c) vit9696
B9A00100 000F32
B9A00100 0031C0
10.12.x,10.13.x,10.14.x

xcpm_idle_wrmsr (c) Pike R. Alpha
B9E20000 000F30
B9E20000 009090
10.12.x,10.13.x,10.14.x

xcpm_assert_rdmsr (c) Sherlocks
B9980100 000F32
B9980100 0031C0
10.12.x,10.13.x,10.14.x

xcpm_SMT_scope_msrs (c) Pike R. Alpha
BE0B0000 005DE908 000000
BE0B0000 005DC390 909090
10.12.x,10.13.x,10.14.x

cpuid_set_info (c) Pike R. Alpha
04723CD0
04XX3CD0
10.13.x,10.14.x
- XX: need value you want

xcpm_bootstrap (c) Pike R. Alpha
89D804C4 3C22
89D804XX 3C22
10.13.x,10.14.x
- XX: need value you want

xcpm_assert_wrmsr (c) Sherlocks
B9990100 000F30
B9990100 009090
10.13.x,10.14.x

xcpm_core_scope_msrs (c) Pike R. Alpha
BE030000 0031D2E8 79FCFFFF
BE030000 0031D290 90909090

xcpm_pkg_scope_msrs (c) Pike R. Alpha
BE070000 0031D2E8 91FCFFFF
BE070000 0031D290 90909090
10.14.x

xcpm_program_msrs (c) Pike R. Alpha
554889E5 41574156 41554154 53504189 D64889FB 4189F54C 8D3D6387
C39089E5 41574156 41554154 53504189 D64889FB 4189F54C 8D3D6387
10.14.x

xcpm_SMT_scope_msrs (c) Pike R. Alpha
BE0B0000 0031D2E8 66FCFFFF
BE0B0000 0031D290 90909090
10.14.x

Disable panic kext logging on 10.14 Release kernel (c) vit9696
8A0284C0 7442
8A0284C0 EB42
10.14.x
 

pct

Joined
Nov 8, 2010
Messages
87
Motherboard
Gigabyte H67MA-UD2H-B3
CPU
i3-2105
Graphics
MSI GT710 1Gb
Hi

I'm just updating my old hack (legacy boot with Gigabyte H67MA-UD2H-B3, SandyBridge i3-2105 with a GT710) to Mojave (already booting with Clover 4920, lilu, AppleALC and WEG) and soon to Catalina (with clover 5100) and was wondering which guide I should use for proper Power Management and sleep.

Should I still use this thread as this is for SandyBridge ? Even with recent OS (Mojave/Catalina) and recent Clover (4920/5100) ?

Or is there another way ? (what about for ex macOS Native CPU/IGPU Power Management ?) Or Clover itself ?

Thanks

EDIT Dec 20 : So i tried to run the thread #1 methodology. I have a SandyBridge but I must use SMBIOS 13.2 or 14.2 to get my GT710 recognized.
Thus when I run ssdtPRGen.sh, I've got a board-id error as the CPU is not supported by these SMBIOS. I then tried to add the -target 0 option to force SandyBridge but I then got the following iasl compiling error and got no file. What's wrong ?

Thanks

Scope (\_PR_) {320 bytes} with ACPI Processor declarations found in DSDT (ACPI 1.0 compliant)
Generating ssdt.dsl for a 'iMac14,2' with board-id [Mac-27ADBB7B4CEE8E61]
Sandy Bridge Core i3-2105 processor [0x206A7] setup [0x]
With a maximum TDP of 65 Watt, as specified by Intel
Number logical CPU's: 4 (Core Frequency: 3100 MHz)
Number of Turbo States: 0
Number of P-States: 16 (1600-3100 MHz)
Injected C-States for ._PR (C1,C3,C6,C7)
Warning: 'cpu-type' may be set improperly (0x instead of 0x06)
- Clover users should read https://clover-wiki.zetam.org/Configuration/CPU#cpu_type
Error: board-id [Mac-27ADBB7B4CEE8E61] not supported by Sandy Bridge – check SMBIOS data / use the -target option

Do you want to continue (y/n)? y
Warning: 'system-type' may be set improperly (1 instead of 2)
- Clover users should read https://clover-wiki.zetam.org/Configuration/ACPI#acpi_smartups
Compiling: ssdt_pr.dsl
Intel ACPI Component Architecture
ASL Optimizing Compiler version 20140926-64 [Nov 6 2014]
Copyright (c) 2000 - 2014 Intel Corporation

Compiler aborting due to parser-detected syntax error(s)
/Users/philippe/Library/ssdtPRGen/ssdt.dsl 20: External (\_PR_.._PR, DeviceObj)
Error 6126 - ^ Invalid character (0x2E), expecting ASL keyword or name

/Users/philippe/Library/ssdtPRGen/ssdt.dsl 20: External (\_PR_.._PR, DeviceObj)
Error 6126 - ^ Invalid character (0x2E), expecting ASL keyword or name

/Users/philippe/Library/ssdtPRGen/ssdt.dsl 20: External (\_PR_.._PR, DeviceObj)
Error 6126 - syntax error, unexpected PARSEOP_NAMESEG, expecting ')' ^

/Users/philippe/Library/ssdtPRGen/ssdt.dsl 21: External (\_PR_.._PR, DeviceObj)
Error 6126 - ^ Invalid character (0x2E), expecting ASL keyword or name

/Users/philippe/Library/ssdtPRGen/ssdt.dsl 21: External (\_PR_.._PR, DeviceObj)
Error 6126 - ^ Invalid character (0x2E), expecting ASL keyword or name

/Users/philippe/Library/ssdtPRGen/ssdt.dsl 21: External (\_PR_.._PR, DeviceObj)
Error 6126 - syntax error, unexpected PARSEOP_NAMESEG, expecting ')' ^

/Users/philippe/Library/ssdtPRGen/ssdt.dsl 22: External (\_PR_.._PR, DeviceObj)
Error 6126 - ^ Invalid character (0x2E), expecting ASL keyword or name

/Users/philippe/Library/ssdtPRGen/ssdt.dsl 22: External (\_PR_.._PR, DeviceObj)
Error 6126 - ^ Invalid character (0x2E), expecting ASL keyword or name

/Users/philippe/Library/ssdtPRGen/ssdt.dsl 22: External (\_PR_.._PR, DeviceObj)
Error 6126 - syntax error, unexpected PARSEOP_NAMESEG, expecting ')' ^

/Users/philippe/Library/ssdtPRGen/ssdt.dsl 23: External (\_PR_.._PR, DeviceObj)
Error 6126 - ^ Invalid character (0x2E), expecting ASL keyword or name

/Users/philippe/Library/ssdtPRGen/ssdt.dsl 23: External (\_PR_.._PR, DeviceObj)
Error 6126 - ^ Invalid character (0x2E), expecting ASL keyword or name

/Users/philippe/Library/ssdtPRGen/ssdt.dsl 23: External (\_PR_.._PR, DeviceObj)
Error 6126 - syntax error, unexpected PARSEOP_NAMESEG, expecting ')' ^

/Users/philippe/Library/ssdtPRGen/ssdt.dsl 25: Scope (\_PR_.._PR)
Error 6126 - ^ Invalid character (0x2E), expecting ASL keyword or name

/Users/philippe/Library/ssdtPRGen/ssdt.dsl 25: Scope (\_PR_.._PR)
Error 6126 - ^ Invalid character (0x2E), expecting ASL keyword or name

/Users/philippe/Library/ssdtPRGen/ssdt.dsl 25: Scope (\_PR_.._PR)
Error 6126 - ^ syntax error, unexpected PARSEOP_NAMESEG, expecting ')'

/Users/philippe/Library/ssdtPRGen/ssdt.dsl 145:
Error 6126 - syntax error, unexpected PARSEOP_SCOPE, expecting $end and premature End-Of-File

ASL Input: /Users/philippe/Library/ssdtPRGen/ssdt.dsl - 145 lines, 4776 bytes, 23 keywords

Compilation complete. 16 Errors, 0 Warnings, 0 Remarks, 0 Optimizations
Error: IASL status: 255 (Failed)

I attach the full set of problem report files
 

Attachments

Last edited:
Joined
Jan 21, 2015
Messages
6
Motherboard
x1550
CPU
q9450
Graphics
vega 64
Hello, i am new to this but not new to oci`ing :)

I challanged myself to resurect an old beast asus g73jh laptop with an xm 940 first gen i7, after i flashed an unlocked bios i can set any mulitplier for turbo boot, but is not taking any effect. i had install high sierra

ssdtPRGen.sh is not working, i did try to boot with -xpcm generate p c states not helping, clover see the turbo ratio but not appling, any ideeas what to try?

Regards
 
Top