Contribute
Register

[Mavericks Install Guide] Lenovo Thinkpad 510w step by step

Joined
Sep 7, 2013
Messages
13
Motherboard
Toshiba Satellite c55-A5100
CPU
i3-3120 2.5
Graphics
Intel HD 4000
Mac
Classic Mac
Mobile Phone
Hello All,

This is my installation guide / upgrade guide to Maverick on my Lenovo ThinkPad 510W.

Firstly I want to thank the people on this site (and other sites), RehabMan etc for their guidance. I made a few dumb mistakes but after that it seemed good.

Now for my story

I actually have a weird scenario where I ended up doing several machines and I thought I would post about them here.

I am no expert and potentially some things I did you don't have too etc but this is what I did, and I wrote it all down.

Machine = Lenovo Thinkpad 510w
Memory = 16gigs 4x4 Samsung memory
Chipset = Intel (R) 5 Series / 3400 Series Chipset Family
CPU = Intel (R) Core (TM) i7 Q720 1.6hrtz
Ethernet = Intel (R) 82577LM gigabit
Wireless = Intel (R) Centrino (R) Ultimate-N 6300 AGN
Modem = HDA CX20585
Sound = Conexant 20585 Smart Audio HD
DVD = HL-DT-ST DVDRam GT30N
Video = NVidia Quadro FX 880M
Disk = 320gigs ST9320423AS
BIOS = 1.45
Embedded Controller = 1.21
Machine Type Model = 4391BW9

Additional Things:
1. Docking Station (Lenovo)
2. ACER 23 inch external monitor (Supports DVI / HDMI / VGA, but I specifically used VGA)

OS X Version = Mavericks 10.9.2

What does not work:

I figured I'd explain this versus everything that works. And it's possible I don't know TO list it so feel free to ask

1. Sound - I cannot get this working. I've tried to use my P-brain but every link I try and every kext etc fails for me.

What I tried for sound:
-Deleting all Kexts for sounds, fixing permissions, rebooting
-installing VoodooHDA, permissions, reboot (nadda)
-installing the legacy, patched and any other I could find, doing the same thing
(using KextUtility) to Add, Update, Reboot

I could certainly be doing something / missing something so if someone can help here that would be great

2. Wire-less
I did not patch my bio (as I've seen some posts) and I do have like 5 different USB / Wifi Cards but I didn't try any yet... so that's still coming

3. Bluetooth
This actually worked up until Maverick, and then I got the "this isn't compatible, so I'm moving it message". I have not found / looked for a new driver so if someone can post something before I do great.

How it works so far

Booting - Awesome. I updated the boot list so that it would take away from of the flags that caused it issues like i386 (kernel flags) and it boots perfectly and quickly every time. I love it

Video - Amazing. The laptop LCD is running full HD 1920x1080 and I have an external monitor attached, that automatically is getting extended onto, through the VGA port. I didn't even realize this would happen but it is :)

Docking Station - working amazing and thank God I had it because without it, during my install I would have been hosed

Install / Upgrade Process - flawless... I mean honestly it was easy and I really had no issues (minus the things I can't get working)

USB - great (partial issue at the start, which I will explain later), but great now.

Hard Drives - perfectly

Backups - perfectly

Flash drives - some people are having issues with not being able to see flash drives after Maverick. I have that issue on my other laptop, not this one. Works perfectly

Ethernet - perfectly (minus wireless)

Sound - Nope not yet

Keyboards & TouchPad and USB Keyboard / Mice = perfectly

Mouse Button (on keyboard) - does not work, at least not for me. I spent zero time caring or trying to make it work, since the mouse pad works fine (all buttons, above and below it)

Things you need:
Again this is what I did, not what you have to do. I can only vouch for what I did

  • Snow Leopard 10.6.3 CD / DVD (which I bought from the Mac Store). I actually bought a 5 user
  • 2 8 gig memory sticks. You only need 1, I merely had two for my process.
  • USB Mouse / Keyboard (mine were wireless)
  • ******NOTE*****
  • You must be able to create a Maverick USB (Unibeast) or forget it
  • Part of my steps explains how I did this
  • please note though, I had multiple machines to do this with
  • without the secondary machines I would not have been able too
  • ***************
  • External Monitor (VGA)
  • Docking station for Lenovo
  • Unibeast for Maverick
  • Multi-beast for Snow Leopard
  • Multi-beast for Maverick
  • **Maverick Download from App Store
  • iBoot Ivy (yes I used Ivy not legacy) DVD
  • iBoot Legacy (for my other machine)


Step by Step:

Let me start by saying, I didn't have anyone who could make me a Maverick USB stick. So I had to first build out a machine with 10.6.8 Snow Leopard so that I could use Unibeast to do it.

Step 1 - Build out a 10.6.8 machine
  • I used another older laptop, that actually ended up working (and I will document that machine in another thread)
  • Configure 10.6.3 on HP Compaq 8510w
    • Create iBoot Legacy CD
    • Set BIOS to AHCI and Boot CD First (USB second) (HD third)
    • Boot into iBoot
    • At boot, swap in Snow Leopard 10.6.3
    • Hit F5
    • Select that Install CD. I used -v -f ACPI=off ncpi=0x2000
    • use disk utility to create the partitions
    • Install 10.6.3
    • Run Multi-beast for Snow Leopard, do the EASY install and reboot
    • I rebooted and went back into Snow Leopard using the above flags
    • Update to 10.6.8 (don't reboot)
    • run Multi-beast against and update the drivers again using EASY
    • eject the CD and reboot again
    • go back into 10.6.8 (somehow my Ethernet had gone away, so I ran Multi-Beast against from the disk, added the Ethernet driver back) and it came back and I moved on
    • From that point on my Compaq 8510w worked perfectly with 10.6.8 and all patches available from the store
Step 2 - Configure 10.9.2 onto a USB Stick from my Compaq 8510w

  • Download the store bits
  • Download the Unibeast
  • Follow the instructions here http://tonymacx86.blogspot.com/2010/04/iboot-multibeast-install-mac-os-x-on.html
  • **************NOTES**************************
  • This process was extremely painful for me I tried to do this like 4 times
  • and it just never completed. Then finally I said bleh and let it run for 21 hours
  • and it finally finished. This was a frustrating part. I only figured it was still doing something because my flashdrive has a light and the drive available size kept changing, albeit slowly
  • Be patient on this, no matter what the UI tells you
  • and make sure to select Laptop Support. I didn't at first and had to force reboot to stop the process (that had been going for 6 hours) to start again
  • Not fun. This was the ONLY bad part of it all really
  • **********************************************
  • Finally the stick was configured and ready to go

Step 3 - Build out 10.6.3 on my Lenovo ThinkPad 510w

  • **********TROUBLES THAT I HAD************************************
    • Let me first start by saying that I had several issues at first.
    • 1. I didn't realize that the laptop keyboard didn't work (during the install), or that the left side USB ports didn't work, so the only one that did was the rear one
    • My CD player is also flakey so sometimes it fails to read the disk (that was fun)
    • MOUSE Issue: because I was using a USB mouse and I had it plugged into the left side, the installation was giving this stupid looking picture... I was like WTF is that picture. I took a photo and sent to my brother who said, hmmm that looks like a mouse. I was like wtf and he found a thread that yet... it means that the install lost a connection to your mouse. WTF APPLE USE YOUR WORDS lol
    • So I didn't know what to do because the touch pad didn't work either... and if USB didn't then I was hosed
    • Fortunately the back USB was working... so I plugged a mouse in there and was able to get through the install
    • However, I was NOT able to rename the partition so they were called Untitled 1 and 2 lol
    • Now remember the keyboard didn't work, but fortunately I had a docking station, so during the install, I popped it onto the docking station and the USB ports worked there, so whew I had a keyboard and a thumb drive port :)
    • I also used the Ethernet on the Docking station (but the laptop one works fine too)
  • ****************************************************************
  • Build out 10.6.3 on my Lenovo ThinkPad 510w
  • ************ READY FIRST TWO BULLETS BELOW FIRST***********
    • Now you may be thinking, what in the heck are you doing this? Well to be honest I tried to get Maverick to install directly from the USB and honestly I just couldn't get past the black screen. I personally believe, that I could have, as I did later, and I was merely tired and not using the right flags.
    • Once I was using the right ones it worked, so please I do NOT think you need to do this, and you could probably save time by trying at least once before doing this. I did NOT go back and verify this so it would be your 3 minutes of time. If you get past the black screen I assume it will work :)
    • For this I used the iBoot IVY (not normal / legacy)
    • Swapped CD for Snow Leopard 10.6.3 and hit F5
    • I booted and then used -v ACPI=off GraphicsEnabler=No ncpi=0x2000 cpus=1
    • Now maybe you don't need all those, but I used them and it worked so I wasn't gonna try something else
    • I actually created two partitions. Initially I did this because I wanted to have Windows on the other, but I actually ended up using it for backups, which worked great
    • I may still put Windows On it though :)
  • 10.6.3 Finalized
    • Once I had 10.6.3 installed I did the same as with my Compaq
    • I downloaded Multi-beast for Snow Leopard
    • I ran Multi-Beast, did EASY
    • I rebooted
    • I used the same flags to get back into Snow Leopard
    • Did a backup :)

Step 4 - Patched to 10.6.8 (no reboot)

  • Patched with Multi-beast again EASY
  • Multi-beast Other
    • Added USB 3.0 and Keyboard / TouchPad support
    • Bingo worked like a charm
  • When done I took out the CD and rebooted

  • What's working
    • Everything was working minus Sound (I didn't test it sorry) and Wireless. At this point even Bluetooth worked
  • Downloaded Multi-Beast for Maverick onto the disk. I really suggest you do this, don't assume you need / can use the USB or CD etc. Just download it early :)
  • Did a backup

Step 5 - Installing 10.9.2 (booting first)

  • Ok now I have two things: 1) My machine has 10.6.8 and works flawlessly 2) a USB stick with Maverick
  • Now I attempted to boot using the USB Stick. Now remember when I first tried this all I could ever get was a black screen.... SAME.... for like 30 minutes and I thought I would not be able to do it
  • I was tired, so I took a break, had a snack, watched a little TV and then went back to my laptop
  • SUCCESS: flags I used, again maybe you don't need all these but it worked for me
  • -v -x -f GraphicsEnabler=Yes IGPEnabler=No ncpi=0x3000 (yes 3000) ACPI=off
  • Bingo, I was in and the installation started!!

Step 6 - Installing 10.9.2
  • So, I actually had a very weird situation happen to me, I have no idea whether you will or not, but I did
    • I had started the install and it said 1hr 51 minutes
    • It was 2am so I went to bed
    • I got up at 8 and it was back at the boot selection screen. I thought sweet
  • Install had not completed and it started again and said another 7 minutes
  • that completed
  • I got into 10.9.2 using the same flags as I had booted with at first again. Yes I know you probably don't need it or as many, but hey it worked for me so I did it again.
  • I ran Multi-beast and applied EASY + Ethernet + USB 3.0 + Touchpad / Keyboard / PS2 drivers
  • Did a backup
  • Rebooted
Step 7 - Ran updates, did backup, rebooted

Now at this point, it is running great. Again the things that do not work are Sound, Wireless and Bluetooth.

If anyone has thoughts on those (kext for sound + steps that actually work woot, same for Bluetooth)

I hope this helps, if for no other reason it shows that Compaq 8510w is easy to do for 10.6.8, and Thinkpad 510w easily runs 10.6.3/.6/10.9.2

Thanks,
-Michael
 
Joined
Sep 7, 2013
Messages
13
Motherboard
Toshiba Satellite c55-A5100
CPU
i3-3120 2.5
Graphics
Intel HD 4000
Mac
Classic Mac
Mobile Phone
Sound Update: Its Working!!

I was able to get the sound working. I tried over and over different kexts etc for Conextant with no avail.

And I tried VoodooHDA but clearly I was doing something wrong so...

1. I went in and deleted all HDA sound files (for sure this time)
2. Fixed permissions
3. Installed VoodooHDA 2.8.4 from Multi-Beast
-Received an Error that it did NOT install correctly
4. I ran KextUtil to fix permissions
5. Re-ran Multi-Beast again and installed VoodooHDA 2.8.4 again
This time no error
6. Ran kextutil again to fix permissions

rebooted

BINGO :) The headphone jack, the internal speakers, the mute / unmute works. I didn't try the MIC, however it is specifically listed as available for input so I am hopeful.

Anyhoo, that only leaves Bluetooth and Wireless not working (oh and card reader... but honestly I don't care about that or the modem)

Cheers,
-Michael
 
Top