Contribute
Register

Maverick INTEL DX79SR guide step by step

Joined
Jul 28, 2013
Messages
16
Motherboard
INTEL
CPU
2,99 GHz Quad-Core Intel Core i5
Graphics
Radeon RX 580 4 GB
After one week of trying, I finally successfully installed a fully working OSX Maverick on my Hackintosh.

Thanks for the help to other members of the forum.

To help the community, I am posting my step by step guide.
Install time (without the unibeast preparation) aprox. 35min

Tech. spec.:
Motherboard INTEL DX79SR, CPU 8 core Xeon, system disk SSD 180 GB, 32 GB RAM, two NVIDIA cards GTX650

1) First boot with unibeast: -v npci=0x2000 dart=0 cpus=1

It can happen that the installation of Maverick could seem to be not responding, don't worry be patient.
If you have problems to start the installation (the install window is not responding, try not to touch the mouse and just press enter). Sometimes can also happen that the machine reboots 4 or 5 times. Just don't give up and again write the verbose syntax as stated (again and again).

2) After Maverick installation, you should restart the machine.
Boot with unibeast with the same syntax but choose then the new system disk with the fresh Maverick on it. If the boot stops (is not responding) try then -v npci=0x2000 dart=0 (without cpus=1) that helped me in my case.

3) Maverick should startup and the main installation should be OK / working.

4) AUDIO / USB / ETHERNET was not working, be patient, thats the Multibeast job, so now lets use Multibeast

5) Install ONLY bootloader chimera 2.2.1 NOTHING ELSE!…reboot without using unibeast now

6) During boot screen press any key and again write -v npci=0x2000 dart=0 cpus=1
If problems occur, boot again without cpus=1

7) If Maverick boots up, it means that you machine is working and almost ready

8) Start Multibeast again and install ONLY audio Realtek ALC892 non DSDT / ethernet (latest intel version) / USB 3.0 universal and voodooTSCsync according to your CPU - in my case: 8 core
DONT INSTALL anything else! (after the last multi beast installation, on boot there is no need anymore to use cpus=1 since voodoo kicks in.

P.S. this procedure I did it one step at the time just in case, but since I tried and all worked, all above instructions for Multibeast you can do it in one take.

9) Reboot and use -v npci=0x2000 dart=0

10) LAST step Chameleon wizard: I just changed the MACPRO info to MAC PRO 6.1 LGA2011 and changed the boot theme (any choice based on your taste)
IMPORTANT: Chameleon wizard is useful so that you don't have to manually on each boot write the syntax "-v npci=0x2000 dart=0"
So this is my screenshot of the chameleon wizard settings:
Chameleon.jpg

Save the settings and reboot.
The setup is finished.

P.S.
Just to mention something else. Could be useful for people who are migrating from mountain lion.

I had a backup clone HDD DISK IMAGE of my precious Mountain Lion 10.8.4 with all of my hard work and programs. The disk had no boot loader or any other settings (hack kexts).
So, my above step by step guide was also safe in this case since I installed Maverick on that particular HDD all of my programs and settings and files were INTACT and after the upgrade process everything works!
 
Joined
Apr 2, 2011
Messages
5
Motherboard
Gigabyte GA-EP45T-DS3R
CPU
Q9650
Graphics
GT 9500 / GT 9600
Mac
  1. Mac Pro
I have the same motherboard with cpu 3970X and how you set the BIOS? I do not quite understand the new motherboard because even use LGA775!
 
Joined
Jul 28, 2013
Messages
16
Motherboard
INTEL
CPU
2,99 GHz Quad-Core Intel Core i5
Graphics
Radeon RX 580 4 GB
Could you be more specific or clear.don't understand you.
Be advised that this forum is not meant for people who don't have an advanced understanding off hacking osx
 
Joined
Apr 2, 2011
Messages
5
Motherboard
Gigabyte GA-EP45T-DS3R
CPU
Q9650
Graphics
GT 9500 / GT 9600
Mac
  1. Mac Pro
Thank you brow! I installed OS X 10.10 with Clover!
 
Joined
Sep 1, 2014
Messages
1
Motherboard
Intel DX79SR
CPU
i7-3930K
Graphics
GTX 760
Mobile Phone
  1. iOS
Thanks for the post, it help me with Yosemite 10.10.4. My system is running for the most part, except iMessage and power managment. My CPU cores are stuck at 3200Mhz all the time. Were you able to properly set you speedstep on your dx79SR/i7-3920k? Thank you.
 
Joined
Feb 24, 2013
Messages
1
Motherboard
GA-X79-UD3
CPU
i7 3820
Graphics
Nvidia GT 630
Mac
Classic Mac
Mobile Phone
  1. iOS
Hello, been trying to install maverick with this setup but I cant seem to get into the install screen. I used the boot flags listed here, but, as soon I hit enter, the screen goes black, and i dont' see it go into verbose mode. I also noticed the HDD light flashes for a bit, and then stops flashing. Is there something I might be missing with the bios setup? I'm on a DX79SR with 3820. Maybe someone on here can point me to the right direction to get this working.
 
Joined
Jul 28, 2013
Messages
16
Motherboard
INTEL
CPU
2,99 GHz Quad-Core Intel Core i5
Graphics
Radeon RX 580 4 GB
Hello, been trying to install maverick with this setup but I cant seem to get into the install screen. I used the boot flags listed here, but, as soon I hit enter, the screen goes black, and i dont' see it go into verbose mode. I also noticed the HDD light flashes for a bit, and then stops flashing. Is there something I might be missing with the bios setup? I'm on a DX79SR with 3820. Maybe someone on here can point me to the right direction to get this working.


IF something is not working during installation its because (maybe) you have a different graphic card.
Try to use bootflag: GraphicsEnabler=Yes or if its not working then "No"
 
Top