Contribute
Register

Maverick - Can't load kext on normal boot and System notice kext error

Status
Not open for further replies.
Joined
Dec 14, 2013
Messages
11
Motherboard
Asus K53SV
CPU
Core I5 2430M
Graphics
Optimus Intel HD3000 and NVidia Gefore GT 540M
Mac
Classic Mac
Mobile Phone
First of all, I want to show my appreciation for tonymacx86 as well as hackintosh community for the guides and tools that helped me successfully installed Maverick on my Asus laptop. However, there's still some minor things that need to be fixed before it can function properly.

First, I have to boot with -x flag in order to let wifi work. While I tried with -v flag, I saw that there's error occur and kexts could not be loaded. Please refer attached file for detail information.

Second, Maverick sometimes show message inform that my wifi kexts has been installed improperly and need to be reinstall even though wifi still working properly (I wonder whether this has anything related to the first problem?). I got my wifi kext from http://www.osx86.net/files/file/1550-ar9285-ar5b195-ar9002wb-pcie-wireless-half-size/

Once again, thank you so much and please pardon for my bad English

IMG_1279.jpg
 
Joined
Dec 14, 2013
Messages
11
Motherboard
Asus K53SV
CPU
Core I5 2430M
Graphics
Optimus Intel HD3000 and NVidia Gefore GT 540M
Mac
Classic Mac
Mobile Phone
Please help me. I don't know how to fix boot issue
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,103
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
First of all, I want to show my appreciation for tonymacx86 as well as hackintosh community for the guides and tools that helped me successfully installed Maverick on my Asus laptop. However, there's still some minor things that need to be fixed before it can function properly.

First, I have to boot with -x flag in order to let wifi work. While I tried with -v flag, I saw that there's error occur and kexts could not be loaded. Please refer attached file for detail information.

Second, Maverick sometimes show message inform that my wifi kexts has been installed improperly and need to be reinstall even though wifi still working properly (I wonder whether this has anything related to the first problem?). I got my wifi kext from http://www.osx86.net/files/file/1550-ar9285-ar5b195-ar9002wb-pcie-wireless-half-size/

Once again, thank you so much and please pardon for my bad English

View attachment 76941

For AR9285 there is no need to install a patched kext. See here: http://www.tonymacx86.com/network/104850-guide-airport-pcie-half-mini-v2.html

Easiest way is to use the "enabler kext", toledaARPT.kext.
 
Joined
Dec 14, 2013
Messages
11
Motherboard
Asus K53SV
CPU
Core I5 2430M
Graphics
Optimus Intel HD3000 and NVidia Gefore GT 540M
Mac
Classic Mac
Mobile Phone
Joined
Dec 14, 2013
Messages
11
Motherboard
Asus K53SV
CPU
Core I5 2430M
Graphics
Optimus Intel HD3000 and NVidia Gefore GT 540M
Mac
Classic Mac
Mobile Phone
I fixed the kext error issue, now only boot problem left. My conclusion is that there's some corrupted kexts that can be read and make the system skip reading kexts. So please suggest me which should I try to figured out which kexts cause the problem
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,103
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I fixed the kext error issue, now only boot problem left. My conclusion is that there's some corrupted kexts that can be read and make the system skip reading kexts. So please suggest me which should I try to figured out which kexts cause the problem

Boot "-v" to diagnose. But if you're replaced your system kexts unnecessarily, you should do a fresh install, so you know what you have. Trying to fix a damaged system is pointless...
 
Joined
Dec 14, 2013
Messages
11
Motherboard
Asus K53SV
CPU
Core I5 2430M
Graphics
Optimus Intel HD3000 and NVidia Gefore GT 540M
Mac
Classic Mac
Mobile Phone
Boot "-v" to diagnose. But if you're replaced your system kexts unnecessarily, you should do a fresh install, so you know what you have. Trying to fix a damaged system is pointless...

I just diagnosed with "-v" flag more carefully and find out some more clues, I will try to make it as clarified as possible.

I can't boot into Maverick without "-v" or "-x" flag

If I boot with "-x" flag, I can boot into Maverick but sound and spotlight won't work (I can understand that sound won't work because of VoodooHDA kext hasn't been loaded with "-x" mode, but still don't know why spotlight doesn't work)

If I boot with "-v" flag, some time I can boot into Maverick, but most of the time I can't. And here come the clues that I found. When I can't boot into Maverick, these console messages show up instead of the login screen IMG_1287.jpgIMG_1288.jpg.

When I shut down, there're also error messages. I tried shut down several times and there's 2 difference messages which will be showed below

1: IMG_1295.jpgIMG_1296.jpg
2: IMG_1302.jpgIMG_1303.jpg

That's all I know for now. I want to attach my kext here but it too big
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,103
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I just diagnosed with "-v" flag more carefully and find out some more clues, I will try to make it as clarified as possible.

I can't boot into Maverick without "-v" or "-x" flag

If I boot with "-x" flag, I can boot into Maverick but sound and spotlight won't work (I can understand that sound won't work because of VoodooHDA kext hasn't been loaded with "-x" mode, but still don't know why spotlight doesn't work)

If I boot with "-v" flag, some time I can boot into Maverick, but most of the time I can't. And here come the clues that I found. When I can't boot into Maverick, these console messages show up instead of the login screen View attachment 77066View attachment 77067.

When I shut down, there're also error messages. I tried shut down several times and there's 2 difference messages which will be showed below

1: View attachment 77068View attachment 77069
2: View attachment 77070View attachment 77071

That's all I know for now. I want to attach my kext here but it too big

Your issue is not related to bluetooth. Likely a graphics problem...
 
Joined
Dec 14, 2013
Messages
11
Motherboard
Asus K53SV
CPU
Core I5 2430M
Graphics
Optimus Intel HD3000 and NVidia Gefore GT 540M
Mac
Classic Mac
Mobile Phone
I have IntelHD3000 and NVDA 5400M, and have kext for both. So should I remove NVDA kexts?

These're kexts which are loaded by my Hackintosh Screen Shot 2013-12-19 at 0.14.20.jpg
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,103
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I have IntelHD3000 and NVDA 5400M, and have kext for both. So should I remove NVDA kexts?

These're kexts which are loaded by my Hackintosh View attachment 77073

If you have both (Optimus... not supported) then you should remove the nvidia kexts (NVDA*, GeForce*). There is no reason to install anything for HD3000... it is natively supported.
 
Status
Not open for further replies.
Top