Contribute
Register

Matebook 13 boot every two attempts

Joined
Oct 16, 2018
Messages
80
Motherboard
Lenovo v330--15IKB 81AX
CPU
i5 8250U
Graphics
UHD 620
Well, no need to use the Fake ALS SSDT you have there. ALS = Ambient Light Sensor.
?
Removed SSDT-ALS0.aml from ACPI folder and the bootflag "keepsyms=1" but problem is still there.
I cannot reproduce kernel panic
What about my last question, about your reboots?
If you mean panic log, you can find in the old post of this thread, situation is still the same

The panics come only when i shut down and reboot a lot of times by button and very rarely.

BIG NEWS: Audio also work sometimes yes and sometimes not, but the most important thing that i've noticed, is that pc do not reboot, because if i wait the boot time and then i click some buttons and then "Enter" i can hear the sound of wrong password(with black screen). So i think there is not related to a memory error, but with error on graphical and audio. I use matebook x config.plist with some correction, maybe the error is there, but i have no competencies to find it


nb: i've tried to catch the lines before the screen goes black, but are to fast even for screenshot of a video. Will try to catch it.
EDIT: catched the rows before screen goes black(attached), scuse me is if not perfecly readable, but it's so hard to catch it.
 

Attachments

Last edited:
Joined
Apr 21, 2016
Messages
1,342
Motherboard
ASUS X556UA-Clover
CPU
i5-6200U
Graphics
HD 520,1366x768
Mobile Phone
iOS
Removed SSDT-ALS0.aml from ACPI folder and the bootflag "keepsyms=1" but problem is still there.
I cannot reproduce kernel panic

If you mean panic log, you can find in the old post of this thread, situation is still the same

The panics come only when i shut down and reboot a lot of times by button and very rarely.

BIG NEWS: Audio also work sometimes yes and sometimes not, but the most important thing that i've noticed, is that pc do not reboot, because if i wait the boot time and then i click some buttons and then "Enter" i can hear the sound of wrong password(with black screen). So i think there is not related to a memory error, but with error on graphical and audio. I use matebook x config.plist with some correction, maybe the error is there, but i have no competencies to find it


nb: i've tried to catch the lines before the screen goes black, but are to fast even for screenshot of a video. Will try to catch it.
EDIT: catched the rows before screen goes black(attached), scuse me is if not perfecly readable, but it's so hard to catch it.
Once you make changes, it's usually best to attach a new troubleshooting archive.

The latest archive you uploaded has 18 panic logs from the same day (July 17, yesterday).

So you don't have the 'Boot every 2 attempts' issue?
Can you describe everything that's wrong again, clearly? :)
 
Joined
Oct 16, 2018
Messages
80
Motherboard
Lenovo v330--15IKB 81AX
CPU
i5 8250U
Graphics
UHD 620
Once you make changes, it's usually best to attach a new troubleshooting archive.

The latest archive you uploaded has 18 panic logs from the same day (July 17, yesterday).

So you don't have the 'Boot every 2 attempts' issue?
Can you describe everything that's wrong again, clearly? :)
The system sometimes it boots fine, sometimes it boot but after some second screen become black(i can hear sound), and sometimes it reboot after some second. I cant describe more clearly than this, the situation itself is a mess.
new log attached
 

Attachments

Joined
Apr 21, 2016
Messages
1,342
Motherboard
ASUS X556UA-Clover
CPU
i5-6200U
Graphics
HD 520,1366x768
Mobile Phone
iOS
The system sometimes it boots fine, sometimes it boot but after some second screen become black(i can hear sound), and sometimes it reboot after some second. I cant describe more clearly than this, the situation itself is a mess.
new log attached
Some notes about your config.plist:
All of your DSDT 'fixes' can probably be removed - FixHPET, FixIPIC, FixRTC and FixTMR.
FixHeaders can help when enabled.
To have a proper power management you should enable PluginType injection.
What's that "ACPI Patch" find/replace pattern?

Is there a reason you disable your I2C1 controller? Letting VoodooI2C load under it should be just fine...
Remove the I2C1._STA -> I2C1.XSTA rename and the I2C1 disabler SSDT.

Disable AppleIntelCPUPM within KernelAndKextPatches.

Kexts:
You should only have *necessary* kexts in Clover. Once you must have to boot. Audio is not necessary, you have 3 audio-related kexts there. Does HoRNDIS even work via Clover?
As you don't have Broadcom hardware, you don't need AirportBrcmFixup.kext nor FakePCIID_Broadcom_WiFi.kext.

There are 13 panics from today (July 18). Can you try removing VoodooI2C just for testing and see if those issues persist? First follow everything mentioned above, then try it (Unless those changes already fix that).
 
Joined
Oct 16, 2018
Messages
80
Motherboard
Lenovo v330--15IKB 81AX
CPU
i5 8250U
Graphics
UHD 620
Some notes about your config.plist:
All of your DSDT 'fixes' can probably be removed - FixHPET, FixIPIC, FixRTC and FixTMR.
What's that "ACPI Patch" find/replace pattern?
Disable AppleIntelCPUPM within KernelAndKextPatches.
Removed "AppleIntelCPUPM" and relatives "KernelAndKextPatches". Removed DTDT fixies, except for "FixHPET"(won't boot without it). I don't know what the ACPI patch find/replace do, but if I remove it, os won't boot.

FixHeaders can help when enabled.
To have a proper power management you should enable PluginType injection.
Enabled both

Is there a reason you disable your I2C1 controller? Letting VoodooI2C load under it should be just fine...
Remove the I2C1._STA -> I2C1.XSTA rename and the I2C1 disabler SSDT.
I have no idea, but removing won't change anything, so I removed to make all more clean

Kexts:
You should only have *necessary* kexts in Clover. Once you must have to boot. Audio is not necessary, you have 3 audio-related kexts there. Does HoRNDIS even work via Clover?
As you don't have Broadcom hardware, you don't need AirportBrcmFixup.kext nor FakePCIID_Broadcom_WiFi.kext.
Removed audio kext in clover, and remove Broadcom kext from both clover and Library/Extensions(I have no wifi card Broadcom), I don't need HoRNDIS, removed from clover for now

There are 13 panics from today (July 18). Can you try removing VoodooI2C just for testing and see if those issues persist? First follow everything mentioned above, then try it (Unless those changes already fix that).
Can't be the reason because I had the problem also before I've installed that kext.

Problem stil here, error log attached, many thanks for your time and knowledge.
 

Attachments

Joined
Apr 21, 2016
Messages
1,342
Motherboard
ASUS X556UA-Clover
CPU
i5-6200U
Graphics
HD 520,1366x768
Mobile Phone
iOS
Removed "AppleIntelCPUPM" and relatives "KernelAndKextPatches". Removed DTDT fixies, except for "FixHPET"(won't boot without it). I don't know what the ACPI patch find/replace do, but if I remove it, os won't boot.


Enabled both


I have no idea, but removing won't change anything, so I removed to make all more clean


Removed audio kext in clover, and remove Broadcom kext from both clover and Library/Extensions(I have no wifi card Broadcom), I don't need HoRNDIS, removed from clover for now


Can't be the reason because I had the problem also before I've installed that kext.

Problem stil here, error log attached, many thanks for your time and knowledge.
There are more and more panic logs caused by VoodooGPIO during boot (Last panic is after 4.1sec uptime) there. Please verify anyway, try removing VoodooI2C and rebuilding your kextcache.
 
Joined
Oct 16, 2018
Messages
80
Motherboard
Lenovo v330--15IKB 81AX
CPU
i5 8250U
Graphics
UHD 620
There are more and more panic logs caused by VoodooGPIO during boot (Last panic is after 4.1sec uptime) there. Please verify anyway, try removing VoodooI2C and rebuilding your kextcache.
Done, seems that boot fails are reduced, but are still here(and I have no trackpad working :cry:)
In the error log the first crash was happened this morning when I've turn on the first time the laptop. Then I've tried to shutdown and reboot, and in 8 attempts, 3 was fail.

nb: I've found the ACPI folder in a Chinese repository, it's a little messed, it's possible that the problem are referred to that?
 

Attachments

Joined
Apr 21, 2016
Messages
1,342
Motherboard
ASUS X556UA-Clover
CPU
i5-6200U
Graphics
HD 520,1366x768
Mobile Phone
iOS
Done, seems that boot fails are reduced, but are still here(and I have no trackpad working :cry:)
In the error log the first crash was happened this morning when I've turn on the first time the laptop. Then I've tried to shutdown and reboot, and in 8 attempts, 3 was fail.

nb: I've found the ACPI folder in a Chinese repository, it's a little messed, it's possible that the problem are referred to that?
Removing VoodooI2C was just for testing. I don't expect you to simply not use it.

SSDT-XCPM-SBpr00 can be removed when injecting PluginType via Clover.
You still have the I2C1 disabler SSDT, you should've removed it.

Using someone else's setup isn't always a good idea. It must be reliable and stable...
If you can't trust the source, it's better to do everything yourself and consult that source.

Look over your setup, investigate every part of it. If you don't know what something does, do some research and see if you actually need it. Not too sure about some renames/SSDTs you have there...
 
Joined
Oct 16, 2018
Messages
80
Motherboard
Lenovo v330--15IKB 81AX
CPU
i5 8250U
Graphics
UHD 620
Removing VoodooI2C was just for testing. I don't expect you to simply not use it.
Ok
SSDT-XCPM-SBpr00 can be removed when injecting PluginType via Clover.
You still have the I2C1 disabler SSDT, you should've removed it.
Both removed

Using someone else's setup isn't always a good idea. It must be reliable and stable...
If you can't trust the source, it's better to do everything yourself and consult that source.

Look over your setup, investigate every part of it. If you don't know what something does, do some research and see if you actually need it. Not too sure about some renames/SSDTs you have there...
What do you mean renames/SSDTs? Config or acpi folder? I will try my best using Google lol, I have no knowledge to generate a DSDT event with a guide it's to hard for me :(

NB:Seems solved by removing GFX0 to IGPU 47465830 49475055
Attached new error log to see if panics was gone

I don't know how to say thanks, you're a very good one!
 

Attachments

Last edited:
Joined
Apr 21, 2016
Messages
1,342
Motherboard
ASUS X556UA-Clover
CPU
i5-6200U
Graphics
HD 520,1366x768
Mobile Phone
iOS
What do you mean renames/SSDTs? Config or acpi folder? I will try my best using Google lol, I have no knowledge to generate a DSDT event with a guide it's to hard for me :(
I mean both.

NB:Seems solved by removing GFX0 to IGPU 47465830 49475055
Attached new error log to see if panics was gone
Interesting. WhateverGreen handles this rename so it is possible to remove from config.plist.
Remove your SSDT-PNLF-COFFEELAKE, get it from here:
Do not disable _OSI -> XOSI rename. It's an important fix (combined with SSDT-XOSI you have). Some features, usually I2C/USB won't work without it.

I don't know how to say thanks, you're a very good one!
Happy to help :)
 
Top