Contribute
Register

Manual sleep working, but system awakens itself - 10.6.6

Status
Not open for further replies.
Joined
Feb 17, 2011
Messages
12
Motherboard
GIGABYTE GA-P55A-UD3 INTEL P55 I5/I7 DDR3 PCI-E LGA1156 USB3 ATX
CPU
Core i7-870 2.93 GHz, Socket 1156
Graphics
XFX HD-585X-ZNFV ATI Radeon HD 5850 1GB 256-bit GDDR5 PCI Express 2.0 x16 DX1
Mac
  1. iMac
  2. MacBook
Classic Mac
  1. 128K
  2. 512K
  3. Classic
  4. iBook
  5. Power Mac
  6. PowerBook
Mobile Phone
  1. iOS
After a period of flawless sleep/wake management on my GA-P55A-UD3 v2.0 (BIOS F11) running 10.6.6 I started getting a variety of sleep/wake problems on the machine. Through systematic troubleshooting I now have the system in a state where I can reliably force sleep it repeatedly and manually waken it with screen, DVD drive and USB hubs restored. The system doesn't sleep automatically and I could live with this except something is making it wake from forced sleep after a period of time (at least 5 minutes). I tried disabling "Wake for Ethernet Network Access" in Energy Saver but that had no effect (unless changing that setting requires a restart to take effect?).

The most recent change was to manually remove the PXHCD.kext (provides USB3.0 functionality). Before this, the system was, I think, waking on it's own but not waking the monitor - requiring a restart.

The change I made before that was to boot the system in 32bit mode. This was because I saw a number of reports in the Console log of kexts that were incompatible with 64bit arch. This has snuffed half my RAM so I'll try again with 64 now that the PXHCD.kext fix has done something.

The Hack's hibernate mode is set to "0" (i.e. suspend to RAM). Settings as follows:

BIOS
Power Management Set-up
---------------------------------
ACPI Suspend Type: S3(STR)
Soft-off by PWR-BUTTON: Instant-Off
PME Event Wake Up: Enabled
Power on by Ring: Enabled
Resume By Alarm: Disabled
HPET Support: Enabled
HPET Mode: 64-bit mode
Power on by mouse: Disabled
Power on by keyboard: Disabled
AC Back Function: Soft-Off
ErP Support: Disabled


Integrated Peripherals
---------------------------------
eXtreme Hard Drive: Disabled
PCH SATA Control Mode: AHCI
SATA Port0-3 Native Mode: Enabled
USB Controllers: Enabled
USB Legacy Function: Enabled
USB Storage Function: Enabled
Turbo SATA3: Auto
Azalia Codec: Auto
Onboard H/W LAN: Enabled
Green LAN: Disabled
Onboard LAN Boot ROM: Disabled
Onboard USB3.0 Controller: Enabled <-- A previous fix to restore screen after wake
Onboard IDE Controller: Enabled
GSATA Controller: Enabled
GSATA Ctrl Mode: AHCI
SATA3 RAID Config: -
...

MultiBeast 3.8.0 (Used when sleep/wake was working properly so continued to use)
[Following options checked]
UserDSDT Install (using "DSDT-GA-P55A-UD3-2.0-F11.aml" from DSDT database)
System Utilities
Drivers/Kexts/Audio/Realtek ALC8xx
Drivers/Kexts/Disk/IOAHCIBlockStorageInjector
Drivers/Kexts/Graphics/ATI Injectors.../ATI 48xx Patch for 10.6.6
Drivers/Network/Lnx2Mac's...
Customisation/Boot Options/32-bit Apple Boot Screen

Follow-ups

Removed PXHCD.kext (provides USB3.0 funcitonality) from "/System/Library/Extensions/", ran Kext Utility, Repaired Disk Permissions, restarted.

If anyone with similar hardware has encountered this problem or has some pointers I'd really appreciate hearing from you. I've avoided trying SleepEnabler kexts because a) sleep seems to work when manually triggered, b) they shouldn't be necessary using this DSDT file and c) many users report kernel panics when applying them - particularly to Gigabyte MBs.
 
Joined
Dec 24, 2011
Messages
31
Motherboard
Mac OS X Lion
CPU
Ivy Bridge
Graphics
CPU graphic
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
Mobile Phone
  1. Other
I am also working to get auto-sleep on my machine. The only flaw is my C910 usb webcam mic not working after waking up . I need to restart my machine. I use sleepwatcher and plist file.

Did you check what is the reason of your system wakeup in Console?
As far as I know, RTC Alarm for wake reason means you have some schedule tasks. In Os x Lion, I take a look at the plist files from /Library/LaunchDaemons/,/Library/LaunchAgents/, ~/Library/LaunchAgents/ . I think it is same for SL. You might need to open each plist file and check any one of them has 3000 sec StartInterval. Maybe you installed one program and it checks update every 5 min on demand. Hope it helps you.

For reading launchd plist, you can also use Lingon 2.2 (paid app) or just for READING, you can use Lingon 2.1 (free version) http://sourceforge.net/projects/lingon/ ... gon/2.1.1/
The free version is good for reading but not safe for editing.

For auto-sleep, you can try pleasesleep app or sleepwatcher. Pleasesleep won't care whether you are watching movies or not. It forces the machine down. So I use sleepwatcher.
 

Going Bald

Moderator
Joined
Aug 14, 2010
Messages
23,309
Motherboard
GA-X58A-UD7-F7
CPU
W3670
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. Android
Put it to sleep and watch the MultiDrive carefully - does the light come on just before system wakeup? If it is, put a disc in the drive when you want to sleep it.
 
Joined
Feb 17, 2011
Messages
12
Motherboard
GIGABYTE GA-P55A-UD3 INTEL P55 I5/I7 DDR3 PCI-E LGA1156 USB3 ATX
CPU
Core i7-870 2.93 GHz, Socket 1156
Graphics
XFX HD-585X-ZNFV ATI Radeon HD 5850 1GB 256-bit GDDR5 PCI Express 2.0 x16 DX1
Mac
  1. iMac
  2. MacBook
Classic Mac
  1. 128K
  2. 512K
  3. Classic
  4. iBook
  5. Power Mac
  6. PowerBook
Mobile Phone
  1. iOS
As far as I know, RTC Alarm for wake reason means you have some schedule tasks. In Os x Lion, I take a look at the plist files from /Library/LaunchDaemons/,/Library/LaunchAgents/, ~/Library/LaunchAgents/ . I think it is same for SL

Useful tips thanks. I can see about 4-5 processes in there. I run a scheduled network back-up service so I disabled that and installed PleaseSleep. The system auto slept successfully. I left it overnight and woke it this morning. Disks and fans spun up and the screen came on but it was completely grey. USB devices did not re-register. I haven't observed either of these symptoms when manually sleeping the machine and wakening it.

I reviewed the System log and see that the machine woke repeatedly every two hours or so through the night. Here's a snippet of one sleep wake cycle:


23/01/12 10:12:38 PM kernel System Sleep
24/01/12 12:12:35 AM kernel Wake reason = RTC
24/01/12 12:12:35 AM kernel RTC: maintenance alarm 2012/1/23 11:12:34, sleep 2012/1/23 09:12:38
24/01/12 12:12:35 AM kernel System Wake
24/01/12 12:12:35 AM kernel vmmon: powerStateDidChange flags=0x82 (state 4)
24/01/12 12:12:35 AM kernel IONetworkController::enable
24/01/12 12:12:36 AM kernel USBF: 32190.738 [0xba89e00] The IOUSBFamily is having trouble enumerating a USB device that has been plugged in. It will keep retrying. (Port 1 of Hub at 0x5a000000)
24/01/12 12:12:43 AM configd[16] setting hostname to "XXXX-Mac-Pro.local"
24/01/12 12:12:43 AM Apple80211 framework[200] ACInterfaceGetPower called with NULL interface
24/01/12 12:12:43 AM Apple80211 framework[200] ACInterfaceGetPower called with NULL interface
24/01/12 12:12:44 AM sudo[1508] root : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/usr/bin/killall Scutum
24/01/12 12:12:44 AM com.apple.SystemStarter[27] No matching processes were found
24/01/12 12:12:49 AM sudo[1512] root : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/usr/bin/killall Scutum
24/01/12 12:12:49 AM com.apple.SystemStarter[27] No matching processes were found
24/01/12 12:12:50 AM sudo[1515] root : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/Applications/Ralink Wireless Utility/Scutum -Dralink -ien1 -c/Applications/Ralink Wireless Utility/Security.conf
24/01/12 12:12:52 AM kernel IONetworkController::disable
24/01/12 12:12:52 AM kernel Saitek X45 Flight Control Stick ::terminate(kIOServiceSynchronous) timeout
24/01/12 12:12:53 AM ntpd[22] sendto(17.82.253.7) (fd=24): No route to host
24/01/12 12:12:55 AM kernel vmmon: powerStateDidChange flags=0x4 (state 2)
24/01/12 12:12:55 AM kernel System Sleep
...

Put it to sleep and watch the MultiDrive carefully - does the light come on just before system wakeup? If it is, put a disc in the drive when you want to sleep it.

Once I've worked out what's generating that 2 hour cycle and can change it for testing purposes I'll give this a try. One problem I was having, which deleting the PXHCD.kext seems to have fixed, was loss of the DVD drive on wake until a new POST was issued to the MoBo.

I'll be happy if I can get it to a state where I can force sleep it and keep it sleeping until I'm ready to use it again then restore with all hubs/peripherals active.
 
Joined
Feb 17, 2011
Messages
12
Motherboard
GIGABYTE GA-P55A-UD3 INTEL P55 I5/I7 DDR3 PCI-E LGA1156 USB3 ATX
CPU
Core i7-870 2.93 GHz, Socket 1156
Graphics
XFX HD-585X-ZNFV ATI Radeon HD 5850 1GB 256-bit GDDR5 PCI Express 2.0 x16 DX1
Mac
  1. iMac
  2. MacBook
Classic Mac
  1. 128K
  2. 512K
  3. Classic
  4. iBook
  5. Power Mac
  6. PowerBook
Mobile Phone
  1. iOS
Ah ha, good sleuthing! That looks like the culprit. I'll have to try the commands on that blog post. I turned off the Wake on Network in the Energy Saver prefs in earlier tests (and some other options) and got a kernel panic when booting the machine fresh - so not sure that's the way forward.
:banghead: :crazy:
 
Joined
Feb 17, 2011
Messages
12
Motherboard
GIGABYTE GA-P55A-UD3 INTEL P55 I5/I7 DDR3 PCI-E LGA1156 USB3 ATX
CPU
Core i7-870 2.93 GHz, Socket 1156
Graphics
XFX HD-585X-ZNFV ATI Radeon HD 5850 1GB 256-bit GDDR5 PCI Express 2.0 x16 DX1
Mac
  1. iMac
  2. MacBook
Classic Mac
  1. 128K
  2. 512K
  3. Classic
  4. iBook
  5. Power Mac
  6. PowerBook
Mobile Phone
  1. iOS
I think every 2 hr RTC Alarm might be "Wake for NetWork Access" . Have you turn it on in Energy Saver Setting?

Success! Turned off "Wake on Ethernet", force slept the machine and returned to it this morning and woke it successfully with all peripherals sparked. The logs showed no wake activity since I put it to sleep so all good.

Probably means I can't trust it to auto-sleep but that's no biggie. Now just have to see if I can retain this behaviour switching the boot options back to 64-bit.
 
Status
Not open for further replies.
Top