Contribute
Register

ManHands' Haswell Build: i7-4770K - GA-Z87X-UD5H - 32GB RAM - GTX 760

Status
Not open for further replies.
Joined
Jul 1, 2013
Messages
77
Motherboard
GA-Z87X-UD5H Rev 1.0 16GB Kingston Hyper-X grey
CPU
Intel i7 4790k
Graphics
GTX970
skirk08's Haswell Build: i7-4770K - GA-Z87X-UD5H - 32GB RAM - GTX 760

Yes, however your SSDT.aml P-state table doesn't match your CPU now. Do me a favor and search 'XCPM' in the Console. I'm guessing you'll get a P-state table mismatch error. I don't know the severity of this, but I'm guessing it's not good for power management if your P-state table and CPU states don't match.

You were right! :thumbup:

So I re-ran the script and here are the search results before rerunning script at 21:44 and after rebooting with the new SSDT created with -turbo 4600 at 21:53.


15/07/2014 21:44:56.000 kernel[0]: XCPM: P-state table mismatch (error:0x12)
15/07/2014 21:44:56.000 kernel[0]: X86PlatformShim::sendPStates - pmCPUControl (XCPMIO_SETPSTATETABLE) returned 0x12
15/07/2014 21:53:04.000 kernel[0]: XCPM: registered
15/07/2014 21:53:04.000 kernel[0]: IOPPF: XCPM mode

I'll create a few different ssdt's at higher speeds when I need them and file the lower maximum clock ones away should I need them at a later date!

Thank you! Nice catch!
 
Joined
Nov 9, 2011
Messages
211
Motherboard
Gigabyte Z390 Aorus Master
CPU
i9-9900K
Graphics
Vega 56
Mobile Phone
  1. Android
  2. iOS
skirk08's Haswell Build: i7-4770K - GA-Z87X-UD5H - 32GB RAM - GTX 760

Thank you! Nice catch!

You bet. Curious, Gigabyte is now showing the F10c beta bios on their website now. I know you didn't want to earlier, but have you thought about flashing this to see if it handles the 4790K any better?

I did flash it on mine playing around with a few things over the past month, and you can easily go back to F9 if need be. I got it from the TweakTown forum. But now that it's hosted on the Gigabyte site, any change of mind?

I'm so stable right now, I don't want to screw anything up by swapping out CPUs. But, the itch is killing me to get the 4790K...
 
Joined
Jul 1, 2013
Messages
77
Motherboard
GA-Z87X-UD5H Rev 1.0 16GB Kingston Hyper-X grey
CPU
Intel i7 4790k
Graphics
GTX970
skirk08's Haswell Build: i7-4770K - GA-Z87X-UD5H - 32GB RAM - GTX 760

You bet. Curious, Gigabyte is now showing the F10c beta bios on their website now. I know you didn't want to earlier, but have you thought about flashing this to see if it handles the 4790K any better?

I did flash it on mine playing around with a few things over the past month, and you can easily go back to F9 if need be. I got it from the TweakTown forum. But now that it's hosted on the Gigabyte site, any change of mind?

I'm so stable right now, I don't want to screw anything up by swapping out CPUs. But, the itch is killing me to get the 4790K...

I saw Stasio said that the Z87 f10 finals should be very soon, not too many pages back in that thread. I very nearly went for f10c yesterday, but I just got everything re-installed both sides here and just manually dropped my vcore till it wouldn't Handbrake anymore. As far as I could tell, the only thing f10c fixes is default vcores/vrins but I just hammered that down manually anyhow. I also saw a horrible Beta BIOS they had up for a while for one of the boards that omitted the SATA code accidentally. That kinda thing is a worry!

I think I'll wait.....I have cloned drives but just one set of my AU/VST's is a 230gb+ install in itself, so it's a very long road back should anything go haywire.

If it ain't broke, don't fix it? Is there anything you do that needs the few extra mhz? Mine's a late '13 cpu, some say the L14 batches are a little cooler, but who knows? It's still a silicon lottery. Mine's retail not OEM as they had no stock at that time.

If I were you, I'd just hold out and go full on Broadwell/Skylake or maybe one of the Xeons if you need the grunt. I only had to complete rebuild due to faulty power supply that blew and took my old z68 and i5 2500k at 4.2 with it....4 years 24/7 at 4.2. I loved that chip...

If you do get the 4790k, I got the SSDT's right here! ;)

I'll read the Tweaktown thread, see what this "Improve Intel K-sku CPU performance" business is all about!

Cheers!

PS: And I went Z87 for out of the box OSX compatibility. I was completely stuck when the old Z68 blew up! I realise that Z97 would have maybe been more cutting edge and offer future CPU swap-outs, but the need to work was urgent. I couldn't hang about for things to pan out...
 
Joined
Jul 1, 2013
Messages
77
Motherboard
GA-Z87X-UD5H Rev 1.0 16GB Kingston Hyper-X grey
CPU
Intel i7 4790k
Graphics
GTX970
skirk08's Haswell Build: i7-4770K - GA-Z87X-UD5H - 32GB RAM - GTX 760

OK I flashed in f10c for you! :D

Here's my findings.

4.6ghz seems the sweet spot for my 4790k. The reason is that I can run 4.6 stable, Handbrake, Prime and all at 1.161vcore. With max temps under Handbrake at 100% load of 74c.

If I go for 4.7, I need at least 1.222 vcore (I know it's safe, the default BIOS still tries for 1.3+ lol) but there is a +10c (Core 2 +15c) heat returned for that 100mhz jump. It's alot of heat for 100mhz.

So, yeah, f10c allowed me so far to drop the vcore lower than f9 at 1.190 stable down to 1.161 and falling @4.6. It may well go lower, it's just a slow process running Handbrake and Realbench and Cinebench with Realtemps every time I change the vcore down a bit to prove stability then booting OSX and checking things there. Back and forth.

I'll keep going and report back. Any ideas that may help going up to 4.7 but cool, very welcome Skirk. I got a decent big Cooler on it....

Also, My CPU fan doesn't show in OSX HW Monitor or in any of the Windows bench/monitor programs, but it is working and reported in BIOS at correct speeds. Have you seen that at all? Same with f9 & f10c

Cheers!

Amblin
 
Joined
Nov 9, 2011
Messages
211
Motherboard
Gigabyte Z390 Aorus Master
CPU
i9-9900K
Graphics
Vega 56
Mobile Phone
  1. Android
  2. iOS
skirk08's Haswell Build: i7-4770K - GA-Z87X-UD5H - 32GB RAM - GTX 760

OK I flashed in f10c for you! Any ideas that may help going up to 4.7 but cool?

Such a gentleman you are. Glad things didn't blow up. And lower voltages are always a good thing. Not sure how you'd be able to push it to 4.7 while staying cool and stable, as all the 4790K OC guides have been for Z97 boards that I've seen. I'm guessing it's going to be a lot of trial an error. Have you tried upping ring voltage at all while staying @ the same vCore and VRIN? It may add a little heat along w/ stability, but not as much heat if you upped vCore more.

Also, My CPU fan doesn't show in OSX HW Monitor or in any of the Windows bench/monitor programs, but it is working and reported in BIOS at correct speeds. Have you seen that at all? Same with f9 & f10c

Yeah, same issue here too; F9 and F10c as well. I've had the Hyper 212 Evo and the Notctua NH-D15, and neither reported in OS X. All I get is two system fans and the GPU fan reporting in HW Monitor.
 
Joined
Jun 20, 2013
Messages
14
Motherboard
GA-Z97X-UD5H
CPU
i7-4790K
Graphics
GTX 780
Mac
  1. MacBook
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Power Mac
Mobile Phone
  1. Android
  2. iOS
skirk08's Haswell Build: i7-4770K - GA-Z87X-UD5H - 32GB RAM - GTX 760

so did re running the script with a higher clock solve the xcpm mismatch problem? cause I'm still getting that error.
 
Joined
Nov 9, 2011
Messages
211
Motherboard
Gigabyte Z390 Aorus Master
CPU
i9-9900K
Graphics
Vega 56
Mobile Phone
  1. Android
  2. iOS
skirk08's Haswell Build: i7-4770K - GA-Z87X-UD5H - 32GB RAM - GTX 760

so did re running the script with a higher clock solve the xcpm mismatch problem? cause I'm still getting that error.

Yes, see here.
 
Joined
Jun 20, 2013
Messages
14
Motherboard
GA-Z97X-UD5H
CPU
i7-4790K
Graphics
GTX 780
Mac
  1. MacBook
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Power Mac
Mobile Phone
  1. Android
  2. iOS
skirk08's Haswell Build: i7-4770K - GA-Z87X-UD5H - 32GB RAM - GTX 760

fantastic! I just did it problem went away.

My only issues still is I cant get any P-states other than 8 and 40-47 for my turbo boost. Amblin do you know what p-states youre hitting?
 
Joined
Nov 9, 2011
Messages
211
Motherboard
Gigabyte Z390 Aorus Master
CPU
i9-9900K
Graphics
Vega 56
Mobile Phone
  1. Android
  2. iOS
skirk08's Haswell Build: i7-4770K - GA-Z87X-UD5H - 32GB RAM - GTX 760

My only issues still is I cant get any P-states other than 8 and 40-47 for my turbo boost.

What are you using to validate your P-states?
 
Joined
Jun 20, 2013
Messages
14
Motherboard
GA-Z97X-UD5H
CPU
i7-4790K
Graphics
GTX 780
Mac
  1. MacBook
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Power Mac
Mobile Phone
  1. Android
  2. iOS
skirk08's Haswell Build: i7-4770K - GA-Z87X-UD5H - 32GB RAM - GTX 760

I've used all types of programs, MSRDumper.kext, ACPIMI, DCPIManager, HWMonitor all the same issue. Like ACPIMI "shows" the other P-states but for some reason it never goes to those states.
 
Status
Not open for further replies.
Top