Contribute
Register

Making the MSI Radeon r9 280x

Status
Not open for further replies.
Joined
May 2, 2014
Messages
13
Motherboard
Gigabyte GA-Z87-DS3H mobo
CPU
i7-4770k @4.1GHz
Graphics
MSI Radeon R9 280x
Mac
Classic Mac
Mobile Phone
Hi there!

Just installed Mavericks on my PC and everything is working perfect except my radeon.

My parts:
-Gigabyte GA-Z87-DS3H rev1.1 motherboard
-Crucial Ballistix 16GB (8x2) sport kit
-MSI Radeon r9 280x 3G Gaming edition
-650W PSU
-Seagate Barracuda 1TB
-Corsair Force Series 128GB
-Intel core i7 @4.1GHZ liquid cooled

When setting the PCIe1 slot as primary display output in BIOS, the screen goes black under boot. When I set it to IGFX and put the HDMI cable straight into the motherboard - the computer boots perfect. How can I fix this?

Thanks a lot for help!

Best Regards,
Erik
 

WonkeyDonkey

Moderator
Joined
Aug 31, 2010
Messages
3,896
Motherboard
Asrock Z87E-ITX
CPU
i7-4770S
Graphics
GTX 760
Mac
  1. iMac
  2. Mac mini
Mobile Phone
  1. iOS
Hi there!

Just installed Mavericks on my PC and everything is working perfect except my radeon.

My parts:
-Gigabyte GA-Z87-DS3H rev1.1 motherboard
-Crucial Ballistix 16GB (8x2) sport kit
-MSI Radeon r9 280x 3G Gaming edition
-650W PSU
-Seagate Barracuda 1TB
-Corsair Force Series 128GB
-Intel core i7 @4.1GHZ liquid cooled

When setting the PCIe1 slot as primary display output in BIOS, the screen goes black under boot. When I set it to IGFX and put the HDMI cable straight into the motherboard - the computer boots perfect. How can I fix this?

Thanks a lot for help!

Best Regards,
Erik

Can you set PCI-E slot as first/primary, and disable the iGfx altogether.
 
Joined
May 2, 2014
Messages
13
Motherboard
Gigabyte GA-Z87-DS3H mobo
CPU
i7-4770k @4.1GHz
Graphics
MSI Radeon R9 280x
Mac
Classic Mac
Mobile Phone
Yeah, but then osx goes to blackscreen during boot
 
Joined
May 2, 2014
Messages
13
Motherboard
Gigabyte GA-Z87-DS3H mobo
CPU
i7-4770k @4.1GHz
Graphics
MSI Radeon R9 280x
Mac
Classic Mac
Mobile Phone
How do I check? I selected DSDTfree in multibeast with Generate CPU States, hibernate mode =desktop and use KernelCache in multibeast
 
Joined
May 2, 2014
Messages
13
Motherboard
Gigabyte GA-Z87-DS3H mobo
CPU
i7-4770k @4.1GHz
Graphics
MSI Radeon R9 280x
Mac
Classic Mac
Mobile Phone
Nothing really. I press the power button on my computer and it boots into osx automatically
 

WonkeyDonkey

Moderator
Joined
Aug 31, 2010
Messages
3,896
Motherboard
Asrock Z87E-ITX
CPU
i7-4770S
Graphics
GTX 760
Mac
  1. iMac
  2. Mac mini
Mobile Phone
  1. iOS
Nothing really. I press the power button on my computer and it boots into osx automatically

Well you prob need to add some boot flags then.

Try with :

GraphicsEnabler=Yes IGPEnabler=No

And see how you get on with that.
 
Joined
May 2, 2014
Messages
13
Motherboard
Gigabyte GA-Z87-DS3H mobo
CPU
i7-4770k @4.1GHz
Graphics
MSI Radeon R9 280x
Mac
Classic Mac
Mobile Phone
Done that now. It made a weird noise for half a second just before hitting the logonscreen, but it started. There's no monitor output on the gpu though. Should I change my BIOS? btw, I need to run out'n cut the grass, but i'll be back in an hour:) pls help me then, really nice of you:)
 
Joined
May 2, 2014
Messages
13
Motherboard
Gigabyte GA-Z87-DS3H mobo
CPU
i7-4770k @4.1GHz
Graphics
MSI Radeon R9 280x
Mac
Classic Mac
Mobile Phone
Back - what should I do now? I've enabled/installed those two things you mentioned. Should I alter the BIOS or what's next?
 
Status
Not open for further replies.
Top