Contribute
Register

macOS10.12.4 Wake up black screen(Only backlight)

Joined
Jan 11, 2017
Messages
12
CPU
i5
Graphics
HD4000
Do a fresh install. Then test...
Avoid adding software until your system is working properly.
Hello RehabMan.

Thank you for taking the time to reply.

I have a new installation of the operating system (macOS 10.12.4)

Or the same problem.

Did not install any third party software.

The following is my report:

Code:
NerodeMBP:~ nero$ kextstat|grep -y acpiplat
   13    2 0xffffff7f83132000 0x66000    0x66000    com.apple.driver.AppleACPIPlatform (5.0) 65E05472-6AE7-3308-8CC8-FA6CB0DB2AEE <12 11 7 6 5 4 3 1>
NerodeMBP:~ nero$ kextstat|grep -y appleintelcpu
NerodeMBP:~ nero$ kextstat|grep -y applelpc
  102    0 0xffffff7f82955000 0x3000     0x3000     com.apple.driver.AppleLPC (3.1) F51595F0-F9B1-3B85-A1C3-F984DAD4107E <96 12 5 4 3>
NerodeMBP:~ nero$ kextstat|grep -y applehda
   95    1 0xffffff7f82e12000 0x1d000    0x1d000    com.apple.driver.AppleHDAController (279.48) ED51F180-19C8-3DE1-AF81-0E389D98ADDE <94 48 29 12 7 6 5 4 3 1>
  119    0 0xffffff7f82f94000 0xb5000    0xb5000    com.apple.driver.AppleHDA (279.48) 806B8C17-50CA-3C6B-90B3-195F38D8FB89 <118 106 95 94 48 29 6 5 4 3 1>
NerodeMBP:~ nero$ sudo touch /System/Library/Extensions && sudo kextcache -u /
Password:
KernelCache ID: A660F2D405AE139B0216807A71A90BB3
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,949
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hello RehabMan.

Thank you for taking the time to reply.

I have a new installation of the operating system (macOS 10.12.4)

Or the same problem.

Did not install any third party software.

The following is my report:

Code:
NerodeMBP:~ nero$ kextstat|grep -y acpiplat
   13    2 0xffffff7f83132000 0x66000    0x66000    com.apple.driver.AppleACPIPlatform (5.0) 65E05472-6AE7-3308-8CC8-FA6CB0DB2AEE <12 11 7 6 5 4 3 1>
NerodeMBP:~ nero$ kextstat|grep -y appleintelcpu
NerodeMBP:~ nero$ kextstat|grep -y applelpc
  102    0 0xffffff7f82955000 0x3000     0x3000     com.apple.driver.AppleLPC (3.1) F51595F0-F9B1-3B85-A1C3-F984DAD4107E <96 12 5 4 3>
NerodeMBP:~ nero$ kextstat|grep -y applehda
   95    1 0xffffff7f82e12000 0x1d000    0x1d000    com.apple.driver.AppleHDAController (279.48) ED51F180-19C8-3DE1-AF81-0E389D98ADDE <94 48 29 12 7 6 5 4 3 1>
  119    0 0xffffff7f82f94000 0xb5000    0xb5000    com.apple.driver.AppleHDA (279.48) 806B8C17-50CA-3C6B-90B3-195F38D8FB89 <118 106 95 94 48 29 6 5 4 3 1>
NerodeMBP:~ nero$ sudo touch /System/Library/Extensions && sudo kextcache -u /
Password:
KernelCache ID: A660F2D405AE139B0216807A71A90BB3
Your ioreg shows IntelBacklight.kext and 10.12.4.
IntelBacklight.kext does not work on 10.12.4. See here: https://www.tonymacx86.com/threads/...rol-using-applebacklightinjector-kext.218222/

Also, your Clover hotpatch setup is very complex.
I'm not going to attempt to understand/debug it...
You may want to patch the traditional way (static patching) to see if your mistake is within your hotpatch setup.
 
Joined
Jan 11, 2017
Messages
12
CPU
i5
Graphics
HD4000
Your ioreg shows IntelBacklight.kext and 10.12.4.
IntelBacklight.kext does not work on 10.12.4. See here: https://www.tonymacx86.com/threads/...rol-using-applebacklightinjector-kext.218222/
I see.

Because I currently use macOS 10.12.3, so I did not delete the kext.

After testing, removing IntelBacklight.kext does not fix this problem.

Also, your Clover hotpatch setup is very complex.
I'm not going to attempt to understand/debug it...
You may want to patch the traditional way (static patching) to see if your mistake is within your hotpatch setup.
My hotpatch follow the guidelines you provided (https://www.tonymacx86.com/threads/guide-using-clover-to-hotpatch-acpi.200137/ https://www.tonymacx86.com/threads/guide-using-clover-to-hotpatch-acpi.200137/)

Refer to your HP-ProBook-4x30s-DSDT-Patch (https://github.com/RehabMan/HP-ProBook-4x30s-DSDT-Patch/tree/master/hotpatch) to achieve battery fix, turn off the discrete graphics.

thanks for your advice.

I will try static patching.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,949
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Because I currently use macOS 10.12.3
Wrong. Your ioreg shows Darwin 16.5.0. That is 10.12.4.

After testing, removing IntelBacklight.kext does not fix this problem.
Implementing brightness control on 10.12.4 involves more than that.
You clearly didn't read the guide.

I will try static patching.
Good plan. If you want to use hotpatch, you should always have a working static patch first (unless you really know what you're doing).
 
Joined
Jan 11, 2017
Messages
12
CPU
i5
Graphics
HD4000
Wrong. Your ioreg shows Darwin 16.5.0. That is 10.12.4.
Now i am using the macOS10.12.3, 10.12.4 is for testing only, so i did not remove IntelBacklight.kext.

Implementing brightness control on 10.12.4 involves more than that.
You clearly didn't read the guide.
I follow the guidelines, but I still can not achieve the brightness control (AppleBacklightInjector.kext is not loaded)

If I want to solve the sober black screen (only the backlight), do I need to achieve brightness control first?

If so, I will first try to solve the problem of brightness control.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,949
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Now i am using the macOS10.12.3, 10.12.4 is for testing only, so i did not remove IntelBacklight.kext.
The files you provided were 10.12.4.

I follow the guidelines, but I still can not achieve the brightness control (AppleBacklightInjector.kext is not loaded)
The files you provided show IntelBacklight.kext installed on 10.12.4.
It is not according to the guide I linked.
 
Joined
May 24, 2015
Messages
167
Motherboard
ThinkPad X1c 2015
Mac
Classic Mac
Mobile Phone
My Thinkpad X1 Carbon Gen 3 (2560x1440) has a similar problem, where I get backlight but an all-black-pixel display.

I noticed that if I left it there long enough, the backlight would turn off (energy saver). And then I could press Shift or something to wake it from the screen blanker, and have pixels that actually worked.

Eventually I figured out that I could make this faster by pressing the sleep key* on my keyboard. I think this starts the process of going to sleep. But Macs don't sleep instantly. The display turns off, and I press shift to wake it from the sleep process and then the screen works. Then I log in like a normal person.

I am curious whether this works for you.

* There isn't actually a sleep key on this laptop. I press the power button for about two seconds. So perhaps I'm pressing "hibernate" instead...

(RehabMan: this isn't a request for assistance. :) BTW, I'm still on 10.11, waiting on a spare disk; hopefully I can redo my guides for Sierra.)
 
Joined
Mar 12, 2016
Messages
8
I'm having the same problem with my ASUS K501LX (CPU i7-5500U, GPU Intel HD 5500) on macOS 10.12.4. If I set ig-platform-id to 0x16260006 (my default settings), the computer can enter sleep mode, but it will show black screen and freeze after wake. While if I change it to 0x16160002, the computer also show black screen after wake, but the OS is still working (I can press Ctrl + Power and then press R to perform a reboot). On El Capitan 10.11.6, my computer works fine with my configuration and be able to sleep and wake normally.

I attached the necessary files for problem reporting. Hope you can help me find the cause of this problem.
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,949
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I'm having the same problem with my ASUS K501LX (CPU i7-5500U, GPU Intel HD 5500) on macOS 10.12.4. If I set ig-platform-id to 0x16260006 (my default settings), the computer can enter sleep mode, but it will show black screen and freeze after wake. While if I change it to 0x16160002, the computer also show black screen after wake, but the OS is still working (I can press Ctrl + Power and then press R to perform a reboot). On El Capitan 10.11.6, my computer works fine with my configuration and be able to sleep and wake normally.

I attached the necessary files for problem reporting. Hope you can help me find the cause of this problem.
You have everything but the kitchen sink as far as kexts installed.
Start over...
Don't install so much junk...
Focus on basic power management, correct ACPI patches, correct graphics config...

Follow the Clover guide linked from the FAQ.
http://www.tonymacx86.com/el-capita...faq-read-first-laptop-frequent-questions.html

Also, don't use KextsToPatch entries for anything but the version you're running. Or use MatchOS to selectively apply them depending on version.

Your ACPI hotpatch setup also looks quite messy... Before delving into hotpatch, make sure your system works correctly with ACPI via static patch.
 
Joined
Mar 12, 2016
Messages
8
You have everything but the kitchen sink as far as kexts installed.
Start over...
Don't install so much junk...
Focus on basic power management, correct ACPI patches, correct graphics config...

Follow the Clover guide linked from the FAQ.
http://www.tonymacx86.com/el-capita...faq-read-first-laptop-frequent-questions.html

Also, don't use KextsToPatch entries for anything but the version you're running. Or use MatchOS to selectively apply them depending on version.

Your ACPI hotpatch setup also looks quite messy... Before delving into hotpatch, make sure your system works correctly with ACPI via static patch.
My configuration worked perfectly fine on El Capitan 10.11.6. And yesterday I tried to install 10.12.3 and it worked fine, too, no black screen and freezing after wake.

But for your testing, I reinstalled 10.12.4 with static ACPI patching and only mandatory kexts in EFI/CLOVER/kexts/Other (no kexts installed in /L/E). It stills have the problem of black screen and freezing after wake.

Here is my reporting files. Hope you can find the cause of the problem. :)
 

Attachments

Top