Contribute
Register

macOS Sierra PB: Need testers for new AMD Radeon drivers!

Status
Not open for further replies.
Joined
May 15, 2016
Messages
4,637
Motherboard
GIGABYTE Z170M D3H
CPU
i5-6500
Graphics
RX 480
Mac
iMac
Joined
Nov 4, 2016
Messages
113
Motherboard
GA-Z170x-Designare
CPU
Core i7-6700k
Graphics
AMD FirePro W9000 + Radeon 7970
Can't wait, another 2 weeks again! $499, not bad for a 1080 equal that will run in OS without a special driver. At least we have the lilu and Mr. Green kexts for our Polaris cards.
Until Apple supports multi stream transport monitors on more than one video card, I can't upgrade yet. It looks like the Radeon WX 9100 will be 6 DisplayPort, but it also will probably cost 2000 dollars or thereabouts :p.

Hopefully the design of the new Mac Pro gets them to support this scenario better. For cost reasons I'd be fine running a single Vega card to drive my primary monitor and a secondary card to drive the others. Even the cut down Vega 56 or possibly the Vega Nano would be a huge step up.
 
Joined
Aug 15, 2016
Messages
126
Motherboard
GA-Z170X-UD5
CPU
i5-6500
Graphics
Vega 56
Mobile Phone
Android
Is anyone else experiencing random freezes with the WhateverGreen and/or the Lilu kexts?

My system kept freezing on me and when I removed the WhateverGreen and the Lilu kexts my system became stable again.
 
Joined
May 15, 2016
Messages
4,637
Motherboard
GIGABYTE Z170M D3H
CPU
i5-6500
Graphics
RX 480
Mac
iMac
Is anyone else experiencing random freezes with the WhateverGreen and/or the Lilu kexts?

My system kept freezing on me and when I removed the WhateverGreen and the Lilu kexts my system became stable again.
I think they updated the lilukext, did you try the updated version?
 
Joined
Nov 4, 2016
Messages
113
Motherboard
GA-Z170x-Designare
CPU
Core i7-6700k
Graphics
AMD FirePro W9000 + Radeon 7970
I'm encountering some weird glitching that happens during video playback ... relatively repeatable on certain youtube videos and causes horizontal lines to glitch across parts of the screen. Stops immediately if I stop video playback. Oddly I never encountered this prior to the WhateverGreen fix so I suspect it is related. If I enable h264 acceleration via intel video, the problem almost goes away entirely, but then final cut starts crashing again. Luckily Skylake processor alone is capable of playing back nearly any video without acceleration, so I guess I won't worry about it too much right now.
 
Joined
Jun 30, 2012
Messages
82
Motherboard
MSI Krait Gaming 3x
CPU
i7-6700K
Graphics
RX 580
Mac
iMac
Mobile Phone
iOS
High Sierra has very good drivers, Sierra may need patching.
Hi
well after long time have got back my rx480 from RMA and currently running 10.12.5 so can you point out best way to enable the card as presently this system was being used on internal graphic with kext patches or will an update to 10.12.6 give me Drivers OOB, presently will be putting RX480 with the 6700k rig
Till. we wait for VEGA.....:think:
 
Joined
May 15, 2016
Messages
4,637
Motherboard
GIGABYTE Z170M D3H
CPU
i5-6500
Graphics
RX 480
Mac
iMac
Hi
well after long time have got back my rx480 from RMA and currently running 10.12.5 so can you point out best way to enable the card as presently this system was being used on internal graphic with kext patches or will an update to 10.12.6 give me Drivers OOB, presently will be putting RX480 with the 6700k rig
Till. we wait for VEGA.....:think:
Sierra 12.6 has all the native drivers and CU fix already to go, you can use CPU graphics but you may need to reconfigure your IGPU settings and fixes if you are using those in 12.5. I am able to get the RX 460-480 working with Skylake CPU without any major fixes for CPU.

Clover settings:
Inject Intel, fake ID 0x00000000, ig 19120001 it gives me HD 530 1536mb and the RX 480 gets full acceleration and proper CU count. If you have preexisting fixes like lilukext, or other HD 530 Intel fixes then you may need to either remove them or find the latest updated fix for Sierra 12.6. The above settings will work but you need to remove any other fixes or it ma not.

Option 2 is follow the above settings and download the lilukext and WhateverGreenkext in place them in Clover Kexts folders and or System/library/Extensions folder. Make sure to run Kext wizzard to repair permissions and rebuild caches before reboot. Try it and see if the RX has the new AMD Radeon Pro 480/475 label. If it does reboot and go to bios and disable IGFX or internal graphics and use the RX as a dedicated vCard.

High Sierra has audio working for Polaris cards now but it is a beta so there can be bugs. But you can use the same lilukext and green kext to run the same way.
 
Status
Not open for further replies.

Top