Contribute
Register

macOS Sierra PB: Need testers for new AMD Radeon drivers!

Status
Not open for further replies.
Joined
Apr 3, 2016
Messages
78
Motherboard
GA-H170M-DS3H
CPU
i5-6500
Graphics
AMD RX 480
Mac
iMac, MacBook Pro
Mobile Phone
Android, iOS
My Rx480 DisplayPort does not work,It shows in the system information but the monitor have no single.
And it can not support 60hz. I don't know what's wrong with it.
I just update 10.12.5.
here's my config.
I had the same problem the first time that I tried to make my RX 480 and the problem was that was in the x8 slot, are you trying to move to the x16 slot? or before work without problem in that slot?
 
Joined
Apr 27, 2016
Messages
15
Motherboard
B360 AORUS GAMING 3 WIF
CPU
i7 8700
Graphics
RX480
Mac
MacBook Air, Mac Pro
Mobile Phone
iOS
It doesn't work.I moved to the first slot,it as before.
Before I update 10.12.4 and clover,the DP connector did work,but it was in 59Hz.But I backup 10.12.3,It didn't work,either.
Anyway thanks all of you.And sorry for my bad english.
 
Joined
May 15, 2016
Messages
4,637
Motherboard
GIGABYTE Z170M D3H
CPU
i5-6500
Graphics
RX 480
Mac
iMac
It doesn't work.I moved to the first slot,it as before.
Before I update 10.12.4 and clover,the DP connector did work,but it was in 59Hz.But I backup 10.12.3,It didn't work,either.
Anyway thanks all of you.And sorry for my bad english.
Try to PM "personal message" Mork Vom Ork he may have a solution for DisplayPort issue.
 
Joined
May 15, 2016
Messages
4,637
Motherboard
GIGABYTE Z170M D3H
CPU
i5-6500
Graphics
RX 480
Mac
iMac
I had the same problem the first time that I tried to make my RX 480 and the problem was that was in the x8 slot, are you trying to move to the x16 slot? or before work without problem in that slot?
Using a Xeon CPU no igpu graphics so the pci lanes are 8x one for helper and one for the RX. This may be the issue though. I have same problem with X99 type system and only 8 pcie lanes available for RX.
 
Joined
Dec 28, 2012
Messages
143
Motherboard
ASRock Z370 Professional Gaming
CPU
i7-8086K
Graphics
Radeon VII
Mac
MacBook Pro
Mobile Phone
iOS
Displayport issue is ALWAYS related to FramBuffer mismatch configuration. Nothing else.
How to get the right FrameBuffer patch is explained enough here within the forum. You just need to look at the right places.
And FrameBuffer patching is no weird science, but also nothing you could learn between yet and now.

You have to read carefully the instructions and you have to UNDERSTAND about what you read.
Only than the given information will be selfexplained.
 
Joined
Apr 27, 2016
Messages
15
Motherboard
B360 AORUS GAMING 3 WIF
CPU
i7 8700
Graphics
RX480
Mac
MacBook Air, Mac Pro
Mobile Phone
iOS
Displayport issue is ALWAYS related to FramBuffer mismatch configuration. Nothing else.
How to get the right FrameBuffer patch is explained enough here within the forum. You just need to look at the right places.
And FrameBuffer patching is no weird science, but also nothing you could learn between yet and now.

You have to read carefully the instructions and you have to UNDERSTAND about what you read.
Only than the given information will be selfexplained.
Thank you,mork.
I'll read again.
 
Joined
Jul 8, 2016
Messages
61
Motherboard
Asus ROG Strix Z370-G Gaming WIFI
CPU
i7 8700K
Graphics
Radeon RX 580 8GB
Mac
iMac, MacBook Pro
Mobile Phone
iOS
I have bought a Radeon RX 480, any step by step to install it on OS X 10.12.5 ?
 
Joined
May 15, 2016
Messages
4,637
Motherboard
GIGABYTE Z170M D3H
CPU
i5-6500
Graphics
RX 480
Mac
iMac
Try first using clover ATI fake ID 0x67EF1002 in graphics settings in boot menu. Sometimes it works, some cards may not.

If not you can search "Enabling AMD RX 4xx cards in sierra" to do it manually, it's not difficult the key is to always use kext wizard before you reboot, and set SIP to disabled. Some people need to boot into recovery partition and use terminal "csrutil disable" without quotation marks to disable it completely. I never have issues and I only use booter config 0x28 and active csr config 0x67 which normally disables sip and allows acceleration.
 
Joined
Jul 8, 2016
Messages
61
Motherboard
Asus ROG Strix Z370-G Gaming WIFI
CPU
i7 8700K
Graphics
Radeon RX 580 8GB
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Try first using clover ATI fake ID 0x67EF1002 in graphics settings in boot menu. Sometimes it works, some cards may not.

If not you can search "Enabling AMD RX 4xx cards in sierra" to do it manually, it's not difficult the key is to always use kext wizard before you reboot, and set SIP to disabled. Some people need to boot into recovery partition and use terminal "csrutil disable" without quotation marks to disable it completely. I never have issues and I only use booter config 0x28 and active csr config 0x67 which normally disables sip and allows acceleration.

Do I have to enable iGPU ? or I can use it alone like I did with my Radeon 7950? my new Radeon (https://www.amazon.com/dp/B06VSWDK2H/?tag=tonymacx86com-20)
Would you mind sharing clover config ?
 
Status
Not open for further replies.

Top