Contribute
Register

macOS Sierra PB: Need testers for new AMD Radeon drivers!

Status
Not open for further replies.

Gigamaxx

Moderator
Joined
May 15, 2016
Messages
5,369
Motherboard
GIGABYTE Z170M D3H
CPU
i5-6500
Graphics
RX 480
Mac
iMac
I'm noticing different LuxMark scores when testing the RX 480 at different resolutions on my 4K monitor. Is this something I should expect? I apologize, I'm not familiar with OpenCL's workings but I thought it would be resolution independent. First score is the monitor scaled to 3360 x 1890 (via Display Preferences). Second score is native 4K (3840 x 2160).

My old eyes struggle a little at native 4K resolution for everyday work (which is coding). I doubt this difference is noticeable in most "real world" situations but I was just curious. Thanks.

View attachment 234892 View attachment 234893
Did you run a few bench I each configuration? Luxmark can vary by a few hundred points, also do a force quit on any open apps before testing each, its just above the shut down option.
 
Joined
Sep 4, 2015
Messages
79
Motherboard
ASUS Prime X299-A
CPU
i9-7920X
Graphics
RX Vega 64
Mac
MacBook Pro, Mac mini
Mobile Phone
iOS
Did you run a few bench I each configuration? Luxmark can vary by a few hundred points, also do a force quit on any open apps before testing each, its just above the shut down option.
Yes, in the scaled resolution, scores are in the 13,500 - 13,800 range, while in native 4K they are 14,400 - 14,550 (granted, we're talking probably 5 runs in each resolution). I run the benchmarks immediately after booting with no other apps running.

Update: Just to provide some further evidence, here is a screenshot of hashcat. The only difference between these two runs is a change in display resolution (from scaled for the first run to native 4K for the second). Again, the differences are small (~ 2.5% decrease) but consistent.

Screen Shot 2017-02-06 at 3.07.14 PM.png
 
Last edited:
Joined
Jul 24, 2011
Messages
22
Motherboard
Sony Vaio Intel Lynx Point-LP (Premium)
CPU
i7-4500U
Graphics
HD 4400
What brand of RX 480 is it? All RX 470-480s have 0x67DF1002 as far as I know. Only the RX 460 has a different ID 0x67EF1002.
Hello, it is the
ASUS ROG STRIX Radeon Rx 480 8GB OC Edition DP 1.4 HDMI 2.0 AMD Polaris Graphics Cards STRIX-RX480-O8G-GAMING





 

Fl0r!an

Moderator
Joined
Jul 6, 2010
Messages
2,714
Motherboard
Asus Z170M-Plus
CPU
i5-6600K
Graphics
R9 280
Mac
MacBook Pro, Mac Pro
Mobile Phone
iOS
I'm noticing different LuxMark scores when testing the RX 480 at different resolutions on my 4K monitor. Is this something I should expect? I apologize, I'm not familiar with OpenCL's workings but I thought it would be resolution independent. First score is the monitor scaled to 3360 x 1890 (via Display Preferences). Second score is native 4K (3840 x 2160).
Are you talking about 3360x1890 HiDPI (which would create an enormous internal resolution of 6720x3780 = 25 MP!)? Or did you actually reduce the resolution to 3360x1890?

In the first case I wouldn't be surprised about lower scores, pushing 25MP surely creates some reasonable load for the GPU, even when drawing the UI.
 
Joined
Dec 26, 2016
Messages
123
Motherboard
Gigabyte GA-Z170X-Gaming 3
CPU
i7 6700K
Graphics
RX 480
Mac
MacBook, MacBook Pro
Classic Mac
Power Mac
I just want let you know that if you have problems like the system restarts when you select "shutdown" to power off or it firstly powers off and then powers on again just after a few seconds in infinite loops, i managed to get rid of this by doing so:

- disabling ErP in BIOS
- disabling USB DAC Power in BIOS

This disables the system consume least power in S5 (shutdown) state. When you stop here you already have fixed the mentioned problem (Gigabyte MLB). In this state you could still power on your system with keyboard, a mouse movement or click when connected to USB DAC ports. To get rid of this just diable USB DAC Power in BIOS. You'll loose this ports. However you should have enough USB 3 and 3.1 using without DAC Power.

I tested lots of shutdowns via menu + fast shutdowns via control+alt+apple+eject it works as expected. ;)
 
Last edited:

Gigamaxx

Moderator
Joined
May 15, 2016
Messages
5,369
Motherboard
GIGABYTE Z170M D3H
CPU
i5-6500
Graphics
RX 480
Mac
iMac
Nothing changed in 10.12.4 beta 2, the only kext that were updated is: AppleBacklightExpert.kext System.kext IOPCIFamily.kext IONDRVSupport.kext IOGraphicsFamily.kext AudioAUUC.kext
Audio? Maybe some news on sound for the RX? Wishful thinking I know.
 

Gigamaxx

Moderator
Joined
May 15, 2016
Messages
5,369
Motherboard
GIGABYTE Z170M D3H
CPU
i5-6500
Graphics
RX 480
Mac
iMac
I just want let you know that if you have problems like the system restarts when you select "shutdown" to power off or it firstly powers off and then powers on again just after a few seconds in infinite loops, i managed to get rid of this by doing so:

- disabling ErP in BIOS
- disabling USB DAC Power

This disables the system consume least power in S5 (shutdown) state. When you stop here you already have fixed the mentioned problem (Gigabyte MLB). In this state you could still power on your system with keyboard, a mouse movement or click when connected to USB DAC ports. To get rid of this just diable USB DAC Power in BIOS. You'll loose this ports. However you should have enough USB 3 and 3.1 using without DAC Power.

I tested lots of shutdowns via menu + fast shutdowns via control+alt+apple+eject it works as expected. ;)
Have you tested sleep?
 
Status
Not open for further replies.
Top