Contribute
Register

macOS Native CPU/IGPU Power Management

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,100
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
So you can confirm that my PM scenario is right.. So I don't worry about the fact that CPU does not reach 800Mhz.
I set iMac18,1 in my SMSBIOS because I think it's almost near my system (i3 Dual Core Kaby Lake). Do you suggest me to take this configuration and stay quite and peaceful, or maybe I should change SMBIOS or try other solutions to optimize PM?
Thank you.

The ioreg and AII output look ok (in -PM files).

Note/off-topic: config.plist/ACPI/DSDT/Fixes/FixRegions=true is a huge mistake.
 
Joined
Nov 3, 2010
Messages
63
Motherboard
MSI B250M-Pro VD
CPU
Intel Core i3-7100
Graphics
Sapphire Pulse Rx 560
Mac
  1. iMac
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
The ioreg and AII output look ok (in -PM files).
Note/off-topic: config.plist/ACPI/DSDT/Fixes/FixRegions=true is a huge mistake.

Thank you. I'll correct FixRegion.
You're great.
 
Joined
Jan 5, 2018
Messages
27
Motherboard
SuperMicro C7Z370-CG-IW-Clover
CPU
i7-8700K OC @ 5.3 GHz
Graphics
GTX 1070 Ti
Mobile Phone
  1. Android
  2. iOS
Last edited:
Joined
Mar 24, 2011
Messages
54
Motherboard
Gigabyte Ga-P55A-ud4
CPU
i7
Graphics
GeForce GTX 960
what is wrong?

Osx 10.13.2 (17C205)
I74790K ( no - Intel GPU in bios)
GA-z97mx-gaming 5
GA- ourus-1080-gtx
Clover r4359-RM4
 

Attachments

  • config.plist
    5.6 KB · Views: 219
  • Schermata 2018-01-18 alle 19.37.57.png
    Schermata 2018-01-18 alle 19.37.57.png
    208.3 KB · Views: 126
  • Schermata 2018-01-18 alle 19.40.43.png
    Schermata 2018-01-18 alle 19.40.43.png
    141.7 KB · Views: 148
  • Schermata 2018-01-18 alle 19.47.07.png
    Schermata 2018-01-18 alle 19.47.07.png
    44.8 KB · Views: 117
  • Output Appleintelinfo.txt
    11.1 KB · Views: 79
Joined
Mar 18, 2017
Messages
61
Motherboard
x299
CPU
i9
Graphics
Radeon VII
i feel like i'm a ghost =/

could you please tell me what did i wrong ?
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,100
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi RehabMAn,

thank you so much for all information, I want to meet you =)

my cpu always working max frequency on on High Sierra 10.12.3, I already checked with several apps (intel power gadget, istat, hwmonitor)
cleardot.gif


I tried bios update and default settings but didn't work,

I tried ssdt patching but didn't work,

I tried SSDT-XCPM patching but didn't work.

Please help me
i feel like i'm a ghost =/

could you please tell me what did i wrong ?

Your ioreg is corrupt. Must use IORegistryExplorer v2.1.

Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the tool mentioned in the FAQ, that way it is less likely you'll omit something.
 
Top