Contribute
Register

macOS Native CPU/IGPU Power Management

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,103
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
@RehabMan hi, i see the clvoer version in bitbucket.org is 4359....there is necessary to update to r4369.or still use r4359 in onder to make plugin type works? thank you

My 4359 build has Generate/PluginType. It has been there for quite some time...
 
Joined
Nov 3, 2010
Messages
63
Motherboard
MSI B250M-Pro VD
CPU
Intel Core i3-7100
Graphics
Sapphire Pulse Rx 560
Mac
  1. iMac
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
Hi Mr Rehabman and Toleda,
I recently create a new customac with the parts in my profile.
Installed HS 10.13.2 and all seems to work fine. I only use with success a dGPU (RX 560) with enabled HEVC and Multi-Monitor in BIOS.
System seems really reliable with working sleep/work
But I've doubt with the PM, because with only ACPI->SSDT->Generate->PluginType=YES frequency of my i3-7000 seems to goes down in a wrong way and never reach 800Mhz.
But X86PlatformPlugin seems to work.

With ACPI->SSDT->Generate->PluginType=NO, CPU seems to go down in a better way, reaching 800Mhz, but X86PlatformPlugin is not enabled...

Please can you verify what is wrong or not in my config?
I attach all file request in #POST1
Thank you.
 

Attachments

  • Stalvatero-Files-PM.zip
    1.8 MB · Views: 60

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,103
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi Mr Rehabman and Toleda,
I recently create a new customac with the parts in my profile.
Installed HS 10.13.2 and all seems to work fine. I only use with success a dGPU (RX 560) with enabled HEVC and Multi-Monitor in BIOS.
System seems really reliable with working sleep/work
But I've doubt with the PM, because with only ACPI->SSDT->Generate->PluginType=YES frequency of my i3-7000 seems to goes down in a wrong way and never reach 800Mhz.
But X86PlatformPlugin seems to work.

With ACPI->SSDT->Generate->PluginType=NO, CPU seems to go down in a better way, reaching 800Mhz, but X86PlatformPlugin is not enabled...

Please can you verify what is wrong or not in my config?
I attach all file request in #POST1
Thank you.

With plugin-type injection, SMBIOS affects CPU PM by way of X86PlatformPlugin.
The results you have with X86PlatformPlugin and iMac SMBIOS are not unexpected and you would see the same on a real iMac18,1.
Do some research on FrequencyVectors and you'll understand.
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,103
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
hi,,rehabman, i have downloaded r4359 now. the newest clover version is r4380...will you update it recently?

Only when I finish testing.
There are a lot of big changes regarding OsxAptioFix*.efi, therefore must be careful.
 
Joined
Mar 18, 2017
Messages
61
Motherboard
x299
CPU
i9
Graphics
Radeon VII
Hi RehabMAn,

thank you so much for all information, I want to meet you =)

my cpu always working max frequency on on High Sierra 10.12.3, I already checked with several apps (intel power gadget, istat, hwmonitor)
cleardot.gif


I tried bios update and default settings but didn't work,

I tried ssdt patching but didn't work,

I tried SSDT-XCPM patching but didn't work.

Please help me
 

Attachments

  • Screen Shot 2018-01-15 at 18.27.08.jpg
    Screen Shot 2018-01-15 at 18.27.08.jpg
    1.9 MB · Views: 80
  • Lapseart’s Mac Pro.ioreg
    15.6 MB · Views: 88
  • appleintelinfo.txt
    9.3 KB · Views: 171
Joined
Nov 3, 2010
Messages
63
Motherboard
MSI B250M-Pro VD
CPU
Intel Core i3-7100
Graphics
Sapphire Pulse Rx 560
Mac
  1. iMac
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
With plugin-type injection, SMBIOS affects CPU PM by way of X86PlatformPlugin.
The results you have with X86PlatformPlugin and iMac SMBIOS are not unexpected and you would see the same on a real iMac18,1.
Do some research on FrequencyVectors and you'll understand.

So you can confirm that my PM scenario is right.. So I don't worry about the fact that CPU does not reach 800Mhz.
I set iMac18,1 in my SMSBIOS because I think it's almost near my system (i3 Dual Core Kaby Lake). Do you suggest me to take this configuration and stay quite and peaceful, or maybe I should change SMBIOS or try other solutions to optimize PM?
Thank you.
 
Top