macOS Native CPU/IGPU Power Management

Discussion in 'General Help' started by toleda, May 25, 2017.

  1. RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    160,470
    Mobo:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    Sep 18, 2017 at 10:27 PM #241
    RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    160,470
    Mobo:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    CPU PM is working.
     
    atomicamp likes this.
  2. atomicamp

    atomicamp

    Joined:
    Aug 10, 2017
    Messages:
    98
    Mobo:
    BitFenix Phenom M
    CPU:
    intel core i7 6700k 4ghz skylake
    Graphics:
    Gigabyte GeForce GTX 1080 XTREME Gaming Extreme (GV-N1080XTREME-8GD Premium )
    Mac:
    iMac
    Sep 18, 2017 at 11:25 PM #242
    atomicamp

    atomicamp

    Joined:
    Aug 10, 2017
    Messages:
    98
    Mobo:
    BitFenix Phenom M
    CPU:
    intel core i7 6700k 4ghz skylake
    Graphics:
    Gigabyte GeForce GTX 1080 XTREME Gaming Extreme (GV-N1080XTREME-8GD Premium )
    Mac:
    iMac
  3. Spillseverything

    Spillseverything

    Joined:
    Aug 9, 2016
    Messages:
    4
    Sep 19, 2017 at 6:58 PM #243
    Spillseverything

    Spillseverything

    Joined:
    Aug 9, 2016
    Messages:
    4
    I don't think my PM is working properly. Intel Power Gadget shows consistently high Frequencies.

    10.12.6 / Gigabyte GA-Z170X-UD5 TH / F5 / Intel i7 6700K / nVdia Titan X
     

    Attached Files:

  4. Spillseverything

    Spillseverything

    Joined:
    Aug 9, 2016
    Messages:
    4
    Sep 19, 2017 at 7:27 PM #244
    Spillseverything

    Spillseverything

    Joined:
    Aug 9, 2016
    Messages:
    4
    Also here are my clover files.
     

    Attached Files:

    Last edited: Sep 19, 2017
  5. RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    160,470
    Mobo:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    Sep 19, 2017 at 8:00 PM #245
    RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    160,470
    Mobo:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    Check Activity Monitor.
     
  6. Spillseverything

    Spillseverything

    Joined:
    Aug 9, 2016
    Messages:
    4
    Sep 21, 2017 at 8:47 PM #246
    Spillseverything

    Spillseverything

    Joined:
    Aug 9, 2016
    Messages:
    4
    Activity Monitor seems to be reacting a bit better. Anything I should be looking for specifically? Also what could cause Intel Power Gadget to not read properly?
     
  7. RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    160,470
    Mobo:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    Sep 21, 2017 at 9:05 PM #247
    RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    160,470
    Mobo:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    You reported high CPU frequencies.
    Since CPU PM will use high pstates only when CPU demand is high, you should check Activity Monitor to see which processes are using CPU cycles.
     
  8. Spillseverything

    Spillseverything

    Joined:
    Aug 9, 2016
    Messages:
    4
    Sep 21, 2017 at 9:07 PM #248
    Spillseverything

    Spillseverything

    Joined:
    Aug 9, 2016
    Messages:
    4
    Ahh copy that. Something called mds is hogging huge CPU percentages. No idea what that is though. I will google it up.
     
  9. RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    160,470
    Mobo:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    Sep 21, 2017 at 9:35 PM #249
    RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    160,470
    Mobo:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    mds is the Spotlight search indexer.
    Maybe you have a lot of files to churn through.
     
  10. diep90.nguyen

    diep90.nguyen

    Joined:
    Sep 18, 2017
    Messages:
    38
    Mobo:
    H170N-wifi
    CPU:
    I3-6100
    Graphics:
    Strix 750 Ti
    Mobile Phone:
    iOS
    Sep 29, 2017 at 2:45 PM #250
    diep90.nguyen

    diep90.nguyen

    Joined:
    Sep 18, 2017
    Messages:
    38
    Mobo:
    H170N-wifi
    CPU:
    I3-6100
    Graphics:
    Strix 750 Ti
    Mobile Phone:
    iOS
    Hi,

    Problem Reporting
    1. Description of problem
    -> after installing, my cpu almost runs ~ 3Ghz and higher than before installing although I did not do nothing. steps not full
    1. OS X version/motherboard model/BIOS version/processor/graphics
    -> 10.13/H170n-Wifi/F22a/i3-6100/Strix 750 Ti
    1. Procedure/Guide Used
    -> followed page #1
    1. Copy of IOReg/File/Save a Copy As…, verify file (no ioreg.txt, screenshots)-
    -> attachment
    1. Copy of AppleIntelInfo/Terminal: cat /tmp/AppleIntelInfo.dat
      • Terminal/Shell/Export Text As...
    -> attachment
    1. Copy Of Console/All Messages (last boot)
      • Console/File/Save a Copy As...
    -> my console does not have save function.
    [​IMG]
    1. Screenshot of Intel Power Gadget
    -> attachment
    1. Clover (files only, no text pasted to Post)
      • EFI/CLOVER/config.plist
      • DPCIManager/Misc/Boot Log
      • EFI/CLOVER/ACPI/Patched/dsdt (if installed)
      • EFI/CLOVER/ACPI/Patched/ssdt (all)
    -> attachment

    thanks.
     

    Attached Files:

Share This Page