Contribute
Register

macOS Native CPU/IGPU Power Management

UtterDisbelief

Moderator
Joined
Feb 13, 2012
Messages
1,901
Motherboard
Gigabyte Z370M D3H
CPU
i3-8350K
Graphics
RX 560
Mac
iMac, Mac mini
Classic Mac
eMac, iBook
Mobile Phone
iOS
Would you be so kind to share your config.plist with me? (Via pm if you don't want it publically available)

I just want to compare what you have against mine, since we share almost similar motherboards (Maximus series), and see if I have overlooked something there that might be causing this issue?
What you have done so far to configure your USB ports. USBInjectAll.kext? An SSDT? FakePCIID and FakePCIID_XHCIMux kexts?
 
Joined
Nov 13, 2018
Messages
15
Motherboard
Asus Maximus VII Gene Z97-3503
CPU
i7-4790K
Graphics
RX 580
Mobile Phone
iOS
Probably not an Audio problem as such. Consider just the USB angle.

What you have done so far to configure your USB ports. USBInjectAll.kext? An SSDT? FakePCIID and FakePCIID_XHCIMux kexts?

Power management seems key here.
Thanks for your suggestion, I will go ahead and make a thread.

By the way, my problem is indeed not an Audio issue, but a USB issue. This happens for all USBs when used, the audio was just an example. My webcam, my mouse or my audio interface when used cause a spike @ max speed.

For my USB ports I am using USBInjectAll with a custom SSDT, alongside with FakePCIID and FakePCIID_XHCIMux kexts. The only issue I have with usb per se, is that I cannot rename my EC0 device to EC (as described in my post here)
 
Joined
May 16, 2018
Messages
62
Motherboard
ASRock Extreme 4
CPU
i7-8700k
Graphics
RX 560
@toleda
After I have inserted the command "sudo kextunload AppleIntelInfo.kext" in terminal this is the output i got.

"Can't open CFBundle for /Users/jaminwang/Desktop/AppleIntelInfo.kext/AppleIntelInfo.kext."

I did follow the instruction but couldnt get it working


INSTALLATION:
Baseline
  • IOReg
    • File/Save a Copy As...
  • AppleIntelInfo.kext (see, Tools/3., below)
    • Terminal/$ (Drag kext to terminal window)
      Code:
      sudo kextload AppleIntelInfo.kext
      • Permissions problem, Terminal/$
        Code:
        cd (Drag kext to terminal window)
        sudo chown -R root:wheel AppleIntelInfo.kext
        sudo chmod -R 755 AppleIntelInfo.kext
        sudo kextload AppleIntelInfo.kext
    • Let system idle for 2 minutes, then
    • Terminal/$
      Code:
      sudo cat /tmp/AppleIntelInfo.dat
      sudo kextunload AppleIntelInfo.kext
    • Terminal/Select AppleIntelInfo.kext output
    • Terminal/Shell/Export Selected Text As ...

 

toleda

Moderator
Joined
May 20, 2010
Messages
24,301
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
512K, LC, Power Mac
Mobile Phone
iOS
I have inserted the command "sudo kextunload AppleIntelInfo.kext" in terminal
kextload required before Kextunload can run
Post Terminal output (Terminal/Shell/Export Selected Text As ...)
 

toleda

Moderator
Joined
May 20, 2010
Messages
24,301
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
512K, LC, Power Mac
Mobile Phone
iOS
Here is the output
Not correct:
cd /Users/jaminwang/Desktop/AppleIntelInfo.kext

Correct:
Post #1/sudo kextload AppleIntelInfo.kext (Drag kext to terminal window)

Or if, Desktop/AppleIntelInfo.kext
cd Desktop
sudo kextload AppleIntelInfo.kext
 
Last edited:

toleda

Moderator
Joined
May 20, 2010
Messages
24,301
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
512K, LC, Power Mac
Mobile Phone
iOS
Joined
Dec 10, 2013
Messages
152
Motherboard
Huawei Matebook D 2017
CPU
i5-7200U
Graphics
HD 620
Hi,
i'm posting here because i think it's my issue is related to a power management problem.
Here is the issue :
After a fresh boot my laptop power consuming according to Intel Power Gadget at idle PKG 0.8 as showed in the screenshot i took attached to this post.
But after the laptop goes to sleep and wake up the Intel Power Gadget shows PKG at idle is 1.3 and never goes lower than that.
I don't see any processes after sleep that are using more cpu than before sleep. I tried to disable most of my kext (AppleALC, bluetooth , wifi etc) but i've always the same result. Could be some CPU power state that got "broken" after sleep ?

Could someone point me in the right direction ?


Thanks
Mattia
 

Attachments

Top