Contribute
Register

macOS Mojave is Now Available on the Mac App Store

Status
Not open for further replies.
Joined
Jan 15, 2014
Messages
15
Mac
Classic Mac
Mobile Phone
Update completed without any issues except for breaking my Wi-Fi (AR9380 / TP-Link TL-WDN4800). My WiFi icon simply says "WiFi: no hardware installed". It's never happened before, but I have Ethernet working so I'll keep on tinkering in the coming days.
It also broke my Wi-Fi. I was using a $20 Fenvi PCI-e Wi-Fi card I bought off Amazon. It has an Atheros chipset (not sure the exact model). It was working out of the box with no additional kexts or patches since Sierra.

Not sure if Apple have disabled support for it in Mojave. I'm not going to bother attempting to get it fixed, but just go out and buy an BCM94331CD which comes directly from the 2012 iMacs + PCI-e adapter. Hopefully that would give me better and more reliable Wi-Fi + Bluetooth.

Still, let me know if you find any fix for this, as I'd love to be able to use the Atheros until I get the Broadcom.
 
Joined
Oct 1, 2017
Messages
14
Motherboard
GIGABYTE z97X-gaming3
CPU
i7 4790k
Graphics
Nvidia GeForce GTX 1060 3G
Mac
  1. MacBook Air
Classic Mac
  1. iBook
Mobile Phone
  1. iOS
Updated successfully, just downloaded the installer from AppStore and run on High Sierra 10.13.6

Gigabyte Z97X-UD3H
i7-4790K
16 GB RAM DDR3
Intel HD Graphics 4600 with dual monitor HDMI + DVI
SSD Samsung 850 EVO 500 GB work with Trim enabled

Clover 4676
Kext:
  • AppleALC.kext by toleda with Clover Inject
  • AppleIntelE1000e.kext
  • FakeSMC.kext
  • Lilu.kext
  • NullCPUPowerManagement.kext
  • WhateverGreen.kext
It works very well and looks faster than High Sierra!


View attachment 352435
I have a same system ,because the nv-drivers are not released,so plan to use the Intel HD graphics ,so may I have a file of config.plist from you ,thank you very very much!
 
Joined
Nov 13, 2017
Messages
4
Motherboard
MSI B150 PC Mate
CPU
i5-6600
Graphics
GTX 1060
Mobile Phone
  1. iOS
Joined
Jun 25, 2017
Messages
55
Motherboard
Gigabyte GA-Z87-D3HP
CPU
i5-4670
Graphics
RX 560
Mac
  1. MacBook Air
Classic Mac
  1. Performa
Mobile Phone
  1. iOS
Black screen for me on install.
Unplugged my second monitor plugged into the 560, and it appears to be installing ok at the moment (28 min remaining...). It may have been installing before, but as screens were black i couldn't see. fingers crossed.
 
Joined
Jan 15, 2014
Messages
15
Mac
Classic Mac
Mobile Phone
I did some research and found out Apple did remove Wi-Fi/Bluetooth support for some Atheros cards AR92xx/93xx in Mojave.

I also found out you can get it back with a little easy trick:
  1. On High Sierra 10.13.6, go to System > Library > Extensions > IO80211Familly.kext > Contents > Plugins
  2. Copy AirPortAtheros40.kext and install it in L/E of Mojave drive (make sure you use KextBeast for installation).
  3. Rebuild kext caches with terminal - sudo kextcache -i /
In my case I didn't even have reboot. Wi-Fi works again immediately after kext rebuild.

I guess I'll hold out on the BCM94331CD/BCM94360CD some other time.

Only issue now is that the fans on my Vega 56 likes to rev up suddenly and not go down. I have to either restart or sleep to get it quiet again.
 
Joined
Jun 25, 2017
Messages
55
Motherboard
Gigabyte GA-Z87-D3HP
CPU
i5-4670
Graphics
RX 560
Mac
  1. MacBook Air
Classic Mac
  1. Performa
Mobile Phone
  1. iOS
Black screen for me on install.
Unplugged my second monitor plugged into the 560, and it appears to be installing ok at the moment (28 min remaining...). It may have been installing before, but as screens were black i couldn't see. fingers crossed.

That did it! got stuck on login (on the page wanting me to give crash reports to apple), but a reboot sorted it. Both screens plugged back in and all working now.
 

UtterDisbelief

Moderator
Joined
Feb 13, 2012
Messages
5,231
Motherboard
Gigabyte Z390M Gaming - Clover 5102
CPU
i5-9600K
Graphics
RX 570 1920x1080
Mac
  1. iMac
  2. Mac mini
Classic Mac
  1. eMac
  2. iBook
Mobile Phone
  1. iOS
Well I downloaded the Installer but after reading 15-pages of posts and probably 50-50 problems I'm hanging back on actually installing it yet.

1) Still unclear as to where we stand with HFS+. Are HDDs now also formatted at APFS? Any way to force SSDs install to remain HFS+ ?
Does the old script still work?

2) Which WiFi chips have been deprecated?

3) Does NVRAM emulation still work for GPUs and iMessage?

4) Any major apps still not updated for Mojave? 32-bit?

Etc etc.

:rolleyes:
 
Joined
Sep 15, 2015
Messages
151
Motherboard
Gigabyte GA-Z97X-GAMING 3
CPU
i7-4790K
Graphics
Sapphire Nitro RX 480 OC
Mac
  1. MacBook Pro
These are Kepler Cards and natively supported, no needfor webdrivers with correct smbios

No, it's not that simple. Nvidia mixed the Kepler and Maxwell architectures in the 700 series. The GTX 745, GTX 750 and GTX 750 Ti are Maxwell based cards and not supported with the native macOSX drivers.
 
Joined
Mar 9, 2012
Messages
2,403
Motherboard
Gigabyte Z390 AORUS Pro WFI
CPU
i5-9400F
Graphics
RX 580
Mac
  1. iMac
  2. Mac Pro
Mobile Phone
  1. iOS
Will UniBeast and MultiBeast for Mojave be available?

Clover is very complicated for me :(

Hi Clover is not that complicated really - you have the same GA-Z87X as my board so if I may offer you the selections you need to make in Clover to get a successful install, just select all the options in the screen shot and then install to reach the desktop.
In the kext 'Other' folder you will need these latest versions (included with the post). Please let us know how you got on. Good luck.
 

Attachments

  • Screenshot 2018-09-25 at 10.40.11.png
    Screenshot 2018-09-25 at 10.40.11.png
    2.1 MB · Views: 456
  • Archive.zip
    1,012.6 KB · Views: 57
Status
Not open for further replies.
Top