Contribute
Register

Solved > macOS Mojave/High Sierra Boot Install Failure - AsRock Z370 Extreme4, i7-8700k

Joined
Dec 28, 2019
Messages
8
Motherboard
ASRock Z370 Extreme4
CPU
i7-8700K
Graphics
GTX 1080 + RX 580
Solution Update:
Adding the "NvmExpressDxe.efi" driver solved it for me. There was no need to take any steps other than that, assuming that you already had the correct BIOS settings.

Hello,

I'm trying to take a stab at making my first hackintosh and I've gotten stuck on 1 issue for the past day. I'll list information about my setup and then proceed to detail and provide pictures of my issue, along with whatever troubleshooting steps I have attempted so far.

Specs:

MOBO: AsRock Z370 Extreme4 (Latest BIOS(4.20))
CPU: Intel i7-8700k
RAM: 32GB(16x2) G.Skill RIPJAWS V 3000Mhz
GPU: NVIDIA GTX 1080(Solely for Windows gaming, I'll be using the iGPU for macOS... for now)

Storage:
BPX 250GB M.2 NVME SSD(I would be using this drive to install macOS on)
HP EX950 1TB M.2 NVME SSD(Windows 10 is installed on this drive)
500GB Samsung 840 SSD(General storage drive)

BIOS Settings:
  1. OC Tweaker \ DRAM Configuration → Load XMP Setting : XMP 2.0 Profile 1
  2. Advanced \ CPU Configuration → Intel Virtualization Technology : Enabled
  3. Advanced \ Chipset Configuration → Vt-d : Disabled
  4. Advanced \ Chipset Configuration → IOAPIC 24-119 Entries: Enabled
  5. Advanced \ Storage Configuration → Sata Mode Selection: AHCI
  6. Advanced \ Super IO Configuration → Serial Port: Disabled
  7. Advanced \ USB Configuration → Legacy USB Support : Enabled
  8. Advanced \ USB Configuration → PS/2 Simulator : Disabled
  9. Advanced \ USB Configuration → XHCI Hand-off : Enabled
  10. Security \ Secure Boot → Secure Boot: Disabled
  11. Boot → Fast Boot: Disabled
  12. Boot → Boot From Onboard LAN: Disabled
  13. Advanced \ Chipset Configuration → Primary Graphics Adapter : Onboard
  14. Advanced \ Chipset Configuration → Share Memory : 128MB
  15. Advanced \ Chipset Configuration → IGPU Multi-Monitor : Enabled

Problem:
I'm trying to install macOS(either Mojave or High Sierra) but the installation boot stalls after an "AppleNVME Assert Failed" line, shortly after which some glitchy text appears on screen. I've uploaded some pictures of it below -- sorry in advance for the quality they were taken with an old tablet I had on hand. I've also uploaded the EFIs I was using, one of which was taken from a user's build who's was similar to mine but it occurs regardless of which EFI I use, macOS version, and installation method.

What I've tried so far:
  1. Install both Mojave and High Sierra
  2. Completely uninstalled my GPU
  3. Removed 1 of the 2 DIMM slots
  4. Removed any unnecessary USB devices(Audio, Keyboard's USB passthrough cable, Wireless mouse receiver)
  5. Plugging my USB 2.0 Flash Drive to different ports/Using different drives
  6. Vanilla Install
  7. UniBeast Install
  8. Mattystonnie's ACPI Patch
  9. Enabling USB Ownership and USB Injection on Clover's bootloader
  10. Different EFI configs taken from other users' builds with similar specs to mine(Uploaded one)

Would be happy to try any suggestions you guys may have... let me know if there is anything else that I can provide. Thanks in advance for your responses and happy new years!
 

Attachments

Last edited:
Joined
Jul 31, 2012
Messages
14
Motherboard
GA-Z77X-UD5H
CPU
i7-3770K Ivy bridge
Graphics
nvidia gtx 680
Mac
Classic Mac
Mobile Phone
Have you been able to find a fix?
 
Joined
Dec 28, 2019
Messages
8
Motherboard
ASRock Z370 Extreme4
CPU
i7-8700K
Graphics
GTX 1080 + RX 580
Hello!

An update: As it turned out, all that I needed to do was to add the "NvmExpressDxe.efi" driver and the installation went through without a hitch from start-to-finish =)! After doing so I did not have to take any of the troubleshooting steps I had listed... Booted with everything connected as I'd normally do when I boot into Windows.

I initially installed Catalina on it instead but I was promptly reminded of just how much I was going to miss having a 144Hz display so within an hour I proceeded to install High Sierra using the EFI I uploaded on my OP and downloaded "NvmExpressDxe-64.efi" from some github I found to it. I'll be going back to Catalina once I get my hands on an AMD card(Dark Mode is the bees knees, yo).

Anyways, hope this helps anyone else reading this and having a similar issue.

I'll attach that EFI to this post later today once I get on my PC in case anyone wants it.
 
Top