Contribute
Register

macOS High Sierra Public Beta 7 is Now Available

tonymacx86

Administrator
Staff member
Joined
Nov 18, 2009
Messages
8,490
Motherboard
GA-Z270X-UD5
CPU
Core i3-7100
Graphics
HD 630
Mac
MacBook Pro, Mac mini
Classic Mac
Apple, PowerBook
Mobile Phone
iOS
The macOS High Sierra 10.13 Public Beta 7 is now available. Apple wants as many users as possible to test macOS High Sierra to provide constructive feedback before the official release later this fall. To participate in the free Public Beta, you must enroll in the Apple Beta Software Program using your Apple ID.

Enroll in the Free Apple Beta Software Program
https://beta.apple.com/sp/betaprogram/welcome

This site will allow discussion of this software and its installation for those who have enrolled. Users can post for support in the following areas: High Sierra Desktop Support, High Sierra Desktop Guides, High Sierra Laptop Support and High Sierra Laptop Guides.

If you're installing the Public Beta, let us know how it goes!

Related:
macOS High Sierra Public Beta 6 is Now Available
macOS High Sierra Public Beta 5 is Now Available
macOS High Sierra Public Beta 4 is Now Available
macOS High Sierra Public Beta 3 is Now Available
macOS High Sierra Public Beta 2 is Now Available
macOS High Sierra Public Beta is Now Available
How to Create a macOS High Sierra Public Beta Installation USB
Introducing the macOS High Sierra Critter!
High Sierra Desktop Support
High Sierra Desktop Guides
High Sierra Laptop Support
High Sierra Laptop Guides
Apple Reveals macOS High Sierra at WWDC - Available Fall 2017
 
Joined
Oct 31, 2010
Messages
52
Motherboard
GA-P55 USB3
CPU
i7-870
Graphics
HD 7750
Mac
MacBook Pro
Mobile Phone
Android
Not working for me (upgrade from Sierra or clean install), latest Clover, I believe my Radeon 7750 is the culprit, various fixes (verde.kext, patched fakesmc or lilo + green) don't work for me in High Sierra it seems. Anyway, it will work eventually, I guess I have to show some patience until 10.13 is properly released with unibeast, multibeast and stuff.

I use smbios mac pro 5,1 but that was a no go due to firmware, so tried mac pro 6,1 which allowed me to try to upgrade.

Update: (In case someone with similar motherboard and/or older graphics cards reads)
Using Clover 4184 and Nvidia Inject, and creating SMBIOS for Mac Pro 6,1 in Clover Configurator I got the install and High Sierra running using an old Nvidia GeForce GT 320 1GB DDR3 as graphics card.
Once High Sierra was running I also tried with an even older Asus Nvidia GeForce 8400GS Silent 512MB, and using Nvidia Inject it appears to work.
Then I tried with ASUS EAH Radeon 6670 Silent 1GB DDR3, and it also seems to work. This card is quite OK for my needs, so in case I don't get my ASUS 7750 running at least I have other options for High Sierra.

Once installed I went back to Mac Pro 5,1 , I have previously had issues with cpu frequencies with 6,1.

GT320.png
GS8400.png
Radeon6670.png
 
Last edited:
Joined
Mar 24, 2011
Messages
215
Motherboard
P55 Micro SLI
CPU
Core i5 760 @ 3.5GHz
Graphics
EVGA GTX 760 SC 2048MB
Classic Mac
512K
Mobile Phone
Android
The latest version of Lilu and the other kexts now support High Sierra. If not, in the case of lilu, you can add -lilubeta in your boot args and it will work. The same with other lilu kexts but I don't know the specific sintax.

In my case the update went flawless.

Cheers!
 
Joined
Jun 17, 2015
Messages
202
Motherboard
Asus P5P41TED
CPU
E8500
Graphics
GT 6200
Mobile Phone
Other
Refused to boot at first, it seemed the old DSMOS issue I had on the first beta builds was back (it happened at both attempts to install), then reset and pressed F2 at Clover, to get preboot.log , and it booted fine. High Sierra gave the weirdest errors since I started hackintoshing. The preboot logs for both the first boot of the installed OS from the pen drive and for the finalised installation are attached in here https://www.tonymacx86.com/threads/acpi-dynamic-oem-table-load-error-waiting-for-dsmos-horrible-performance.226097/page-5#post-1571898
 
Last edited:

aol

Joined
Apr 14, 2011
Messages
513
Motherboard
GA-Z370-HD3P
CPU
i7-8700K
Graphics
RX570
Mac
MacBook Pro, Mac Pro
Mobile Phone
iOS
Another smooth upgrade now that I've figured out my process. I'm on a GA 10 series board using SMBIOS iMac 14,2, dual monitors on a pascal 1060 card, installing HSB to an APFS-formatted SSD. I'm using apfs.efi from beta 6 and clover 4152.
- boot normal, update from App Store
- upon installer reboot, boot from USB stick with clover 4152 and without emuvariables64efi kext, and select the temporary "install macOS" partition in clover boot partition menu, arrive at secondary installer, let that run, reboot
- boot normal to HSB desktop
- to get 1060 to somewhat kinda run (dual monitors work but it's still glitchy as heck) I followed the guide in the forum #1 (credit @kgp), just the graphics part, involving using patched installer, a "NVIDIA WebDriver Updater" utility that updates NvidiaWeb.kext with the current macOS version and overwriting AppleGraphicsControl.kext with the 10.12.6 version; having done that previously, with each beta update, I just have to redo the NVIDIA WebDriver Updater part and the overwrite AGC.kext part
- re-download the new full installer, extract apfs.efi, and copy into various clover installs for the next time

Thanks!
 
Top