Contribute
Register

macOS High Sierra is Now Available on the Mac App Store

Joined
Dec 21, 2015
Messages
24
Motherboard
MSI Z97 Gaming 5 ATX
CPU
Intel Core i7 4790k
Graphics
ZOTAC GeForce GTX 1060 6GB AMP! Edition
Mac
MacBook Pro
Mobile Phone
Android, iOS
Hello! what do you mean by this (disconnect/disable ALL discrete GPUs )?
In this context, disabling means at a hardware level on the Mobo; Clover should NOT be able to detect the NVIDIA cards, and using nv_disable = 1 does NOT fix the issue. If you cannot disable it in your Mobo's BIOS (I feel like this should be a thing for some newer motherboards, but I know it's not the case for most), then you'll have to physically disconnect the cards.
 
Joined
Aug 21, 2011
Messages
46
Motherboard
Lenovo ThinkPad X20-(Clover
CPU
i5-540M
Graphics
HD
Thanks everyone for giving the upgrade a try and me the confidence to try it myself. :)

It all went well! Only had to copy the apfs.efi driver for Clover to the EFI partition. :)
 
Joined
Jun 20, 2014
Messages
978
Motherboard
Gigabyte Aero 15X v8-BK4K4P
CPU
i7-8750H
Graphics
UHD 630 / GTX 1070 Max-Q / 4K
Successfully updated to macOS 10.13 High Sierra.

- Dual boot High Sierra + Windows 10
- 4k 1080p60 HiDPI working (using CoreDisplayFixup)
- I opted to keep the file system as HFS+ (using --converttoapfs NO)
- Ran audio_cloverALC-130_v0.3.command to restore audio

Had a few issues along the way:
- An error occurred while verifying firmware
- The path /System/Installation/Packages/OSInstall.mpkg appears to be missing or damaged

To solve the above two issues run the latest version of Clover Configurator and re-select your system configuration to update the SMBIOS info (I recommend pasting back your Serial Number if you've already got iMessage etc. working).

For working 4k I compiled the latest versions of Lilu 1.2, Shiki, IntelGraphicsFixup and CoreDisplayFixup. You can download my compiled versions here: Lilu 1.2 + Plugins.zip.
 
Last edited:
Joined
Oct 22, 2015
Messages
25
Motherboard
GA-Z170X-UD5 TH
CPU
i7-6700K
Graphics
Gigabyte GeForce GTX 960
Mac
MacBook
Classic Mac
iBook
Some trouble after upgrading mainboard firmware of Z170X, as I couldn't boot at all anymore.
After figuring out, everything else went "normal": USB and audio needed fixes.
Not yet overclocked – but benchmarks are only about 5 % weaker than they were on my Sierra install with 4,4 GHz.

About This Mac.png
 
Joined
Jul 25, 2015
Messages
13
Motherboard
GA97
CPU
i3-4330
Graphics
R9 270
In this context, disabling means at a hardware level on the Mobo; Clover should NOT be able to detect the NVIDIA cards, and using nv_disable = 1 does NOT fix the issue. If you cannot disable it in your Mobo's BIOS (I feel like this should be a thing for some newer motherboards, but I know it's not the case for most), then you'll have to physically disconnect the cards.
YES. un-hooked nv card.
Installer went its way till it found something missing.
Reloaded the installer from AppStore.
Installation restarted and ended up satisfacorily.
Started HS with the iGPU, installed nv wev drivers (which didn't complain about the absence of nv card..!).
Reboot and disable IGPU.
Hook nv card and .. voilà.
Succes, finally.
Thks to all of you!
 
Top