Contribute
Register

macOS does not boot with newer BIOS

Joined
Jan 24, 2013
Messages
5
Motherboard
Rampage V Extreme
CPU
i7-5960X
Graphics
GTX 1080 Ti
Hello,

I have a working macOS 10.14.2 installation as long as the motherboard BIOS version is 3101 or earlier. With any newer BIOS such as 3202, the screen is stuck on "PCI configuration begin". How can I debug this and find the cause?

I have compared settings between these versions, compared DSDT (a few changes like added devices), compared the UEFI images (too many changes for me to reverse), tried every BIOS newer than 3101, tried different Clover settings and more. I also tried to remove the new devices from the DSDT to no avail.

My goal is to update to version 3801 (latest stable), but I am trying with 3202 first because it is the next version after 3101 with fewer changes.

Thank you for any assistance you can provide!

MB: ASUS Rampage V Extreme
CPU: i7-5960X
GPU: GTX 1080 Ti, Radeon HD 7970
RAM: Crucial Micron, 32 GB
SSD: 970 EVO (NVMe) and a bunch of S-ATA SSDs

Clover: v4813
 

Attachments

  • DSDT_BIOS_3101.zip
    52.8 KB · Views: 82
  • DSDT_BIOS_3202.zip
    52.9 KB · Views: 26
Last edited:
Joined
Jun 3, 2017
Messages
5
Motherboard
ASUS WS Sage X299
CPU
i9-7940X
Graphics
RX 580
Mac
  1. MacBook
  2. MacBook Air
  3. Mac mini
  4. Mac Pro
Mobile Phone
  1. iOS
Try disabling CSM

I had the same problem on:
Gigabyte designare ex x299 after update from bios f3 to f4c

Downgrading to f3 10.4.x booted fine. (clover configurator 5.4.3.1 and clover 4920)
created new dsdt, and still problem.

Found that after the update, CSM was enabled.
Disabled it, and MacOS 10.14.4 again starts fine. (no other changes)

MB: Gigabyte designare ex x299
cpu: i9-7940x
gpu: radeon nitro rx580 8Gb
NMVE: Samsung 970 evo 1tb
 
Joined
Jan 24, 2013
Messages
5
Motherboard
Rampage V Extreme
CPU
i7-5960X
Graphics
GTX 1080 Ti
Hello,

Thanks for your reply and sorry for getting back to you late.

Since I have to disable CSM anyway, it is already disabled and therefore cannot help me.

I was never successful with any DSDT modification so I am not using any custom DSDT.

Thank you!
 
Last edited:
Joined
Jun 21, 2010
Messages
269
Motherboard
Gigabyte Z490 Aorus Elite AC-F4 OC0.6.4
CPU
i5-10600K
Graphics
RX 580
Mac
  1. MacBook Pro
Classic Mac
  1. iMac
Mobile Phone
  1. Android
  2. iOS
Would you please change the thread title to solved?
 
Joined
Jan 24, 2013
Messages
5
Motherboard
Rampage V Extreme
CPU
i7-5960X
Graphics
GTX 1080 Ti
Hello kiu77,

My problem has not yet been solved.
 
Joined
Jan 24, 2013
Messages
5
Motherboard
Rampage V Extreme
CPU
i7-5960X
Graphics
GTX 1080 Ti
I have now, but it does not seem to do anything for me (maybe the patch does not apply to my board). I also tried the "FixRTC" option in my Clover config to no avail because the poster said it was an "RTC fix".

Just in case anyone is interested, I have now attached my original (disassembled) DSDT files for BIOS version 3101 and 3202 in the original post.
 
Last edited:
Joined
Oct 4, 2014
Messages
258
Motherboard
ASUS X299 Sage/10g
CPU
i9-10980XE
Graphics
Radeon VII
I have now, but it does not seem to do anything for me (maybe the patch does not apply to my board). I also tried the "FixRTC" option in my Clover config to no avail because the poster said it was an "RTC fix".

Just in case anyone is interested, I have now attached my original (disassembled) DSDT files for BIOS version 3101 and 3202 in the original post.
Hi there, did you ever find a fix for this? I can't boot with any newer BIOS on my ASUS Sage/10g
 
Joined
Nov 7, 2011
Messages
8
Motherboard
Asus H310T/CSM
CPU
i5-8500
Graphics
UHD 630
Sounds similar to a problem I had after updating ASUS bios.
In bios go to: Advanced\PCH Configuration\System Time and Alarm Source
Change 'System Time and Alarm Source' to "Legacy RTC"
See thread:
 
Top