Contribute
Register

macOS Catalina Public Beta is Now Available

Status
Not open for further replies.
Joined
Jan 13, 2013
Messages
30
Motherboard
GA-H97N-WIFI
CPU
i7-4790
Graphics
RX 570
Mobile Phone
  1. iOS
Just to conclude on my graphics issues... I gave up. Sorry. Instead of trying to get the Intel HD 4600 to work I went out and got a Radeon RX 570 8 GB. No issues since I put the new card in.

Catalina still chokes on sleep, something I had worked out in Mojave. But I don't have the time or energy to work it out. Otherwise, Catalina is working well.
 
Joined
Feb 19, 2018
Messages
793
Motherboard
Gigabyte TRX40 Aorus Xtreme
CPU
Ryzen 3970X
Graphics
RX 6900 XT
Mac
  1. MacBook
  2. MacBook Pro
Classic Mac
  1. Xserve
Mobile Phone
  1. iOS
Dang 2020? I for some reason thought we would see it this September with the release of new Apple products... man that’s a long wait haha. Okay though, that’s what I figured but wanted a more knowledgeable person to verify my thoughts. Thanks!

10.15.0 will be out soon, probably late September / early October.

In the mean time you could dual boot between Mojave and Catalina if you want to experiment and see what the major differences are are test if all your apps work properly.
 

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
13,114
Motherboard
Gigabyte Z690 Aero G
CPU
i5-12600K
Graphics
RX 6800 XT
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
10.15.0 will be out soon, probably late September / early October.

In the mean time you could dual boot between Mojave and Catalina if you want to experiment and see what the major differences are are test if all your apps work properly.
I've used macOS 10 since the beginning after macOS 10 replaced version 9. It has taken Apple to release version 10.x.3 to work the bugs out of the system. I don't use a new macOS 10 until then. Consequently, I don't recommend using a new macOS until 10.x.3 for production work.
 
Joined
Jul 29, 2019
Messages
4
Motherboard
Gigabyte H370N Wifi
CPU
i5-9400
Graphics
UHD 630
Mac
  1. Mac mini
Everything worked fine on my build until Beta 6. Audio is not working.
 
Joined
Dec 16, 2016
Messages
130
Motherboard
Msi z270 pro carbon
CPU
i7 7700k
Graphics
RX 580 + GTX 1080
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. Android
I reinstall and everything is working perfectly. The only thing I could install last version of Clover boat loader. So I copy the entire EFI folder of Mojave
 
Joined
Apr 30, 2010
Messages
653
Motherboard
GA-Z270XP-SLI
CPU
i5-7600K
Graphics
RX 580
Mac
  1. iMac
Classic Mac
  1. Classic
Mobile Phone
  1. Android
Everything works just like any other update! Awesome. Just installed latest Lilu.kext
But I have one question although it may be too soon to ask it. Do you think it will stay that way for all the other updates til the release this fall?
As Yogi Berra said, “It's tough to make predictions, especially about the future”
 
Joined
Jul 29, 2019
Messages
4
Motherboard
Gigabyte H370N Wifi
CPU
i5-9400
Graphics
UHD 630
Mac
  1. Mac mini
Yes! Completely reinstalling Catalina on another partition solved the audio issue, and everything worked. However, for some reason my Mojave partition was affected and would cause a kernel panic when I would try to boot into Mojave. The same happened vice versa when I re-installed Mojave on that partition; the Catalina partition was affected and caused a kernel panic when I tried booting from Catalina. I would suggest installing on a completely different hard drive if you don't want to mess up your main partition.
 
Joined
Aug 28, 2019
Messages
39
Motherboard
intel DZ77GA-70K
CPU
i7-3770K
Graphics
RX 580
Mac
  1. iMac
Mobile Phone
  1. Android
Public Beta 7 is out, upgrading from 6-7 went smooth. Random crash/reboot are still there on my system, probably due to either not clean installed/beta bug, I am not gonna bother with it until final release.

PS.
It seems the random crash/reboot issue was caused by having the "Put hard disks to sleep when possible." option turned on in System Preferences/Energy saver, probably only happens to system with mechanical drives like dvd drive or non-ssd drive. I always had this option turned on in previous MacOS version without problem.
 
Last edited:
Joined
Sep 1, 2016
Messages
442
Motherboard
Gigabyte Z490 I Aorus Ultra
CPU
i9-10900K
Graphics
RX 580
Installed the latest last night... had to manually select the installer on reboot again, but a successful update with everything apparently still working.
 
Status
Not open for further replies.
Top