Contribute
Register

macOS Catalina 10.15.0 - USB Port-Limit Removal Patch

UtterDisbelief

Moderator
Joined
Feb 13, 2012
Messages
8,025
Motherboard
Gigabyte Z590i Aorus Ultra - OC 0.8.0
CPU
i5-10600k
Graphics
Dell RX560
Mac
  1. iMac
  2. Mac mini
Classic Mac
  1. eMac
  2. iBook
Mobile Phone
  1. iOS
Hello Again!!

I just can't understand why, but such is life as a hackintosher!

I went to the hackintool USB Tab to make the screenshot and, guess what? I realized that one of my external hard drives were recoginized (they were the ones that I was struggling yesterday).

However I knew I could count on you! All I need is "a little help from my friends"!

Here is the screenshot you asked for:View attachment 524036

The ones I needed to work were the HS3 and HS4, now they work correctly. How? I just don't know!

Anyway, now I am heading towards, big sur. Any advice?

Thanks a lot!

Advice? Yes. Your USB configuration is wrong. Probably caused by an incorrect kext. However I can't tell from the one screengrab what that problem is.

If you are happy everything is working okay for you, then for Big Sur you need to switch to OpenCore. Clover r5124+ will work but OC is safer.
 
Joined
Aug 28, 2016
Messages
133
Motherboard
Gigabyte Z390 Gaming SLI
CPU
i7-8700
Graphics
Vega 56
Mobile Phone
  1. Android
  2. iOS
Advice? Yes. Your USB configuration is wrong. Probably caused by an incorrect kext. However I can't tell from the one screengrab what that problem is.

If you are happy everything is working okay for you, then for Big Sur you need to switch to OpenCore. Clover r5124+ will work but OC is safer.
Thanks!

Would you mind helping me figuring what is wrong with the USB configuration out? I want to go to big sur next.

What do you need? Config files? EFI Folder ?

Cheers!
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
27,621
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
zipped OC or Clover folder
Thanks!

Would you mind helping me figuring what is wrong with the USB configuration out? I want to go to big sur next.

What do you need? Config files? EFI Folder ?

Cheers!
 

UtterDisbelief

Moderator
Joined
Feb 13, 2012
Messages
8,025
Motherboard
Gigabyte Z590i Aorus Ultra - OC 0.8.0
CPU
i5-10600k
Graphics
Dell RX560
Mac
  1. iMac
  2. Mac mini
Classic Mac
  1. eMac
  2. iBook
Mobile Phone
  1. iOS
Thanks!

Would you mind helping me figuring what is wrong with the USB configuration out? I want to go to big sur next.

What do you need? Config files? EFI Folder ?

Cheers!

Okay, I had to remove your EFI upload post because you had left your serial-numbers in the config.plist.

As for the EFI itself. It is running Clover r5138 which is the new one with OpenCore add-ons. It also had both drivers/UEFI folders and drivers64UEFI/. You should only have one - the first.
The config.plist had no port-limit removal patch for Catalina, only Mojave. And it is a config from a pre-r5123 version of Clover with no Quirks listed.
There was a USBPorts.kext with only 8x , but duplicated, ports for some reason.
You have duplicated kexts in 10.15 and Other folders. Use only the latter.
 
Joined
Aug 28, 2016
Messages
133
Motherboard
Gigabyte Z390 Gaming SLI
CPU
i7-8700
Graphics
Vega 56
Mobile Phone
  1. Android
  2. iOS
Okay, I had to remove your EFI upload post because you had left your serial-numbers in the config.plist.

As for the EFI itself. It is running Clover r5138 which is the new one with OpenCore add-ons. It also had both drivers/UEFI folders and drivers64UEFI/. You should only have one - the first.
The config.plist had no port-limit removal patch for Catalina, only Mojave. And it is a config from a pre-r5123 version of Clover with no Quirks listed.
There was a USBPorts.kext with only 8x , but duplicated, ports for some reason.
You have duplicated kexts in 10.15 and Other folders. Use only the latter.
Wow!

So many things wrong!!! I wasn't aware of them.

So first thing : Remove the drivers64UEFI Folder.

Second thing: Port-limit removal for Catalina. As far as I'm concerned, I followed Utterdisbelief's instructions in this post: https://www.tonymacx86.com/threads/macos-catalina-10-15-0-usb-port-limit-removal-patch.285098/ and here is what I see in Clover Configurator:

Screen Shot 2021-07-09 at 10.51.36.png

And, as far as I'm concerned, USBInjectAll.kext is installed.

Third: USBPorts.kext I created it to work on mojave and I even wrote a guide in this thread:


It worked well on my mojave build but I was testing if it could work on Catalina. So, Should I remove it and create another one?

Fourth: Yes, I do have duplicated Kexts in 10.15 and Other Folders, This is because I don't know where Catalina is reading them from. There is a thread from my good friend PastryChef where he was making a poll where Kexts should be placed:

Many where saying /EFI/CLOVER/kexts/Other, but at a moment it was not working for me, so I copied to /E/C/K/10.15 but I did not erased the copies from /E/C/K/O (sorry my font changed).

I am thinking in erasing the ones in /E/C/K/10.15

With all those changes, would my EFI now be correct?

Thanks a lot for your time.
 

UtterDisbelief

Moderator
Joined
Feb 13, 2012
Messages
8,025
Motherboard
Gigabyte Z590i Aorus Ultra - OC 0.8.0
CPU
i5-10600k
Graphics
Dell RX560
Mac
  1. iMac
  2. Mac mini
Classic Mac
  1. eMac
  2. iBook
Mobile Phone
  1. iOS
Wow!

So many things wrong!!! I wasn't aware of them.

So first thing : Remove the drivers64UEFI Folder.

Second thing: Port-limit removal for Catalina. As far as I'm concerned, I followed Utterdisbelief's instructions in this post: https://www.tonymacx86.com/threads/macos-catalina-10-15-0-usb-port-limit-removal-patch.285098/ and here is what I see in Clover Configurator:

View attachment 524197

And, as far as I'm concerned, USBInjectAll.kext is installed.

Third: USBPorts.kext I created it to work on mojave and I even wrote a guide in this thread:


It worked well on my mojave build but I was testing if it could work on Catalina. So, Should I remove it and create another one?

Fourth: Yes, I do have duplicated Kexts in 10.15 and Other Folders, This is because I don't know where Catalina is reading them from. There is a thread from my good friend PastryChef where he was making a poll where Kexts should be placed:

Many where saying /EFI/CLOVER/kexts/Other, but at a moment it was not working for me, so I copied to /E/C/K/10.15 but I did not erased the copies from /E/C/K/O (sorry my font changed).

I am thinking in erasing the ones in /E/C/K/10.15

With all those changes, would my EFI now be correct?

Thanks a lot for your time.

You have USBInjectAll kext in two places - outside the kext folders and inside the 10.15 folder.

You have three config files but the one which Clover uses is config.plist. That one only has Mojave PLRPatches - "as far as I'm concerned" :D No Catalina. If you have the file you show in your screengrab, it is not what you uploaded.

Again if the USBPorts.kext is the one you uploaded and wrote a guide about - and you want just 8x ports working - that's your choice. No problem ... Except you would not use USBInjectAll.kext and port-limit removal patches as well.

As for correct kext folders ... Catalina does not read anything from your EFI folder, only Clover does and it injects the necessary kexts into the OS where needed, bypassing the kextcaches. Nowadays most builds put all kexts in the Other folder. We only use the others if we are dual-booting different versions of macOS on the same EFI. Very rare.
 
Joined
Aug 28, 2016
Messages
133
Motherboard
Gigabyte Z390 Gaming SLI
CPU
i7-8700
Graphics
Vega 56
Mobile Phone
  1. Android
  2. iOS
You have USBInjectAll kext in two places - outside the kext folders and inside the 10.15 folder.
OK, Will remove it from all places.

You have three config files but the one which Clover uses is config.plist. That one only has Mojave PLRPatches - "as far as I'm concerned" :D No Catalina. If you have the file you show in your screengrab, it is not what you uploaded.

Yes I have 3 since I was doing some tests and didn't want to mess it up, so I could have a backup. I will remove the ones I am not using.

Again if the USBPorts.kext is the one you uploaded and wrote a guide about - and you want just 8x ports working - that's your choice. No problem ... Except you would not use USBInjectAll.kext and port-limit removal patches as well.
Yes, that is the one I created and left only those ports that needed in my hack. I did that file because I installed an HX851i PSU in my system and connected it to the USB port. The problem was the communication through it was waking up my rig, so I had to make that USBPorts.kext in order OSX to disregard that USB port. Now I won't be needing USBInjectAll.kext so I'm removing it

As for correct kext folders ... Catalina does not read anything from your EFI folder, only Clover does and it injects the necessary kexts into the OS where needed, bypassing the kextcaches. Nowadays most builds put all kexts in the Other folder. We only use the others if we are dual-booting different versions of macOS on the same EFI. Very rare.
Thank you so much for that explanation, I didn't know that and now I will know what to do!

Now I will continue my journey to Big Sur, but Now I will migrate to Open Core first.

Again, thanks a lot and have a great Weekend!
 
Top