Contribute
Register

macOS 14.1 Update

why remove the boot argument once update is finished?
macOS would believe that this "Mac" gets 8 PCIe slots and "3 DRAM slots" are installed with 4 memories. I don't feel good with these.
 
Wooooo!, no idea how long it took, it updated while I was at work, came home to 23B73. Booting OpenCore 0.9.5, where’s the drama Apple?. To get the incremental update I disabled BlueToolFixup and added 'revpatch=cpuname,pci,sbvmm’ to my boot args, thanks to XtremeXT for that tip.
Screenshot 2023-10-25 at 8.45.54 PM.png

 
Last edited:
I updated my Dell Vostro 3480 laptop from Sonoma 14 (with OCLP Wi-Fi patches) to 14.1.

  1. Downloaded full Sonoma 14.1 installer via Terminal.
  2. Used OCLP to revert patches.
  3. Installed 14.1.
  4. Used OCLP to install Wi-Fi patches.
All working.

Screenshot 2023-10-25 at 8.55.24 PM.png
 
Last edited:
I had to download the full 14.1 installer from the mac app store. There was no incremental update. Other than that, all went well.
 
Updated from 14.0, via auto update. It worked! OC 0.9.5 and latest kexts. Not using WiFi on this machine.
 
Screenshot 2023-10-26 at 14.27.00.jpg
  • Updated from 14.0 to 14.1 using software update which downloaded full 12.x GB image;
  • No issues installing;
  • OCLP prompted me to patch for my Broadcom WiFi.
Easy peasy lemon squeezy!
Bonza!
 
Had to download the full installer too, no delta update made available. Major issue with install procedure after second reboot : infinite reboot loop and previous system (14.0) unbootable. Tried to do a clean install on a new nvme drive : same issue.
On an usb 3.0 external SSD the install process went through and I cloned that fresh install to make my nvme drive bootable again.
 
Not nearly as painful as I imagined. Yes, Software Update pulled down the whole 12gb image but after 20 minutes and few reboots I was up and running 14.1. OCLP then quite politely asked me to reapply my root patches and Voila my Broadcom WiFi lives another day.
 

Attachments

  • Screenshot 2023-10-26 at 8.45.22 AM.png
    Screenshot 2023-10-26 at 8.45.22 AM.png
    2.1 MB · Views: 70
Last edited:
There was nothing showing up in my Software Update until I installed RestrictEvents.kext and added revpatch=sbvmm in boot args (OC 0.9.5). I'm not sure why they were needed (my SMBIOS is for iMac20,2 and I don't use the Fenvi T919 fix, which is where I first read about them), but adding them made the incremental update appear as available.

Now that I'm successfully on 14.1 I don't know whether or not I should keep the kext and boot arg. Looking around here I see I'm not alone in wondering...
 
Back
Top