Contribute
Register

macOS 11.3 Update

Joined
Dec 6, 2013
Messages
137
Motherboard
GA-Z87X-UD5H
CPU
i7-4770K
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
Classic Mac
  1. Color Classic
Mobile Phone
  1. iOS
I updated from Catalina to Big Sur with Clover r5133 and the latest kexts.

I had already configured my USB ports using Hackintool, but I did need to set XhciPortLimit to false in my config.plist. My USB ports are working after the update.

My only issue was getting the installer to work. I kept getting errors when I tried to start the installation. I tried re-downloading the installer over Ethernet instead of WiFi, but that didn't work. I tried downloading the installer to my MacBook Pro and copying it to my hack, but that didn't work. The last thing I tried was connecting my Ethernet before trying to run the copy from my MacBook Pro (a suggestion I came across in a forum post), and amazingly that worked!

My computer rebooted numerous times and probably took over an hour to complete the installation, but everything seems to be working fine now.
About This Mac 11-3.png
 
Joined
Apr 1, 2020
Messages
66
Motherboard
HP ProBook
CPU
i5-8565U
Graphics
UHD 620
Mac
  1. MacBook Pro
Classic Mac
  1. Apple
Mobile Phone
  1. iOS
Hp Probook 450 G6 UPTADE macOS Big Sur 11.3
Ekran Resmi 2021-04-29 23.04.41.png
 
Joined
Jan 4, 2013
Messages
146
Motherboard
Gigabyte Z390 AORUS Pro
CPU
i9-9900K
Graphics
2 x Vega 64
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Smooth update with USBPort kext updated.
OC 0.6.8

NOTE (not a ral problem, but just a little hassle).

All USB seems working with new USBPort.kext BUT... in USB3 port there is no way to use USB2 device!
I reserved some port to USB2.0 (HS09, HS11, HS13) and disabled the relatives USB3 ports.

MoBo: Gigabyte Aorus Z390 Pro
Attached: USBPort.kext and port mapping with each port name.

Keep in mind that in my attached USBPort.xext the SS09 is voluntarily disabled, as well the HS10.
SS05 and SS06 works at max speed (10Gbs, at least for the SS06 that I've tested).
 

Attachments

  • USBPorts.kext.zip
    1.2 KB · Views: 41
  • AorusZ390Port.png.227503cb405ad08ef4638c287e9ca7f5.png
    AorusZ390Port.png.227503cb405ad08ef4638c287e9ca7f5.png
    58.1 KB · Views: 51
  • NZXTportsSSDT.jpg.bb1a6538809c461c36deb3225f51d6c8.jpg
    NZXTportsSSDT.jpg.bb1a6538809c461c36deb3225f51d6c8.jpg
    18.8 KB · Views: 51
  • 1021096465_AorusZ370ProMainboardcopy.png.829d3646ffaf314ac98b9af695cbf382.png
    1021096465_AorusZ370ProMainboardcopy.png.829d3646ffaf314ac98b9af695cbf382.png
    134 KB · Views: 52
Last edited:
Joined
Mar 3, 2014
Messages
1,018
Motherboard
Gigabyte Z390 I AORUS PRO WIFI
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Air
Classic Mac
  1. Power Mac
Just a note FYI... In 11.3, if you have a backup disk you want to be bootable, you have to download and install this version of the OS twice, once for each disk. I tried using CCC to copy from my primary to secondary disk after installing 11.3 on the primary. All the data copied, but the secondary disk was stuck on 11.2.3. (I remember that CCC warned about this.)
 
Joined
Jan 4, 2018
Messages
45
Motherboard
HP EliteBook 840 G1 - OpenCore
CPU
i5-4300U
Graphics
HD4400
Mobile Phone
  1. iOS
if you care about iPhone jailbreaking avoid this update, Checkra1n crashes when you are in the middle of jailbreaking, other than it looks fine for me.
 
Joined
Sep 1, 2016
Messages
374
Motherboard
GA-Z170N Gaming 5
CPU
i7-6700K
Graphics
RX 580
All good. I've got an SSDT for my USB ports, so... no issues there. It was a little strange, though... during the first two restarts, I got massive text scrolls instead of a progress bar. On the third restart, a 9-minute progress bar. But, like I said... all is good!

EDIT: I spoke too soon. My SSDT doesn't appear to be working properly anymore. Some USB devices aren't mounting. I've got some work to do...

Screen Shot 2021-04-30 at 3.26.47 PM.png
 
Last edited:
Joined
Mar 13, 2015
Messages
59
Motherboard
GA-Z97X-UD3H-BK
CPU
i7 4790K
Graphics
Intel HD 4600
Mac
  1. MacBook
  2. Mac mini
Mobile Phone
  1. Android
Just a note FYI... In 11.3, if you have a backup disk you want to be bootable, you have to download and install this version of the OS twice, once for each disk. I tried using CCC to copy from my primary to secondary disk after installing 11.3 on the primary. All the data copied, but the secondary disk was stuck on 11.2.3. (I remember that CCC warned about this.)
It happened to me with 11.2 itself. After updating to 11.2, I updated bootable backup with CCC. But it stayed at 11.1
I had to do a fresh and full backup. Otherwise, the OS part remains unchanged.
 
Top