Contribute
Register

macOS 10.15 Catalina is Now Available on the Mac App Store

Joined
Apr 5, 2018
Messages
3
Motherboard
Gigabyte B360M GAMING HD
CPU
I5 9600K
Graphics
RX 560
Installed MacOS-Catalina 10.15.1 with Clover

BOARD - Gigabyte B360M GAMING HD - BOARD
CPU - CORE I5 9600K
GRAPHICS CARD - GIGABYTE AMD RX 560 OC 4GB
RAM - CORSAIR VENGANCE 16GB
CPU COOLER - COOLER MASTER LIQUIDLITE 120
SSD - GIGABYTE 480


screen2.png
 
Joined
Nov 26, 2012
Messages
1,467
Motherboard
Gigabyte Z370 Aorus Gaming 5
CPU
i7-8700K
Graphics
RX 580
Mac
iMac, MacBook Pro
Mobile Phone
iOS
@pastrychef Is it absolutely necessary for the update to 10.15, that one needs to install Clover v2.5? The two drives that I have that has (had) 10.14.5(6) has crapped out on me when doing the update to v2.5 5099. The last of the cloned drives that I am presently using is set to clover 4920. If I can clone the other two NVMe drives I may try to install 10.15(x). I think that I bricked the WD Black 500gb after installing 5099 making the drive is inoperable, then attempts to clone the drive back to its original state failed. Flustered in Colorado. Add to the above BIOS at times does not even show any drives available and it will cycle over and over again. Would a BIOS reset be appropriate? Thank you for your assistance. I have also tried doing fresh installs three times.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
12,359
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
@pastrychef Is it absolutely necessary for the update to 10.15, that one needs to install Clover v2.5? The two drives that I have that has (had) 10.14.5(6) has crapped out on me when doing the update to v2.5 5099. The last of the cloned drives that I am presently using is set to clover 4920. If I can clone the other two NVMe drives I may try to install 10.15(x). I think that I bricked the WD Black 500gb after installing 5099 making the drive is inoperable, then attempts to clone the drive back to its original state failed. Flustered in Colorado. Add to the above BIOS at times does not even show any drives available and it will cycle over and over again. Would a BIOS reset be appropriate? Thank you for your assistance. I have also tried doing fresh installs three times.
No, it's not absolutely necessary to be on the latest version of Clover. However, I never tried going so many versions back... My guess is that 4920 should work. Updating your kexts should help.
 
Joined
Nov 26, 2012
Messages
1,467
Motherboard
Gigabyte Z370 Aorus Gaming 5
CPU
i7-8700K
Graphics
RX 580
Mac
iMac, MacBook Pro
Mobile Phone
iOS
After (finally) updating to Clover v2.5 5099 successfully, I did the update to 10.15.1 Running very smooth and much faster than Mojave. I wonder when Apple will name an OS after a place in New York? Something like "Flatbush" or "Canarsie" or "The Bronx". ;)
 
Joined
Jul 13, 2016
Messages
1,436
Motherboard
ASUS ROG STRIX Z370-F
CPU
I5-8600K
Graphics
RX580
Mac
Mac mini, Mac Pro
Mobile Phone
iOS
After (finally) updating to Clover v2.5 5099 successfully, I did the update to 10.15.1 Running very smooth and much faster than Mojave. I wonder when Apple will name an OS after a place in New York? Something like "Flatbush" or "Canarsie" or "The Bronx". ;)
Not saying never but Apple is pretty set on naming after places in CA after they get done with CA they will likely move onto another Theme. Before, it was big cats, other then Mavericks, then they moved onto places in CA. Keep in mind that none of the names are Cities they are state treasures so to speak... like Statue of Liberty!
 
Joined
Nov 26, 2012
Messages
1,467
Motherboard
Gigabyte Z370 Aorus Gaming 5
CPU
i7-8700K
Graphics
RX 580
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Not saying never but apple is pretty set on naming after places in CA after they get done with CA they will likely move onto another Theme. Before It was big cats, other then Mavericks, then they moved onto places in CA. Keep in mind that none of the names are Cities they are state treasures so to speak... like Statue of Liberty!
I was of course joking. Hence, the winky eye.
 
Joined
Nov 20, 2011
Messages
19
Motherboard
Gigabyte GA-Z77X-UD5H
CPU
i5-3570K
Graphics
RX 570
I was finally able to migrate to Catalina (10.15.1)

Thanks to CodeDJ for pushing me in the right direction with his EFI folder (https://www.tonymacx86.com/threads/macos-10-15-catalina-is-now-available-on-the-mac-app-store.284169/post-2024014)

I was using FakeSMC, switched to VirtualSMC for this one and it worked.

It was a very smooth install on a new ssd.

This is what I ended using

BOOT
Clover 5099

KEXTS
VirtualSMC.kext 1.0.9
SMCProcessor.kext 1.0.9
SMCSuperIO.kext 1.0.9
AppleALC.kext 1.4.3
Lilu.kext 1.3.9
WhateverGreen.kext 1.3.4
IntelMausiEthernet.kext 2.5.0
AtherosE2200Ethernet.kext 2.2.2

DRIVERS
ApfsDriverLoader.efi 5099
AppleGenericInput.efi 2.0.9
AppleUISupport.efi 2.0.9
AptioMemoryFix.efi R26
HFSPlus.efi 5099
VirtualSMC.efi 1.0.9

Plus ssdt-ec.dsl and a board-specific DSDT.aml and config.plist

Catalina is working great (apfs encrypted system disk)
 
Last edited:
Joined
Jul 23, 2015
Messages
95
Motherboard
x99-UD4
CPU
5820K
Graphics
RX580 8GB
Mac
MacBook Pro
I just updated through System Preferences > Software Update. I don't even remember when was the last time i used MultiBeast.
Hey Kittciokas,

It seems we have the same setup, x99-UD4, i7-5820K, RX580... I was wondering if you could share your EFI folder since I seem to have problems to run Catalina 100%

Thanks man
 
Joined
Aug 3, 2011
Messages
1
Motherboard
Asrock B360m Fatal1ty
CPU
i5 9400F
Graphics
Asus dual RX580
Mobile Phone
Other
From my point of view it was the clover kext not being used and old ones in the /Library/Extensions.

What you can try is :
- download the last lilu, AppleAlc, WhateverGreen, etc from the kexts section ;
- mount the / as rw ( sudo mount -uw / ) ;
- saving the actual /Library/Extensions content at this point should be a good idea ;
- after unzipping the downloaded archives, copy the kexts to /Library/Extensions/ ;
- then reboot (at your own risks).

Don't know if the kext cache need to be refresh...

I've messed up by deleting the old kexts (including the FakeSMC, you don't want to do that, I assure you) but was able to repair the system as the recovery mode provide access to the disks in the terminal app (I have no encryption enabled). I then just copied the kexts in the /Volumes/[YOUR_OS_ROOT_DRIVE]/Library/Extensions/ (with a cp -r ).

It's not a clean solution.

Hope that helps.
Thank you!! It worked for me! =D
 
Joined
Oct 16, 2018
Messages
9
Motherboard
ASUS ROG STRIX Z370-G GAMING
CPU
i7-8700K
Graphics
UHD-630
It was a struggle with freezing update installation attempts from Mojave but I started to dig deeper using verbose boot (-v boot arg in clover config) & googling a lot. Finally 10.15.2 Catalina is here. In my case the only working solution I found was to add SSDT-EC.aml into /EFI/CLOVER/ACPI/patched (Even if I there is already another SSDT-USB.aml from Patrychef in there - thank you for the SSDT-USB & guides here). SSDT EC0 to EC patch and others did not work for me.
 

Attachments

Top