Contribute
Register

macOS 10.15 Catalina is Now Available on the Mac App Store

Joined
Nov 1, 2019
Messages
1
Motherboard
Asus Prime Z370- PII
CPU
Intel i5
Graphics
Intel internal
Hi. I have just installed Mojave on my Asus Prime Z370-P II | i5 8400 | RX 560 4GB. May I ask if I can upgrade directly to 10.5.1 or I should do something first? I appreciate your help.
 
Joined
Nov 17, 2010
Messages
3
Motherboard
Gigabyte P55A-UD3
CPU
i5
Graphics
GT 710
I have a similar system I am looking to upgrade (P55A-UD4P), would you mind posting which Kexts and Patches were required.

Thanks in advance. Hard to believe these old systems can still run the latest Mac OS
Sorry for the late reply. I have the DSDT.aml I downloaded from here, in my EFI partition /EFI/CLOVER/kexts/Other the only thing I have is FakeSMC.kext. I have nVidia injection disabled in Clover, my nVidia GT 710 is supported natively by Catalina. No patches or fixes in config.plist, it's pretty vanilla. Make sure your graphics is supported before you upgrade, or have a backup. Have fun!
 
Joined
Jan 17, 2010
Messages
39
Motherboard
GA-P55A-UD4P
CPU
i5 750
Graphics
9800GT Silent Cell
Sorry for the late reply. I have the DSDT.aml I downloaded from here, in my EFI partition /EFI/CLOVER/kexts/Other the only thing I have is FakeSMC.kext. I have nVidia injection disabled in Clover, my nVidia GT 710 is supported natively by Catalina. No patches or fixes in config.plist, it's pretty vanilla. Make sure your graphics is supported before you upgrade, or have a backup. Have fun!

No apology necessary, I appreciate you taking the time to detail your solution.

I am still trying to get Catalina running.

I upgraded my El Capitan-based build from a(n unsupported) 9800GT to GT 710, built a USB Installer using my current DSDT + Updated Kexts and Clover, and was able to boot the Installer, format a spare SSD to APFS using Disk Utility and start the Installation of Catalina, however, it rebooted at 17 minutes to go. Since then I haven't even been able to boot to the Installer again, and also cannot even boot into my existing El Capitan install either using its EFI partition or the USB with Updated kexts + Clover. I suspect the GT 710 I purchased second-hand is dying, as my backup Windows 10 also died (black screen of death) while trying to edit some files on the USB. Once I put my old 9800GT back in it booted right back up into Windows or El Capitan like nothing had happened.

I need to investigate DosDude's patcher or sourcing another cheap (preferably passive) GPU that is Catalina-compatible
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
20,442
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
another cheap (preferably passive) GPU that is Catalina-compatible
Nvidia Quadro 410 is the lowest cost card natively supported by Catalina. 15 USD on Ebay. I've never used one with El Capitan but I would guess it should work without problems. One other note, we don't officially support or promote the use of DosDude's software so it's best to avoid using that. The GT 710 never had official support in El Capitan that's probably part of the reason you had problems with it. IIRC support only started in Sierra or High Sierra. The 9800 GT was still supported by El Capitan.

 
Joined
Sep 11, 2014
Messages
54
Motherboard
Asus Hero VII
CPU
i7 4790k
Graphics
GTX 1080
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
So basically how many of you got it to work? My mac went to sh.it when I did the 1st update of Mojave. It takes 5 minutes to start, 3 alone to get to the bootloader. :think:
 
Joined
Nov 3, 2017
Messages
338
Motherboard
Gigabyte Z490 Designare
CPU
i9-10850K
Graphics
Radeon VII
Mac
  1. MacBook Pro
Classic Mac
  1. iMac
Mobile Phone
  1. iOS
So basically how many of you got it to work? My mac went to sh.it when I did the 1st update of Mojave. It takes 5 minutes to start, 3 alone to get to the bootloader. :think:

Yes and with all the other problems with Catalina and just went back to Mohave for now.
 
Joined
Mar 9, 2012
Messages
2,483
Motherboard
Gigabyte Z390 AORUS Pro WFI
CPU
3.6 GHz 8-Core Intel Core i7
Graphics
RX 580
Mac
  1. iMac
  2. Mac Pro
Mobile Phone
  1. iOS
If it's taking that long to boot up that tells me your settings BIOS and/or EFI are completely out of whack - my board same chipset and same manufacture takes 30 seconds max to reach the desktop from BIOS post beep with clover. With OC test disk 10 to 15 seconds with verbose mode. Use a spare USB drive and test the attached EFI Folder to see the result.
 

Attachments

  • EFI.zip
    5.5 MB · Views: 74
Last edited:
Joined
Apr 5, 2018
Messages
3
Motherboard
Gigabyte B360M GAMING HD
CPU
I5 9600K
Graphics
RX 560
Installed MacOS-Catalina 10.15.1 with Clover

BOARD - Gigabyte B360M GAMING HD - BOARD
CPU - CORE I5 9600K
GRAPHICS CARD - GIGABYTE AMD RX 560 OC 4GB
RAM - CORSAIR VENGANCE 16GB
CPU COOLER - COOLER MASTER LIQUIDLITE 120
SSD - GIGABYTE 480


screen2.png
 

elfcake

Banned
Joined
Nov 26, 2012
Messages
1,741
Motherboard
Gigabyte Z490 D
CPU
i7-10700K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS

@pastrychef Is it absolutely necessary for the update to 10.15, that one needs to install Clover v2.5? The two drives that I have that has (had) 10.14.5(6) has crapped out on me when doing the update to v2.5 5099. The last of the cloned drives that I am presently using is set to clover 4920. If I can clone the other two NVMe drives I may try to install 10.15(x). I think that I bricked the WD Black 500gb after installing 5099 making the drive is inoperable, then attempts to clone the drive back to its original state failed. Flustered in Colorado. Add to the above BIOS at times does not even show any drives available and it will cycle over and over again. Would a BIOS reset be appropriate? Thank you for your assistance. I have also tried doing fresh installs three times.
 
Top