Contribute
Register

macOS 10.15 Catalina is Now Available on the Mac App Store

Joined
Nov 22, 2018
Messages
13
Motherboard
ASUS Maximus VII Hero
CPU
i7 4790k
Graphics
GTX 1080 Ti
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
High Sierra or Windows.
So the only way to get ANYTHING newer than HS is to buy AMD GPU ? Nothing higher than HS can't run on a Nvidia gpu?
Then...what's the best AMD GPU available right now that will run Cata?
 
Joined
Nov 24, 2015
Messages
1
Motherboard
Gigabyte Z370 AORUS Gaming 7-OP
CPU
i7-8700K
Graphics
RX Vega 64
Mac
  1. iMac
  2. MacBook Pro
So the only way to get ANYTHING newer than HS is to buy AMD GPU ? Nothing higher than HS can't run on a Nvidia gpu?
Then...what's the best AMD GPU available right now that will run Cata?
Radeon VII
 
Joined
Jun 16, 2010
Messages
304
Motherboard
Gigabyte GA-Z270X-Gaming-K7
CPU
i5-7600K
Graphics
RX 5500 XT
So the only way to get ANYTHING newer than HS is to buy AMD GPU ? Nothing higher than HS can't run on a Nvidia gpu?
Then...what's the best AMD GPU available right now that will run Cata?
Yes and no. Here's something Tony posted a year ago in regards to Mojave and compatible Nvidia GPUs. If you have a GTX 6xx or lower (plus a very few GTX 7xx), then you should be able to run Mojave and by extension, Catalina. If - on the other hand - you're trying to use a GTX 1xxx and higher, it's not going to happen.
 
Joined
Nov 22, 2018
Messages
13
Motherboard
ASUS Maximus VII Hero
CPU
i7 4790k
Graphics
GTX 1080 Ti
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Yes and no. Here's something Tony posted a year ago in regards to Mojave and compatible Nvidia GPUs. If you have a GTX 6xx or lower (plus a very few GTX 7xx), then you should be able to run Mojave and by extension, Catalina. If - on the other hand - you're trying to use a GTX 1xxx and higher, it's not going to happen.
Now that's...a good response. Thank You!
 
Joined
Jan 19, 2017
Messages
18
Motherboard
asus z170i pro gaming
CPU
i7-6700K
Graphics
RX 580
Updated to Catalina...so far everything seems to be working fine. However, I did notice I can't get video to work using the DisplayPort. Switching to HDMI works. I also still can't stream movies directly thru the movies app/itunes.
I'm using a RX580 video card.

I have problem too... RX 580
DP - primary monitor (working), and DP + hdmi - slave .. but working only DP (monitor) and 1 HDMI - 2 devices only ...

How to connect 2-3 or more DP devices + 1 HDMI at the same time?

PEASE HELP... any ideas?
 
Joined
May 17, 2014
Messages
105
Motherboard
ASUS Z490-I STRIX GAMING
CPU
i5-10600K
Graphics
HD630, RX580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
1) Update Clover
2) Update Lilu and AppleALC
3) Upgrade to Catalina.
4) Profit.

No issues at all except for losing Wifi and Bluetooth.
Then I found the thread below that fixed them.

I have annoying Preboot, Preboot 1 and Preboot 2 folders in the root of the file system. Anybody know if they can be deleted?
 
Joined
Oct 1, 2013
Messages
66
Motherboard
Z390 Designare
CPU
i7-8700k
Graphics
GTX 1080
Mac
  1. Mac mini
Mobile Phone
  1. iOS

Attachments

  • Screen Shot 2019-10-11 at 6.40.08 PM.png
    Screen Shot 2019-10-11 at 6.40.08 PM.png
    160.1 KB · Views: 190
Joined
Oct 1, 2013
Messages
66
Motherboard
Z390 Designare
CPU
i7-8700k
Graphics
GTX 1080
Mac
  1. Mac mini
Mobile Phone
  1. iOS
I have updated to Catalina, and everything works except that my system won't go to sleep. I tried nullCpuPowerManagement.kext, HibernationFixup.kext, sudo pmset -a hibernatemode to various modes with no success. I generated a dsdt.aml - still no success. I've set my bios power settings to S5 and S4 enabled. Any help will be appreciated.

[SOLVED] Sleep works, just takes a long time
 
Last edited:
Joined
Jul 27, 2019
Messages
6
Motherboard
Gigabyte H370M D3H GSM
CPU
i5-9600K
Graphics
Radeon RX Vega 56 8GB
Mac
  1. iMac
Updated Clover, Lilu and AppleALC and the Catalina upgrade went nicely, except between 1st and 2nd reboot I was running "blind", i.e. no picture on either my HDMI or DisplayPort displays. But the disk activity LED blinked so I just had a coffee. After, say 10 minutes, the 2nd reboot occurred, and the monitors got their pictures back. One of them displayed "12 minutes remaining", and, after that smooth sailing. Indeed, 12 minutes later, I had Catalina running.

Today I discovered USB 3.0 devices didn't work, so I pasted that port limit patch https://www.tonymacx86.com/threads/usb-2-0-3-0-3-1-fix.284709/ into Clover's config.plist, and they're back.

Finally, I had one more problem. The wallpapers settings didn't "stick"; i.e., no matter what I tried/set after every reboot I got the dynamic Catalina Islands picture on both my displays. Tried some google but not good. Finally, I got it working again by starting Terminal and:

cd ~/Library/Application\ Support/Dock
rm desktoppicture.db

and then, after running Settings/Desktop & Screen Saver, it finally stuck. :)
 
Joined
Jan 19, 2018
Messages
6
Motherboard
Sabertooth z87
CPU
i7 4770k
Graphics
GTX 780
Mac
  1. MacBook Pro
Sidecar I have it 100% functional. I use a BCM94352Z card in my ASUS X556UA (2016), which if I cannot guarantee Bluetooth since my laptop only had an antenna and the BCM94352Z card uses 2 (WiFi / Bluetooth), and I had to discard Bluetooth
 
Last edited:
Top