Contribute
Register

macOS 10.15 Catalina is Now Available on the Mac App Store

Joined
Mar 8, 2012
Messages
96
Motherboard
Gigabyte GA-Z170-HD3
CPU
i3-6100
Graphics
GT 710
Mobile Phone
  1. iOS
From my point of view it was the clover kext not being used and old ones in the /Library/Extensions.

What you can try is :
- download the last lilu, AppleAlc, WhateverGreen, etc from the kexts section ;
- mount the / as rw ( sudo mount -uw / ) ;
- saving the actual /Library/Extensions content at this point should be a good idea ;
- after unzipping the downloaded archives, copy the kexts to /Library/Extensions/ ;
- then reboot (at your own risks).

Don't know if the kext cache need to be refresh...

I've messed up by deleting the old kexts (including the FakeSMC, you don't want to do that, I assure you) but was able to repair the system as the recovery mode provide access to the disks in the terminal app (I have no encryption enabled). I then just copied the kexts in the /Volumes/[YOUR_OS_ROOT_DRIVE]/Library/Extensions/ (with a cp -r ).

It's not a clean solution.

Hope that helps.

My install went fine and sound worked ok. A few restarts later sound stopped. This fixed it. Thank you!
 
Joined
May 24, 2018
Messages
1
Motherboard
ASUS ROG Z170 Maximus hero VIII
CPU
i7 6700k
Graphics
Radeon RX 570 8 GB
View attachment 429448
Everything went quick smooth (the update is done) but now I cannot go pass this loading screen and my computer keeps rebooting. It seems impossible to boot into recovery as well. Anyone has the same problem and is it still possible to fix it?
try removing -lilubetaall if your using it, that fixed it for me.
 
Joined
Oct 2, 2019
Messages
110
Motherboard
GA Z370N WiFi
CPU
8700K
Graphics
Vega 56
Mac
  1. MacBook Air
  2. Mac mini
Exactly same for me.. :problem:
Bluetooth not available...

Edit:

Followed this post and now it's working!
How did you get it working? the post says to use the updated kexts:

"BrcmFirmwareData.kext, BrcmPatchRAM2.kext and BrcmBluetoothInjector.kext and place them inside EFI/CLOVER/kexts/Other"

Mine became totally dead after following this. When using the old method of BrcmFirmwareRepo.kext and BrcmPatchRAM2.kext in L/E, it was working on and off.
 
Last edited:
Joined
Jan 7, 2016
Messages
162
Motherboard
HP Elitedesk 800 G5 Mini
CPU
i9-9900
Graphics
UHD 630
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Screen Shot 2019-10-09 at 11.39.40.png


Motivated me to consolidate and now only have one hack. NUC6 was retired.
 
Joined
Sep 22, 2017
Messages
56
Motherboard
Gigabyte Brix Pro
CPU
i5-4570R
Graphics
Iris 5200
Mobile Phone
  1. Android
Don't upgrade if you still need 32 bit applications and have no 64 bit replacement for it. It will not work anymore.
 
Joined
Jul 29, 2013
Messages
37
Motherboard
Gigabyte GA-z97x-ud7 TH
CPU
i5 4690k
Graphics
Sapphire RX 590 Nitro+
Anyone got it working with FileVault enabled? I had FileVault enabled on Mojave, installation completed but after that it stopped showing the disk in Clover only Preboot and Recovery. If I select Preboot, it gets stuck at the Apple Logo without any indicator. Tried with -v as well, just get a blinking cursor along with Apple Logo. If I go into recovery and decrypt the drive, everything works.

I have the r5070 in Clover and updated drivers in the drivers/UEFI folder and kexts. Any ideas? Thanks!
 
Last edited:
Joined
Oct 23, 2013
Messages
63
Motherboard
Mac Pro Late 2013
CPU
6-core Xeon
Graphics
AMD D500 (Dual)
Mac
  1. MacBook Pro
  2. Mac Pro
Classic Mac
Mobile Phone
  1. iOS
Sidecar requires iPad models with support for Apple Pencil, i.e. most recent versions of any iPad model. My iPad mini 4 won't work either.

Look here for further info.
I have an ipad pro 12.9 latest.
Works fine with my macbook but not my hackintosh.i had to set my smbios to a newer imac than my hardware actually is and my ipad shows up but just wont connect
 
Joined
Jun 7, 2017
Messages
8
Motherboard
Gigabyte GA-H110M-H DDR4
CPU
Intel Core I5-7400 3GHz KABY LAKE
Graphics
Intel HD Graphics 630
Mac
  1. iMac
Mobile Phone
  1. iOS
Finally!

Audio and video working just fine, thanks to hackintool.
Sidecar is not working tho.

Sidecar suddelly started to work, wired.
 
Joined
Dec 6, 2016
Messages
41
Motherboard
Gigabyte Z170A
CPU
Skylake i5-6600K
Graphics
GTX 770
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
I've updated 2 hacks and one genuine MBP 13" 2015. I've had most trouble with MBP! The after-install stuff on MBP got suck at some point and I had to reboot. Both Hackintoshes (see my signature) have updated without a hitch, everything is working.
 
Top