Contribute
Register

macOS 10.15 Catalina is Now Available on the Mac App Store

Joined
Mar 15, 2014
Messages
12
Motherboard
Asus ROG Strix Z270 Gaming
CPU
i7 7700K
Graphics
RX 580
Mac
MacBook Pro
Classic Mac
Power Mac
Mobile Phone
iOS

This fixed my Apple Logo stuck load bar. Update went fine after putting SSDT-EC.aml to EFI/CLOVER/ACPI/Patched
 

Attachments

Joined
Aug 13, 2011
Messages
33
Motherboard
Gigabyte GA-Z68X-UD4-B3
CPU
i7
Graphics
RX 560
Well, "old faithful", the Z68, comes through for me again. So far, all working. The only (very) minor issue was that during the upgrade process, Clover wanted to boot from the FileVault Prebooter, not the Install Preboot. But a manual override via the arrow keys sorted that.

Even the JPEG preview issue is gone!!!!

Great!!!
 
Joined
Nov 19, 2010
Messages
228
Motherboard
Gigabyte EX58 UD3R
CPU
X5650
Graphics
GTX 760
Mac
Mac Pro
View attachment 429242
Went quite good. I had to add -no_compat_check in Clover and SSDT-EC.aml because my boot process stuck at "apfs_module_start:1683". Patched the Install macOS Catalina app with this guide. Maybe this helps someone.
simon1337 do I understand correctly that you have successfully installed Catalina on an "unsupported" MacPro 5,1 SMBIOS? If so, that is very good to hear. I just this morning posted this very question here "Catalina compatibility...Old guard?" . I wonder if you would consider going to that link and adding a little more detail regarding precisely how you accomplished this? I would appreciate anything you might want share on how you accomplished the install at the link.
 
Last edited:
Joined
Mar 30, 2019
Messages
29
Motherboard
Z370 AORUS Gaming 7
CPU
i9-9900K
Graphics
UHD 630 + Vega 56
Mac
Mac Pro
Mobile Phone
iOS
Went smooth. Everything working well. Upgraded from Mojave.
 
Joined
Jan 18, 2012
Messages
109
Motherboard
Asus WS x299 Sage/10G
CPU
i9 9980XE
Graphics
Radeon VII
Mac
MacBook Air
Mobile Phone
iOS
I was using macOS Catalina GM without any problems with my setup, but after trying a new install with macOS Catalina Final Version, when i reach the setup screen my main screen keeps on flickering. Should i update any kexts for my Radeon VII?

Does someone have the same problem?
 
Joined
Apr 4, 2013
Messages
7
Motherboard
Gigabyte B75M-D3H
CPU
i7
Graphics
EVGA GT 710
Mac
MacBook Pro
Mobile Phone
iOS
Joined
Jun 5, 2017
Messages
41
Motherboard
Asus Z370-A
CPU
i7-8700K
Graphics
Vega 64
Mac
iMac, MacBook Pro, Mac Pro
Mobile Phone
iOS

This fixed my Apple Logo stuck load bar. Update went fine after putting SSDT-EC.aml to EFI/CLOVER/ACPI/Patched
IT DID THE TRICK!!!
Do you maybe have an idea on how to change the Smbios to iMac, every time i do this i get black boot screens. Thanks a lot again!!!
Bildschirmfoto 2019-10-08 um 19.04.23.png
 
Joined
Apr 18, 2016
Messages
75
Motherboard
Asus Rog Maximus IX Formula
CPU
i7-7700K - 5Ghz
Graphics
Vega 64
Mac
iMac
Mobile Phone
iOS
you guys with the ASUS boards, you definitely enabled -disablegfxfirmware, and put the WE/Lilu kexts in the EFI/CLOVER/kexts/Other, right? (and maybe -lilubetaall, but that's only something I saw, didn't help me in the end) sorry I don't have the stamina to read the whole thread, and my answers are uncontrollably wordy even when I want to say something simple... hope you guys manage to get it working soon
I tried that but the boot process is stuck at "apfs_module_start:1683"
I'm giving up for now..
 
Top