Contribute
Register

macOS 10.15 Catalina is Now Available on the Mac App Store

Joined
Jun 29, 2013
Messages
29
Motherboard
Gigabyte GA-H270M-D3H
CPU
Core i5-7400
Graphics
EVGA GeForce GT 740
Mobile Phone
  1. iOS
Success (19A583)! But it took... forever.

I made a USB install stick. After the second reboot (the first time it boots from the install partition on the target drive - USB stick no longer needed), when the progress bar got to about 10%, it said "About 16 minutes remaining." It was stuck there for a good 45 minutes (I didn't time it, but I'm trying really hard to be realistic here.)

It finally changed to "About 25 minutes remaining" and rebooted very shortly after that. It picked up from the same spot and chugged along (very slowly!) until the progress was a little under 50%, where it showed "About 19 minutes remaining." That's when I put a stopwatch on it. After 18 minutes it got to about 95% on the progress bar and showed "About 9 minutes remaining."

A minute later, when my stopwatch read almost exactly 19 minutes, it was done and did its final reboot into Catalina (the last "About 9 minutes remaining" didn't actually take 9 minutes at all.)

For anybody that thinks their install is frozen and not working: wait it out! I'd say the full installation took about an hour and a half and for a lot of that time it appeared to be doing nothing.
 
Joined
Jan 4, 2014
Messages
75
Motherboard
Gigabyte Z390 AORUS PRO
CPU
i9-9900K
Graphics
RX 5700 XT
Mac
  1. MacBook Air
Mobile Phone
  1. Android
Ok, the update was successful to me.
- Before updating I did backup of the Mojave 10.14.6 drive and backup of the EFI in a bootable USB drive.
- Uninstalled all 32 bit applications I could remove, and replaced them with 64 bit ones, where possible.
- 3 reboots.
- No audio issue fixed updating AppleALC and Lilu kexts after the Catalina update.

I'm actually using a temporary RX 560 GPU because of my dead Vega 64.
Waiting for 5700 XT support, that I hope could come with the next system update!
 

Attachments

  • catalina.png
    catalina.png
    80 KB · Views: 77

tonymacx86

Administrator
Staff member
Joined
Nov 18, 2009
Messages
8,552
Motherboard
PRIME Z490-A
CPU
i5 10600K
Graphics
Vega 56
Mac
  1. MacBook Air
Classic Mac
  1. Apple
  2. PowerBook
Mobile Phone
  1. iOS
Updated audio drivers.
  • Updated AppleALC, Lilu, and WhateverGreen may be required. Download here.

Anyone with onboard sound issues, install the latest Lilu and AppleALC. I updated the top post to reflect.

Screen Shot 2019-10-08 at 12.01.15 PM.png
 
Joined
May 23, 2016
Messages
175
Motherboard
Lenovo Y50-70
CPU
i7-4720HQ
Graphics
HD4600 / GTX 960M 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I have Lenovo Y50. Everything works, but only Bluetooth don't works. Why?
 
Joined
Mar 1, 2016
Messages
20
Motherboard
Z97M-D3H
CPU
i5-4460
Graphics
EVGA GT 740
Mac
  1. iMac
Mobile Phone
  1. iOS
I did the upgrade and everything works except for sound. Anyone got any ideas? Im using a gigabyte motherboard with built in sound

have you tried this method as suggested by Theophilius, I have a Gigabyte too

 
Joined
Aug 8, 2015
Messages
5
Motherboard
Asus P8P67
CPU
i5-2500K OC@4.4 GHz
Graphics
RX 590
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Catalina MacPro 5.1.png

Went quite good. I had to add -no_compat_check in Clover and SSDT-EC.aml because my boot process stuck at "apfs_module_start:1683". Patched the Install macOS Catalina app with this guide. Maybe this helps someone.
 
Joined
Apr 5, 2012
Messages
117
Motherboard
MSI Z270 Gaming Pro Carbon
CPU
i5-7600
Graphics
RX 570
Mobile Phone
  1. Android
All went well. During installation, the computer went to a black screen for what seemed like a very long time, but it finished correctly in the end. Updated Lilu and WhateverGreen before updating. I was already on Clover v5070 which is the latest available, so no change there. Port mapped USB ports still work. I am using a USB audio solution, so no problems there.

OSCatalina.jpg
 
Joined
Mar 15, 2014
Messages
12
Motherboard
Asus ROG Strix Z270 Gaming
CPU
i7 7700K
Graphics
RX 580
Mac
  1. MacBook Pro
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS

This fixed my Apple Logo stuck load bar. Update went fine after putting SSDT-EC.aml to EFI/CLOVER/ACPI/Patched
 

Attachments

  • SSDT-EC.aml
    63 bytes · Views: 165
Joined
Aug 13, 2011
Messages
55
Motherboard
Gigabyte GA-Z68X-UD4-B3
CPU
i7
Graphics
RX 560
Well, "old faithful", the Z68, comes through for me again. So far, all working. The only (very) minor issue was that during the upgrade process, Clover wanted to boot from the FileVault Prebooter, not the Install Preboot. But a manual override via the arrow keys sorted that.

Even the JPEG preview issue is gone!!!!

Great!!!
 
Top