Contribute
Register

macOS 10.15 Catalina: How to Mount Root Partition Read/Write for Post-Installation

Joined
Feb 25, 2020
Messages
20
Motherboard
MSI Z270 SLI Plus with 64Gb 3200mhz DDR4
CPU
i7-7700K
Graphics
2x RX 580
Hi all, I just got Catalina running great on my machine with Unibeast, but obviously would only boot 'via' my USB installer, & not via the system drive alone

I then tried using MultiBeast (after doing that Sudo trick show on this threadto allow it to work in Catalina) in order to boot directly from the system drive

Obviously didn't tick the correct boxes, & now Catalina wont boot...even when going via the USB boot loader first .

Is there any simple way to remove the bootloader that Multibeast added to my system drive? Or Do I have to install Catalina again from scratch?

If it helps, I also have Ubuntu & Win10 on separate boot drives.

Cheers !
 
Joined
Oct 16, 2020
Messages
3
Motherboard
something that I don't know
CPU
Macbook Pro 2.5 GHz Dual-Core Intel Core i5
Graphics
Intel HD Graphics 4000 1536 MB
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
I managed to reproduce the error, in short your System Integrity Protection (SIP) is enabled, so "sudo mount -uw /" won't work. You can check in Terminal by typing: csrutil status

The new process involves 2 steps:

1. What you need to do is to enable the SIP, if you open clover configurator, mount your EFI, open config.plist (is in /EFI/CLOVER/ ), then under Rt Variables: CsrActiveConfig, change it to 0x67 (this will disable SIP), and restart.
- Disable SIP: 0x67
- Enable SIP: 0x00
- mine was originally set to 0x03 (partial)

2. After restarting, go back to terminal, and type: sudo mount -uw /

3. you may want to re-enable SIP after the post-installation.

Hope it helps! :)
Ive disable SIP, after I tried:
spctl --master-disable
mount -uw /
sudo killall Finder

and it says: ... Ilegal Operation

Ive downloaded Clover Configurator and I found the config.plist file on Mac, but I don't know how to work with the app!

Could you help me please?
 
Joined
Oct 2, 2019
Messages
110
Motherboard
GA Z370N WiFi
CPU
8700K
Graphics
Vega 56
Mac
  1. MacBook Air
  2. Mac mini
Ive disable SIP, after I tried:
spctl --master-disable
mount -uw /
sudo killall Finder

and it says: ... Ilegal Operation

Ive downloaded Clover Configurator and I found the config.plist file on Mac, but I don't know how to work with the app!

Could you help me please?
I don't really understand what you are trying to do. My guess is that you are using a real Mac, not a hackintosh. To disable SIP on a Mac, you need to go to recovery mode (Command-R and press the power button), and in Terminal, type: csrutil disable, then reboot
 
Joined
Oct 16, 2020
Messages
3
Motherboard
something that I don't know
CPU
Macbook Pro 2.5 GHz Dual-Core Intel Core i5
Graphics
Intel HD Graphics 4000 1536 MB
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
I don't really understand what you are trying to do. My guess is that you are using a real Mac, not a hackintosh. To disable SIP on a Mac, you need to go to recovery mode (Command-R and press the power button), and in Terminal, type: csrutil disable, then reboot
Sorry, first time on forums! Yes, im using a real mac
Ive disabled SIP, ive already check the status (with a code I found on this thread) and it says Status Disabled.

After rebooting, tried to make: mount -uw /
And it says: Illegal Operation

I came about to this threat, because im trying to open and "old" package that won't work on Catalina, but would on Mojave
 
Joined
Oct 2, 2019
Messages
110
Motherboard
GA Z370N WiFi
CPU
8700K
Graphics
Vega 56
Mac
  1. MacBook Air
  2. Mac mini
Sorry, first time on forums! Yes, im using a real mac
Ive disabled SIP, ive already check the status (with a code I found on this thread) and it says Status Disabled.

After rebooting, tried to make: mount -uw /
And it says: Illegal Operation

I came about to this threat, because im trying to open and "old" package that won't work on Catalina, but would on Mojave
In short, you can download Hackintool and run it to disable Gatekeeper.

But I'm having trouble understanding you. I'm guessing you want to dual boot with Catalina and Mojave. And you are trying to install some sort of boot loader? I don't think you can do it like this. I think you need to rebuild a new EFI for your Mac. It'll be easier using OpenCore and with two hard disks. Using Multibeast might be a bit tricky. You may want to use the original Clover for this.

To be very honest, what you are trying to do is a bit tricky even for someone with a fair knowledge of Hackintosh, and is very likely to crash a few times. You might be better off using some virtual machine and install Mojave that way. There isn't a straight forward way like installing Windows on a partition with Bootcamp.
 
Joined
Oct 16, 2020
Messages
3
Motherboard
something that I don't know
CPU
Macbook Pro 2.5 GHz Dual-Core Intel Core i5
Graphics
Intel HD Graphics 4000 1536 MB
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
In short, you can download Hackintool and run it to disable Gatekeeper.

But I'm having trouble understanding you. I'm guessing you want to dual boot with Catalina and Mojave. And you are trying to install some sort of boot loader? I don't think you can do it like this. I think you need to rebuild a new EFI for your Mac. It'll be easier using OpenCore and with two hard disks. Using Multibeast might be a bit tricky. You may want to use the original Clover for this.

To be very honest, what you are trying to do is a bit tricky even for someone with a fair knowledge of Hackintosh, and is very likely to crash a few times. You might be better off using some virtual machine and install Mojave that way. There isn't a straight forward way like installing Windows on a partition with Bootcamp.

No no, not at all haha - Bad explaining

So, I've got a MIDI controller, that I would like to connect to my Mac Catalina - For that I need to install some drivers. The drivers only work in the previous version, in Mojave.

So that, I've found a video explaining how to do it:
1st- Disable SIP (I check the status, and it confirmed)

and 2nd- "sudo mount - uw /" - And got "illegal operation"

So, I came about this thread and thought maybe to try out to disable (again) the SIP, and try out the method of your post, and see if it would work the code.

I hope it made more clear! Sorry for the confusion
 
Joined
Jul 13, 2016
Messages
2,923
Motherboard
Gigabyte Z370 Gaming 5
CPU
I9 9900k
Graphics
AMD RX 6900 XT
Mac
  1. Mac mini
  2. Mac Pro
Mobile Phone
  1. iOS
No no, not at all haha - Bad explaining

So, I've got a MIDI controller, that I would like to connect to my Mac Catalina - For that I need to install some drivers. The drivers only work in the previous version, in Mojave.

So that, I've found a video explaining how to do it:
1st- Disable SIP (I check the status, and it confirmed)

and 2nd- "sudo mount - uw /" - And got "illegal operation"

So, I came about this thread and thought maybe to try out to disable (again) the SIP, and try out the method of your post, and see if it would work the code.

I hope it made more clear! Sorry for the confusion
Maybe it is a 32bit app? if that is the case it does not work on Catalina.
 
Joined
Jul 7, 2015
Messages
15
Motherboard
MSI Z95 Gaming 5
CPU
i7-4790k
Graphics
GTX770
I've got a currently ongoing problem with Catalina MultiBeast post-install not having any effect.
MultiBeast says installation has been successful, but when I reboot, I just get a black screen with the text "B1InitializeLibrary failed 0xc00000bb", and that's it.
I can boot into Catalina via the install USB but that's the only way. It's also not installed any drivers, e.g. there's no audio devices present. Other than that and some minor occasional graphical glitches (due to the Nvidia card?) it runs fine.
I've disabled SIP as stated earlier in this thread, no effect.
I've entered "sudo mount -uw /" in the terminal as stated earlier in this thread, no effect.
MultiBeast keeps saying installation has been successful, no errors- but it's not actually done anything that I can tell.
Please help if you can!

Edit: solved; all I had to do was set the UEFI priority to the right disk in the BIOS.
 
Last edited:
Joined
Nov 20, 2020
Messages
4
Motherboard
Gigabyte Z390 Aorus Pro WIFI
CPU
i7-9700K
Graphics
RX 580
Mac
  1. iMac
Mobile Phone
  1. Android
I ran the line above in the Terminal, re-loaded and ran MultiBeast 12 for Catalina. But I still need to keep my USB plugged in to get to Clover then Catalina boots perfectly. What step am I missing?
 
Top