Contribute
Register

macOS 10.15.6 Update

Status
Not open for further replies.
Joined
Mar 22, 2013
Messages
64
Motherboard
Gigabyte Z390 AORUS PRO
CPU
i7-9700K
Graphics
MSI RX 5700 XT
Mac
  1. iMac
Mobile Phone
  1. iOS
Smooth and quick update. As usual using the IGFX and "HDMI", most probably because of my MSI graphic card that avoid me to update using it :(.... I only have issues for upgrades, after the update I switch back to MSI and all is working perfectly ;)

Capture d’écran 2020-07-18 à 17.42.27.png
 
Joined
Jul 1, 2018
Messages
5
Motherboard
MSI Z170A Gaming Pro Carbon
CPU
i5-7600K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Well in my case the update from 10.15.4 to 10.15.6 wasn't easy.

My current Hardware:
  • Mainboard: MSI Z170A Gaming Pro Carbon
  • 16 GB RAM
  • 512GB Samsung 850 Pro (M.2 NVMe)
  • Intel Core i5-7600k
  • MSI Radeon RX 580 ARMOR 8GB OC
  • Two LG 4K Displays connected via DisplayPort

Steps I did before I tried the update for the first time:
  1. Made multiple Time Maschine Backups on different HDDs. (as always)
  2. Updated everything with Multibeast 12.3.0
  3. Updated Lilu.kext, AppleALC.kext and WhateverGreen.kext. in /EFI/.../Clover/kexts/other/
  4. Made sure that no old "Hackintosh" Kexts were in /Library/Extensions/
  5. Restarted my Computer to make sure that everything still worked as expected
  6. I removed all unnecessary internal & external Drives so that just my main M.2 SDD was installed.
Then I startet the Update... It look like the update was installing, no errors... nothing! But after a while my computer rebooted right back into MacOS 10.15.4 (without giving me an error message).

So I startet the Update again & made sure that my Hackintosh booted from the right "boot drive" with the name similar to "[...] install ...". No luck! First I tried just changing the EFI/BIOS settings called "Initial Graphic Adapter" to "IGD" & used my Onboard HDMI Output but I had the same behavior.

The solution:
  • I had to remove my "MSI Radeon RX 580 ARMOR 8GB OC" Graphics Card completely from my system & manually select the right "boot drive". After that the update installed properly. After the first boot into MacOS the colors looked funny (a lot was inverted, but not everything).
  • After the successful update I installed my "MSI Radeon RX 580 ARMOR 8GB OC". I had to change the UEFI/BIOS settings called "Initial Graphic Adapter" back to "PEG". After that my system was behaving normally.
Geekbench 4 Scores after the update:

  • CPU: 5940 (SC), 18042 (MC)
  • Compute: 126154
 
Last edited:
Joined
Jun 27, 2017
Messages
140
Motherboard
Dell Inspiron 15 7560
CPU
i7-7500U
Graphics
HD 620
Mac
  1. MacBook Pro
Mobile Phone
  1. Other
Done! nothing to do, just update.
 

Attachments

  • Captura de Tela 2020-07-18 às 15.43.20.png
    Captura de Tela 2020-07-18 às 15.43.20.png
    86.4 KB · Views: 51
Joined
Jul 19, 2016
Messages
193
Motherboard
Asus X79 Deluxe
CPU
E5-1680 V2
Graphics
RX 580
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
Updated Lilu, WhateverGreen and AppleALC kexts and started update from update file.
22 minutes later system is updated. Smooth, no problems at all.
Screenshot 2020-07-18 at 10.04.29 PM.png
 
Joined
Apr 7, 2011
Messages
8
Motherboard
Gigabyte Z390 AORUS Pro WiFi
CPU
i5-9600K
Graphics
RX 580
Mobile Phone
  1. iOS
I use the Opencore boot loader, and I had the auto-update checked on my machine. It updated overnight while I slept. This morning all is we'll. :)
 
Joined
Aug 16, 2015
Messages
21
Motherboard
Gygabyte GA-X99-UD3
CPU
i7-5820K
Graphics
RX 580
Classic Mac
  1. 512K
  2. Plus
  3. Power Mac
  4. SE
Mobile Phone
  1. iOS
Screen Shot 2020-07-18 at 17.18.35.png
Easy!

I ever restart the machine for check its all fine before run the update and have the system clean, after that Run the update from the System Preferences, boot from the MacOS Install Volume everytime until this volume desapears (2 times as usual in my case).

On the Restart boot from "#yourMacOSVolumeName" and like your iPhone or iPad starts with a Black Screen with the apple on the center and a fine progress bar below. With the 9 remaning minutes process starts all fine!


Thats all!
 
Joined
Mar 30, 2013
Messages
192
Motherboard
Asrock H570 Phantom Gaming 4
CPU
i9-10900
Graphics
RX 580
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
Update went smooth in ca. 20 minutes. Clover also did everything right this time, I did not had to choose the macOS Volume after update was done.
 

CMS

Joined
Nov 8, 2011
Messages
1
Motherboard
Asus Z97 Sabertooth Mark S
CPU
i7-4790K
Graphics
GTX 680
Mac
  1. iMac
Thanks Tony!! Updated without problems.
Captura de Tela 0002-07-19 às 11.03.38.png
 

Jamesbond007

Moderator
Joined
May 21, 2011
Messages
6,503
Motherboard
Z390 Designare
CPU
i7 9700KF
Graphics
RX 580
Mac
  1. Mac mini
Mobile Phone
  1. iOS
When I attempted to download the 10.15.6 Install Catalina app using Software Update on my 2018 Mac mini running Mojave 10.14.6, every time the download finished I was greeted with the error "The update could not be verified" and the app was nowhere to be seen. I tried several times with the same result (with reboots in between).

I did not have the same problem when I downloaded the 10.15.5 Install Catalina app on the same machine before. I have no idea what was causing the issue. I wonder if anyone else had encountered the same problem.

Finally I used an older 2012 Mac mini running High Sierra 10.13.6 and this time I was able to download the app without trouble. The download was slow as that old machine is using WiFi to connect to the internet but download it did.

And then I remembered something called gibMacOS and I realized I should have used that instead of the error-prone Mac App Store. Really frustrated that I wasted so much time and bandwidth on this app!
 
Status
Not open for further replies.
Top