Contribute
Register

macOS 10.15.4 Update

Joined
Oct 21, 2017
Messages
4
Motherboard
Z370 hero X
CPU
IT 8700K
Graphics
rx 580
Mac
  1. MacBook
Mobile Phone
  1. Android
update without problem
15.4.png
 
Joined
Oct 29, 2015
Messages
69
Motherboard
Gigabyte GA-Z170MX Gaming 5
CPU
i5-6500
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Hello everyone! I'd like to, in a way, confirm that Clover r5103 gives problems. My computers all refused to boot the installer. After update to r5107 it all worked nicely. This was the first problems I had for ages, and probably only because I hesitated to update Clover as I normally do. Stay healthy!

Yes, that's the screen I got, too, when I tried updating on 5103. It didn't even start the update so I was able to boot back into 10.15.3 without issue or needing to reclone, etc. 5107 worked fine.
 
Joined
Nov 24, 2010
Messages
131
Motherboard
Gigabyte Z490 Vision D
CPU
i7-11700K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hi All,

I was unable to update to 10.15.4 until I updated Clover to V5107. Prior to the update, the system rebooted and the Apple logo came up but just sat there. After the clover update it went smoothly. Nothing broke.
 
Joined
Oct 10, 2015
Messages
825
Motherboard
Z370 AORUS Gaming 3
CPU
i5-9600K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Z370 | 9600K | RX 580 build
截圖 2020-03-25 23.47.40a.png

Downloaded Clover r5107 via Hackintool and updated it, before taking 20 minutes of the smooth macOS 10.15.4 (19E266) update. I set <key>DefaultVolume</key> to my macOS drive so I have not seen the issue of automatic selection.
 
Joined
Nov 25, 2014
Messages
15
Motherboard
MSI Z170
CPU
i5-6600K
Graphics
GTX 970
Mac
  1. iMac
update smooth withowt problem 2 restart about 25 min
 
Joined
Oct 8, 2011
Messages
39
Motherboard
Gigabyte Z270MX Gaming 5
CPU
i7-7700K
Graphics
Vega 56
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Another successful update! But not without incident this time...

Screen Shot 2020-03-25 at 12.00.31 PM.png


1st attempt:

Update kexts (Hackintool)
Reboot to test kext updates
Create Bootable Backup (CCC)
Apple Software Update to kick off upgrade
Install stuck at Apple Logo, no progress bar, recovered from CCC backup
Was running Clover 5102
Also running FakeSMC versus VirtualSMC (maybe not relevant to upgrade failure)

2nd attempt:

Update Kexts (Hackintool)
Reboot to test kext updates
Migrate from FakeSMC to VirtualSMC (newest Multibeast tool)
- Manually deleted FakeSMC kext and plugins from EFI folder(s) prior to installing VirtualSMC
Reboot to test change to VirtualSMC
Backup EFI Folder
Update Clover Bootloader to 5107
Reboot to test Clover Bootloader update
Create Bootable Backup (CCC)
Apple Software Update to kick off upgrade
Success!!
 

tonymacx86

Administrator
Staff member
Joined
Nov 18, 2009
Messages
8,581
Motherboard
PRIME Z490-A
CPU
i5 10600K
Graphics
Vega 56
Mac
  1. MacBook Air
Classic Mac
  1. Apple
  2. PowerBook
Mobile Phone
  1. iOS
OK I think we have it down to just 100/200/300 Series systems needing the Clover r5107 update before updating to 10.15.4. Skylake CPU+

Successful update on 8 Series system- did not need Clover r5107 to update using the 10.15.4 Combo Update. Used Clover r5104 with no issues.

GA-Z87X-UD7-TH - i7 4770K - GeForce GTX 770
Screen Shot 2020-03-25 at 9.34.32 AM.png
 
Last edited:
Joined
Feb 26, 2016
Messages
25
Motherboard
MSI Z87-G45 GAMING
CPU
i7-4770K
Graphics
Radeon VII
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
Hello !
Successful update :clap:

Update clover externally (pkg not found with clover Config.)
Update kexts with clover configurator.

Reboot.

Like 10.15.3, it was a blind update (10-15 min) still the last reboot.

Capture d’écran 2020-03-25 à 17.15.09.png


Wait and see what's new for Radeon VII perfs and issues... and for the audio.

Have a nice day and take care of you
 
Joined
Jul 8, 2017
Messages
8
Motherboard
Gigabyte Z170X-Gaming 3
CPU
i7-6700
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hi !

Successful update here to but :
  • used multibeast Catalina to have them in Clover (except FakeSMC, I use provided VirtualSMC now) ;
  • had to update to r5107 (Hackintools installed even if there was a warning telling it won't works with my system) ;
  • removed AppleALC, Atheros, FakeSMC, Lilu and WhateverGreen from /L/E ;
  • verified the boot was working with 10.15.3 before updating.
Thanks for the tools. ;)
 
Last edited:
Joined
May 21, 2016
Messages
98
Motherboard
Gigabyte Z370 HD3
CPU
I5-8600K
Graphics
RX 570
Mac
  1. iMac
Mobile Phone
  1. iOS
it was a half success.. upgrade to the latest lilu, whatevergreen and clover..
after successful installation, stuck in a reboot loop.

via verbose mode, I realised the IGPU failed to load.

then I disabled the IGPU in order to get it running


[ solved by adding -disablegfxfirmware to the boot argument in clover
 
Last edited:
Top