Contribute
Register

macOS 10.15.3 Update

Joined
Oct 8, 2011
Messages
39
Motherboard
Gigabyte Z270MX Gaming 5
CPU
i7-7700K
Graphics
Vega 56
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Another painless upgrade, Thanks again!

Same process as usual for the most part. Backup w/ CCC. Update Kexts (WEG, LILU, Apple ALC) in EFI/CLOVER/Kexts/Other. Upgraded Clover to 5102 (TonyMac x86 build). Ran the upgrade from Software Update. Took about 30 minutes for upgrade to complete. Only thing different this time around was removing kexts from /Library/Extensions/ as instructed in Stork's post above.
 

Attachments

  • Screen Shot 2019-12-11 at 3.20.22 PM.png
    Screen Shot 2019-12-11 at 3.20.22 PM.png
    84.9 KB · Views: 75
Joined
Mar 31, 2014
Messages
47
Motherboard
Gigabyte GA-Z97X-UD3H
CPU
i7-4790K
Graphics
RX 580
First I moved all hackintosh kexts from L/E/ to efi/clover/kexts/other/ as recommended.
Then very smooth update on both my machines like a real mac would, around 15 minutes.
Everything fine so far, nothing to complain.
I have SSDT-USB for both my machines, so no problem here.
 
Joined
Jul 15, 2017
Messages
132
Motherboard
Gigabyte GA-Z270XP-SLI
CPU
i7-7700K
Graphics
RX 570
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
Another painless upgrade, Thanks again!

Same process as usual for the most part. Backup w/ CCC. Update Kexts (WEG, LILU, Apple ALC) in EFI/CLOVER/Kexts/Other. Upgraded Clover to 5102 (TonyMac x86 build). Ran the upgrade from Software Update. Took about 30 minutes for upgrade to complete. Only thing different this time around was removing kexts from /Library/Extensions/ as instructed in Stork's post above.
Glad it went well for you!

Which drivers/EFI are you using?

My board is very close to yours and I'm having trouble upgrading from 10.14.6 to Catalina (with WEG/ Lilu, etc. of course), so it might be my EFI drivers?
 
Joined
Sep 20, 2012
Messages
78
Motherboard
ASUS ROG MAXIMUS HERO X Z370
CPU
i9-9900K
Graphics
RX 580
Mac
  1. iMac
Mobile Phone
  1. iOS
Another painless upgrade, Thanks again!

Same process as usual for the most part. Backup w/ CCC. Update Kexts (WEG, LILU, Apple ALC) in EFI/CLOVER/Kexts/Other. Upgraded Clover to 5102 (TonyMac x86 build). Ran the upgrade from Software Update. Took about 30 minutes for upgrade to complete. Only thing different this time around was removing kexts from /Library/Extensions/ as instructed in Stork's post above.

Hi, maybe a noob question; do you copy your kexts to the new folder or reinstall them and delete the old ones ?
Kind regards, Michiel
 
Joined
Apr 13, 2016
Messages
85
Motherboard
GA-H170N-WIFI-22e
CPU
i3-6100
Graphics
HD 530
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. LC
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
I practiced the upgrade on a HDD copy. Then bit the bullet and upgraded the main SSD. It worked! I was reluctant to give up some 32-bit apps (like Photoshop CS3) but can always boot back into a Mojave clone I made.
Three restarts and good to go. I appreciated the careful instructions to remove all Hack kexts to the EFI first. All seems solid at this point - though I never got sleep to work on this rig and haven't tested that yet.
 
Top