Contribute
Register

Solved > [macOS 10.15.0] Thinkpad X1 Extreme Hackintosh

Joined
Feb 15, 2019
Messages
1
Hi Errrneist, I'm looking to buy the Thinkpad X1 extreme. Would you recommend it for hackintosh? (I'm a newbie btw)
 
Joined
Jan 12, 2019
Messages
8
Motherboard
Lenovo 20MF000DUS-Clover
CPU
i7-8850H
Graphics
UHD 630 / GTX 1050 Ti
OK. I've got a new (second) SSD installed, and I got MacOS installed and running! Most things are working perfectly, but there are a few issues still to work out.

Working:
  • Wifi
  • Ethernet (via Lenovo adapter)
  • Battery status
  • Volume control buttons
  • USB 2.0
  • iMessage & Facetime
Not working:
  • USB 3.0 (the USB ports work fine with USB2 devices, but will not even power up a USB3 device)
  • SDXC card reader (I suspect this is related to the USB3 issue)
  • Brightness control buttons
Does anyone have any suggestions for trouble-shooting these not-working items?
 
Last edited:
Joined
Sep 2, 2013
Messages
86
Motherboard
Lenovo Thinkpad X1 Yoga 20FQ
CPU
i7-6600U
Graphics
HD 520
Mac
MacBook Pro, Mac mini
Mobile Phone
Android, iOS
OK. I've got a new (second) SSD installed, and I got MacOS installed and running! Most things are working perfectly, but there are a few issues still to work out.

Working:
  • Wifi
  • Ethernet (via Lenovo adapter)
  • Battery status
  • Volume control buttons
  • USB 2.0
  • iMessage & Facetime
Not working:
  • USB 3.0 (the USB ports work fine with USB2 devices, but will not even power up a USB3 device)
  • SDXC card reader (I suspect this is related to the USB3 issue)
  • Brightness control buttons
Does anyone have any suggestions for trouble-shooting these not-working items?
For my 1st gen X1 Yoga I managed to remap brightness keys using this patch I created:

Code:
into method label _Q15 replace_content
begin
    Notify(\_SB.PCI0.LPC.KBD, 0x0405)\n
end;
into method label _Q14 replace_content
begin
    Notify(\_SB.PCI0.LPC.KBD, 0x0406)\n
end;
Otherwise follow the guide here under "Brightness Keys" but I suspect it should be something similar!
 
Joined
Jan 12, 2019
Messages
8
Motherboard
Lenovo 20MF000DUS-Clover
CPU
i7-8850H
Graphics
UHD 630 / GTX 1050 Ti
...
Otherwise follow the guide here under "Brightness Keys" but I suspect it should be something similar!
Thank you! I have no idea how I missed this guide! Got the brightness keys working last night. :thumbup:
 
Joined
Jun 11, 2011
Messages
11
Motherboard
Asrock z87m Extreme4
CPU
Core i5 4670k
Graphics
Intel HD 4600
Mac
Classic Mac
Mobile Phone
OK. I've got a new (second) SSD installed, and I got MacOS installed and running! Most things are working perfectly, but there are a few issues still to work out.

Working:
  • Wifi
  • Ethernet (via Lenovo adapter)
  • Battery status
  • Volume control buttons
  • USB 2.0
  • iMessage & Facetime
Not working:
  • USB 3.0 (the USB ports work fine with USB2 devices, but will not even power up a USB3 device)
  • SDXC card reader (I suspect this is related to the USB3 issue)
  • Brightness control buttons
Does anyone have any suggestions for trouble-shooting these not-working items?
Hi what is the battery life like on the X1 extreme with Mojave? with average use?

Thank you
 
Joined
Mar 14, 2018
Messages
42
Motherboard
Thinkpad X1 Extreme - Clover
CPU
i7-8850H/C240
Graphics
UHD 630 / GTX 1050Ti, 3840x2160
Mac
MacBook Pro
Mobile Phone
Android
My X1E is on its way. I bought a DW1830 to go into it since it should be more compatible than the stock card. The thing is it looks like the stock card is 2x2 and the DW1830 is 3x3. For those that are using the DW1830, what did you do about the third antenna?

Reading conflicting things: some say to leave it empty, other say doing that isn't good, some say put in a third antenna and then they link to an antenna that isn’t compatible supposedly… well, the card is supposed to be M.2/NGFF format and they will link to an antenna that clearly states it is not M.2/NGFF compatible.
 
Last edited:
Joined
Mar 29, 2011
Messages
57
Motherboard
Lenovo Thinkpad T480
CPU
i7-8550u
Graphics
UHD620
Has anyone tried to get the Nvidia 1050 Ti working in macOS? I noticed the x1 extreme has a bios option to disable integrated graphics and force the dgpu to use the internal/external displays so hypothetically this is possible (no optimus support required). Thanks
 
Joined
Feb 12, 2019
Messages
9
Motherboard
Thinkpad X1 Extreme-1.18
CPU
i7-8850H
Graphics
UHD 630 / GTX 1050 Ti
Mac
MacBook Pro
Mobile Phone
iOS
Hi guys, I have followed the steps in this guide https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/, and replace the kexts/drivers64UEFI/ACPI patches with https://github.com/Errrneist/Hackintosh-Thinkpad-X1-Extreme(10.14.3 folder),, I have finished the installing macos to 970 evo (Reh call it as PHASE 2), after reboot, boot from usb again to Clover menu, then select boot the macos, some message appear quickly then crash to reboot, I have no time to take a picture,,,

my env are as following:
x1 extreme 8850h/16G/512G lenovo ssd(win10) +970evo 500G,no thirdparty hardware attached.
any suggestion?

edit1:
I remade the installer with zysuper's acpi patch/kexts/driver65uefis, now I getting into the macos, touchpad and trackpoint both are working, lightness/audio volume adjustment works fine. but I want to get the fan works more positively so system should get cooler, any idea?
 
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,259
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hi guys, I have followed the steps in this guide https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/, and replace the kexts/drivers64UEFI/ACPI patches with https://github.com/Errrneist/Hackintosh-Thinkpad-X1-Extreme(10.14.3 folder),, I have finished the installing macos to 970 evo (Reh call it as PHASE 2), after reboot, boot from usb again to Clover menu, then select boot the macos, some message appear quickly then crash to reboot, I have no time to take a picture,,,

my env are as following:
x1 extreme 8850h/16G/512G lenovo ssd(win10) +970evo 500G,no thirdparty hardware attached.
any suggestion?

edit1:
I remade the installer with zysuper's acpi patch/kexts/driver65uefis, now I getting into the macos, touchpad and trackpoint both are working, lightness/audio volume adjustment works fine. but I want to get the fan works more positively so system should get cooler, any idea?
No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.
 
Joined
Jan 9, 2019
Messages
3
Motherboard
Thinkpad X1E
CPU
i7-8750H
Graphics
GTX 1050ti
hi,I want to repost your post and efi files to another forum, could I? Of course, I will indicate the source.
 
Top