Contribute
Register

macOS 10.14.6 Update

elfcake

Banned
Joined
Nov 26, 2012
Messages
1,744
Motherboard
Gigabyte Z490 D
CPU
i7-10700K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
@elfcake,

After a clean install of Clover r5018 on a USB I have the following efi drivers in the Folder /EFI/Clover/Drivers/BIOS
  • ApfsDriverLoader.efi
  • AudioDxe.efi
  • FSInject.efi
  • SMCHelper.efi
  • XhciDxe.efi
ApfsDriverLoader.efi, FSInject.efi and SMCHelper.efi are also in /EFI/Clover/Drivers/UEFI which I selected in the Clover Installer along with the others that I selected.

I did not select AudioDxe.efi or XhciDxe.efi so those must have been installed by default.

As I wrote in this post :-


The Clover installer will not update an existing Clover install so i think its best to do a clean/fresh install on to a USB stick and then merge your existing config files ... etc, then copy the new Clover folder to your boot EFI partition.

Cheers
Jay
Unfortunately, I installed after I did the 10.14.6 update and before I read your post. Will this mess up the "system"?

Additionally, I have VirtualSMC.efi in Drivers>UEFI and drivers64UEFI. Can this be correct?
 
Joined
Oct 22, 2011
Messages
124
Motherboard
HP Elite 8300 MT
CPU
i5-3470
Graphics
RX 560
Mac
  1. MacBook Air
  2. MacBook Pro
Classic Mac
  1. Plus
Mobile Phone
  1. Android
  2. iOS
Updated my Sandy Bridge desktop from AS from 10.14.5. Had to manually select correct disk on second boot. Using USB stick for sound. All works as before.
 

jaymonkey

Moderator
Joined
Aug 27, 2011
Messages
3,877
Motherboard
ASRock-Z97 EX6
CPU
i7-4790K OC @ 4.8GHz
Graphics
Vega 64LC + HD4600
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Unfortunately, I installed after I did the 10.14.6 update and before I read your post. Will this mess up the "system"? Additionally, I have VirtualSMC.efi in Drivers>UEFI and drivers64UEFI. Can this be correct?


@elfcake,

As detailed in that post Clover r5000+ does not use the drivers64UEFI folder anymore, so it is unlikely to cause an issue.

Please note that this is not a general help thread, if you need further help, please start a new thread in the appropriate forum.

Cheers
Jay
 
Joined
Apr 26, 2016
Messages
52
Motherboard
ASUS Z270 TUF MARK 2
CPU
I5-7600K
Graphics
RX 570
Mac
  1. iMac
  2. Mac mini
Mobile Phone
  1. iOS
Well i tried for 2 days to update with the combo and could not get it to install. so after much deliberation i removed all my drives (5 of them) and then tried again. SUCCESS :)

So if you have multiple drives and cannot get it to install/update I suggest you remove them as that worked for me.
 
Joined
Apr 4, 2017
Messages
1,064
Motherboard
ASUS Z270 ROG MAXIMUS IX HERO
CPU
i7-7700K
Graphics
Vega 64
Mac
  1. iMac
Mobile Phone
  1. iOS
I updated Lilu, Whatevergreen, and AppleALC, then ran the update. I did NOT update Clover given the previous notes on installation confusion. Update succeeded without issue.
 
Joined
Jan 19, 2019
Messages
21
Motherboard
Gigabyte Z390 M GAMING
CPU
i7-8700K
Graphics
RX 560
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Upgraded smoothly , Without any Issues whatsoever.
Schermata 2019-07-30 alle 23.25.51.png
 
Joined
Nov 13, 2016
Messages
473
Motherboard
Gigabyte Z270M-D3H
CPU
i3-7350K OC 4.5GHz
Graphics
RX 580
Mac
  1. MacBook
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Classic
Mobile Phone
  1. iOS
Updated my desktop without issue. I was already on Clover v4972 and has latest drivers for audio, USB, and my SSDT was already patched.
 
Joined
Nov 20, 2011
Messages
22
Motherboard
Gigabyte Z490 Vision-D
CPU
i7-10700
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Upgrade to 10.14.6 from App Store went smoothly, 3 reboots, ~20min.

Clover 4934 (no change)
AppleALC 1.3.8 -> 1.3.9
Lilu 1.3.6 -> 1.3.7

Will look into booting from USB with the new Clover 5k structure, to get a hang of it.
 
Top