Contribute
Register

macOS 10.14.5 Update

Joined
May 8, 2017
Messages
8
Motherboard
HP 850 G1-Clover
CPU
i7 4600U
Graphics
HD 4400 + HD 8750m
Mac
MacBook Pro
Mobile Phone
iOS
Just updated my hackintosh.. No problem so far
 
Joined
Apr 22, 2013
Messages
3
Motherboard
Gigbyte GA-X99-UD4
CPU
I7-5820K
Graphics
RX 580
Mac
Mac Pro
Classic Mac
iMac
Two restarts and approx 13 minutes later:
View attachment 405474
During the update, I did see some random purple lines on the screen for a few seconds. I ignored it and the update continued fine.
Update went fine. But booting up has some random purple lines on screen. I have random kernel panics on boot. The system was very stable on version 10.14.4. The first or second boot has panics but then I can boot into system.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
9,287
Motherboard
Asus ROG Strix Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
Update went fine. But booting up has some random purple lines on screen. I have random kernel panics on boot. The system was very stable on version 10.14.4. The first or second boot has panics but then I can boot into system.
Lots of people are getting the purples lines. It doesn't seem to affect anything.

I have no idea why you are getting kernel panics. Please start a new thread to look for help resolving it.
 
Joined
Jun 10, 2010
Messages
181
Motherboard
Asus ROG-Z370-G
CPU
i7 8700K
Graphics
RX 580
Mac
MacBook Air
Mobile Phone
Android
Worked fine for me, upgrading from 10.14.3. I performed the Clover update first (to 2.4k r4961) & rebooted to make sure that was fully in place, then ran the 10.14.5 update from Apple.

Glad I read to note from @pastrychef about some random purple lines on the screen during the update - this was after the first reboot iirc and the machine appeared to have "hung".

Bear with! I left it a couple of minutes (!) and the install then carried on without issue.
 
Joined
Nov 30, 2018
Messages
3
Motherboard
Gigabyte H370M-D3H
CPU
i5-8400
Mobile Phone
Android
Updated without issues ... actually, even better than "without issues"!

I previously had two issues - incorrect screen resolution, and no audio - which have resolved themselves without any changes needed on my part, other than updating Lilu and WhateverGreen as part of doing this update.
 
Joined
Jun 2, 2015
Messages
99
Motherboard
Gigabyte Z370 Gaming 7
CPU
i7-8700K
Graphics
Vega 64
Mac
MacBook Pro, Mac mini
Mobile Phone
iOS
Ran the combo updater and it installed correctly. But after rebooting I boot to a black screen after it gets past clover and starts with the apple logo. Gets to the end of the log then black screen. Happens when I add "-x -v"....boots up scrolling verbose across the screen then goes to a black screen. I can boot to safe boot off disk or off usb installer made with Multibeast but it will not boot my system. Any help would be appreciated.
 
Top