Contribute
Register

macOS 10.14.5 Update

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
13,392
Motherboard
ASUS ROG MAXIMUS X HERO Z370
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Pro, Mac mini, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
Quick question. Does anyone know if the latest Clover from Tonymacx86 download is sufficient for this upgrade (r4862)? Or is a newer version required?
Use the latest MultiBeast for Mojave as it has r4920. Do the following:
Bootloaders > Clover UEFI Boot Mode​
Build <---check to see that you selected the above​
Install​
When MultiBeast is done, reboot. Now you can update.
 
Joined
Jan 1, 2016
Messages
4
Motherboard
ASUS CS-B
CPU
i5-4690T
Graphics
HD4600 + RX 560
Mac
MacBook Pro
Mobile Phone
iOS
I use Samsung 960 PRO ( M2 )with no issue…. is 970 Evo ( diffrent ) ?
Samsung 970 EVO Plus is different.
 
Joined
Mar 13, 2016
Messages
35
Motherboard
Asus Prime X299-Deluxe II
CPU
i9-9980XE
Graphics
RX 590
Samsung 970 EVO Plus is different.
Very glad I was reading this as I'm looking to build a 3rd Hackintosh and was waiting for the Evo Plus 2TB to come out before building. Guess I should stick with the 970 Evo 2TB! (Which is working fine in my 2nd Hackintosh.)
 
Joined
Aug 23, 2016
Messages
109
Motherboard
Gigabyte Z170X-UD5 TH
CPU
i7-6700K
Graphics
WX 7100
Mac
MacBook Pro, Mac mini, Mac Pro
Mobile Phone
iOS
I updated as well, see steps below. So far everything seems to be normal. However, I also have the graphic glitches that some others are reporting during boot. I am using a Radeon Pro WX 7100.

  1. checked boot volume with
    Code:
    fsck_apfs -n -l -x /dev/rdisk1s1
    before updating
  2. corrected some issues with fsroot tree by booting with -s and running
    Code:
    /sbin/fsck -fy
  3. updated Clover to 4920 via Clover Configurator
  4. updated FakeSMC to 2018-0915
  5. updated system to 10.14.5 18F132 via System Preferences > Software Update
 
Joined
Nov 8, 2011
Messages
50
Motherboard
Z370-HD3
CPU
i7-8700K
Graphics
RX 580
Updated clover (4920) AppleALC and WEG. Lilu hasn't changed since the last update. Used system update and it took about 10-15 minutes. Same horizontal purple line glitch as others have reported. Everything seems to work fine and graphics are still accelerated. Haven't tried Geekbench yet.
405740
 
Joined
Sep 8, 2015
Messages
21
Motherboard
MSI H270M Bazooka
CPU
i5-7400
Graphics
RX 570
Mac
Mac mini
Mobile Phone
iOS
No pb for update 10.14.4 to 10.14.5.

But, now I have the purple lines for boot.

And i have a bug with Bluetooth on screen login. It’s not working. I have to plug the Magic keyboard on USB for login and after Bluetooth start with launched session...

I have reset my Bluetooth parameters and deleted keyboard and trackpad. Now it’s working again.
 
Top