Contribute
Register

macOS 10.14.3 Supplemental Update

Status
Not open for further replies.
Joined
Sep 20, 2012
Messages
78
Motherboard
ASUS ROG MAXIMUS HERO X Z370
CPU
i9-9900K
Graphics
RX 580
Mac
  1. iMac
Mobile Phone
  1. iOS
Update went fine, all is working.
I had lost the recovery boot option in Clover boot screen, fortunately it has reappeared after the update.
 
Joined
Nov 8, 2017
Messages
9
Motherboard
GA-H270N-WIFI
CPU
i5-7500
Graphics
RX 580
Updated via software update. Smooth update and all is working well except for my IGPU. I disabled the HD 630 for 10.14.13 because I never managed to get it to be stable and play nicely with my new Sapphire Pulse RX 580.
 
Joined
Feb 8, 2013
Messages
96
Motherboard
Gigabyte GA-H270N-Wifi
CPU
i7-7700K
Graphics
GTX 1070
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
What USB patch are you people using? I created USB install sticks for 10.14.1 and 10.14.2 without problems, but now I created a 10.14.3 stick (with or without supplemental update I don't know), but with

com.apple.iokit.IOUSBHostFamily
83FB0F0F 870B0400 00
83FB3F0F 870B0400 00
USB Port Limit Patch 1 ©PMHeart

com.apple.driver.usb.AppleUSBXHCI
4183FF0F 0F839404 0000
4183FF3F 0F839404 0000
USB Port Limit Patch 2 ©PMHeart

com.apple.iokit.IOUSBHostFamily
83E30FD3 E34109DF
83E33FD3 E34109DF
USB Port Limit Patch 3 ©PMHeart

the USB stick boot crashes at the IOUSBHostHIDDevice interruptReadComplete 9 tries remaining thing.
 
Joined
Sep 11, 2018
Messages
18
Motherboard
ASUS ROG Strix Z370-E Gaming
CPU
i7-8700
Graphics
RX 580
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
Smooth update. No issues.
 
Joined
Nov 14, 2013
Messages
8
Motherboard
Dell 7010 SFF
CPU
i7-3770k
Graphics
GT 710
Perfectly smooth update on both my Alienware M17x Haswell and Dell 7010 SFF. Nothing broken.
 
Joined
Nov 8, 2017
Messages
9
Motherboard
GA-H270N-WIFI
CPU
i5-7500
Graphics
RX 580
What USB patch are you people using? I created USB install sticks for 10.14.1 and 10.14.2 without problems, but now I created a 10.14.3 stick (with or without supplemental update I don't know), but with

com.apple.iokit.IOUSBHostFamily
83FB0F0F 870B0400 00
83FB3F0F 870B0400 00
USB Port Limit Patch 1 ©PMHeart

com.apple.driver.usb.AppleUSBXHCI
4183FF0F 0F839404 0000
4183FF3F 0F839404 0000
USB Port Limit Patch 2 ©PMHeart

com.apple.iokit.IOUSBHostFamily
83E30FD3 E34109DF
83E33FD3 E34109DF
USB Port Limit Patch 3 ©PMHeart

the USB stick boot crashes at the IOUSBHostHIDDevice interruptReadComplete 9 tries remaining thing.

I see you have the same board as me. I followed the following guide for my original build...


I had installed the precompiled USB SSDT files linked to in that thread into CLOVER/ACPI/patched... I also still have the USBInjectAll.kext and XHCI-200-series-injector.kext installed but I have since removed all the USB patches in Clover because as I understand it is not needed if you have the proper SSDT files...

All my USB ports are working and show up properly in the system report but I have not fully tested for USB 3.0 because I do not have a device that requires it.

I have attached the zip linked to in that thread. I also replace my boot stick EFI folder with my computer's working EFI folder and I have had no problem recovering from experimentation gone bad. Hope this helps.
 

Attachments

  • USB SSDT File.zip
    1.7 KB · Views: 87
Joined
Apr 5, 2017
Messages
3
Motherboard
Asus Z170 Pro Gaming
CPU
i7-7700
Graphics
HD 630 + RX 580
Mac
  1. iMac
Mobile Phone
  1. iOS
Updated successfully from 10.14 version without any trouble. Sound works fine, I used patching AppleHDA method for it. iMessage is working now despite didn't work before update.
 
Joined
Feb 8, 2013
Messages
96
Motherboard
Gigabyte GA-H270N-Wifi
CPU
i7-7700K
Graphics
GTX 1070
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Hi, thanks for those files. Those are for a GA-H270N-Wifi? I have a Z270N-Wifi but that should the same, right?

Anyway, putting those three files into CLOVER/ACPI/patched doesn't improve things. The Clover config file does not contain any USB related patches anymore.

We kinda need a USB SSDT file database, me thinks. People creating their own each time just isn't realistic ...

I see you have the same board as me. I followed the following guide for my original build...


I had installed the precompiled USB SSDT files linked to in that thread into CLOVER/ACPI/patched... I also still have the USBInjectAll.kext and XHCI-200-series-injector.kext installed but I have since removed all the USB patches in Clover because as I understand it is not needed if you have the proper SSDT files...

All my USB ports are working and show up properly in the system report but I have not fully tested for USB 3.0 because I do not have a device that requires it.

I have attached the zip linked to in that thread. I also replace my boot stick EFI folder with my computer's working EFI folder and I have had no problem recovering from experimentation gone bad. Hope this helps.
 
Joined
Jun 11, 2012
Messages
8
Motherboard
Gigabyte Z390 Gaming X
CPU
Intel Core i95600KF
Graphics
Sapphire RX580
Mac
  1. iMac
No problem here, no need to patch telemetry for my core 2 quad processor.
 

Attachments

  • Capture d’écran 2019-02-10 à 11.07.51.png
    Capture d’écran 2019-02-10 à 11.07.51.png
    95.6 KB · Views: 109
Status
Not open for further replies.
Top