Contribute
Register

macOS 10.14.1 Update

Status
Not open for further replies.
Joined
Mar 15, 2012
Messages
85
Motherboard
GIGABYTE Z370 AORUS Ultra Gaming
CPU
i7-8700K
Graphics
RX 580
SMBIOS'es 18.3 and 18.2 expect that the device has two graphic cards, internal and external, that's why there is flicker when you use only internal Intel card. 18.1 is your friend, since it is from a iMac without external card.
Interesting, Any guide on how to get both internal and external graphics working together? Have this with HS and works very well, I had issues when updating to Mojave.
 
Joined
Jul 26, 2012
Messages
13
Motherboard
ASUS H370-i
CPU
i7-8700
Graphics
Intel UHD 630
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
What's the problem with that? I'm just saying that when you have only internal CPU graphic card (which is visible on the screenshot) and set SMBIOS from an iMac that has both - it flickers like hell. Had the same problem. Solution to that is to set SMBIOS of the machine that doesn't have external GPU when you don't have one. That's SMBIOS 18.1
 
Joined
Mar 15, 2012
Messages
85
Motherboard
GIGABYTE Z370 AORUS Ultra Gaming
CPU
i7-8700K
Graphics
RX 580
What's the problem with that? I'm just saying that when you have only internal CPU graphic card (which is visible on the screenshot) and set SMBIOS from an iMac that has both - it flickers like hell. Had the same problem. Solution to that is to set SMBIOS of the machine that doesn't have external GPU when you don't have one. That's SMBIOS 18.1
No problem, Just didn't realize that maybe I should try 18.2 or 18.3 being that I have both internal and External being utilized. Though on occasion I do get a graphics error that forces a reboot. We change our bios to use both Internal and External graphics. It has helped some people who were having slow Bruce tests in FCP, and processing HVEC encodings. For me it fixed an issue I had with Photos processing video uploaded from a DSLR. Just was looking for addition info.
 
Joined
Oct 19, 2013
Messages
97
Motherboard
Gigabyte Z370 AORUS Ultra Gaming
CPU
i7 8770k
Graphics
RX580
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Mobile Phone
  1. iOS
Caution!! after the installation of 10.14.1 is lost quick sync

Man glad I read this. I fought long and hard to get it working on Mojave and not about to lose it. Any info on the fix?
 
Joined
Sep 23, 2011
Messages
18
Motherboard
Gigabyte Z370 HD3P
CPU
i7-8700
Graphics
HD 630
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
SMBIOS'es 18.3 and 18.2 expect that the device has two graphic cards, internal and external, that's why there is flicker when you use only internal Intel card. 18.1 is your friend, since it is from a iMac without external card.

Just gave it a try, but no luck with iMac 18,1: not starting, like iMac 17,1. I'll stick to 14,2.
Thanks anyway.
 
Last edited:
Joined
Apr 7, 2012
Messages
141
Motherboard
Asus Maximus X Formula
CPU
i7 8700K
Graphics
VEGA
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
What SMBIOS is fit for a Vega FE setup?
 
Joined
Feb 7, 2012
Messages
17
Motherboard
ASUS PRIME H270 PRO - 3610 - Clover
CPU
i7-7700K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac Pro
Classic Mac
  1. iMac
Mobile Phone
  1. Android
  2. iOS
Finally just got round to installing 10.14 yesterday on my testing system, only to find that there was the 10.14.1 update, so downloaded via direct link and installed not so long ago, everything seems fine at the moment that was working prior to the update.

Just need to sort out USB 3.0(also a write up on this and several other systems i use) System Spec below.

  • Gigabyte GA-H270M-DS3H
  • Intel i5 6500
  • Corsair Vengeance LPX 16GB (4X4GB) DDR4 2400 MHz
  • Sapphire Pulse Radeon RX 580 8G GDDR5
  • Samsung 250GB EVO PCI Express 3.0 x4 NVMe (APFS)
Will update if i come across any problems?

CIM :thumbup:
 
Joined
Jan 15, 2014
Messages
15
Mac
Classic Mac
Mobile Phone
Note: You do NOT need to update Lilu, AppleALC or Whatevergreen; if those kexts were working in 10.14.0. I did not and the only minor issue I had was my monitor went blank for about a few minutes during the update process. But after waiting it out, the system rebooted and finished reinstalling as usual. I also noticed a few users say that the new kext updates breaks Quick Sync, as well.

Everything is working fine. I did the manual USB port limit patch so I did not need to do anything else for USB 3.0 to work.
 
Joined
Nov 19, 2015
Messages
107
Motherboard
MSI GS65 Stealth Thin 8RF
CPU
i7-8750H
Graphics
UHD630, GTX1070
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Mobile Phone
  1. Android
  2. iOS
  3. Other
Not perfect the new dmg stand alone asks for APFS, why am I not supriced... so what should I run new install over the app and convert APFS?
 
Joined
Feb 7, 2012
Messages
17
Motherboard
ASUS PRIME H270 PRO - 3610 - Clover
CPU
i7-7700K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac Pro
Classic Mac
  1. iMac
Mobile Phone
  1. Android
  2. iOS
Note: You do NOT need to update Lilu, AppleALC or Whatevergreen; if those kexts were working in 10.14.0. I did not and the only minor issue I had was my monitor went blank for about a few minutes during the update process. But after waiting it out, the system rebooted and finished reinstalling as usual. I also noticed a few users say that the new kext updates breaks Quick Sync, as well.

Everything is working fine. I did the manual USB port limit patch so I did not need to do anything else for USB 3.0 to work.

Even in 10.14.0. i could not get the USB 3.0 ports to work, but today and without changing anything they are on working with USB 2.0 devices at present, which will do for the time being until i get to look at your suggestion of manual USB port limit patch.

Will update on this once i find some spare time?

CIM :thumbup:
 
Status
Not open for further replies.
Top