Contribute
Register

macOS 10.13.4 Update

Joined
Sep 29, 2012
Messages
10
Motherboard
GA Z68AP-D3 and Z77-DS3H
CPU
intel i7 3770
Graphics
Nvidia GTX 560 TI on both mobos
Hi,
Can anybody confirm that this update supports Nvidia GTX 560TI cards (Fermi) in whatever system definitions.
 
Joined
Dec 5, 2013
Messages
57
Motherboard
ASUS ROG Maximus IX Hero
CPU
I7-7700K
Graphics
RX 580
Mac
iMac, MacBook Air
Mobile Phone
iOS
---- About my update process ----

Just updated from 10.13.3 to 10.13.4 (iMac18,3):
- I updated apfs.efi in clover first and rebooted my system (just in case)
- On first restart the system booted into the installer (after apple logo) and resulted into a black screen after couple of seconds and rebooted
- On second automatic restart (after the apple logo) the installer went smoothly
- System rebooted:
  • audio still worked (I'm using cloverALC)
  • Nvidia driver broke (I use GT 1030 card):
    • patched the driver with the script (v...104) - rebooted - still broken
    • upgraded the driver with the script to (v...106) - rebooted - everything works fine (except for the known very hardly noticeable lags - newer versions like v...159 lag very horribly)
---- Different questions ----

* Does anyone know an average time how fast Nvidia usually pushes new driver versions?

* Does native eGPU support mean anything special for Nvidia? I mean some of you report that their AMD cards are natively supported. I assume they are not eGPU's so how are they're natively supported? Are those faked as eGPU? Can Nvidia now introduce new kind of drivers for yet better compatibility with macOS?
 
Joined
Mar 10, 2018
Messages
14
Motherboard
ASUS PRIME X299-Deluxe II
CPU
i9-9900X
Graphics
Radeon VII x2
Mac
MacBook Pro
Mobile Phone
Android, iOS
New patch needed:
Code:
<key>KextsToPatch</key>
        <array>
            <dict>
                <key>Comment</key>
                <string>USB 10.13.4+ by PMHeart</string>
                <key>Disabled</key>
                <false/>
                <key>Find</key>
                <data>
                g32UDw+DlwQAAA==
                </data>
                <key>InfoPlistPatch</key>
                <false/>
                <key>MatchOS</key>
                <string>10.13.x</string>
                <key>Name</key>
                <string>com.apple.driver.usb.AppleUSBXHCI</string>
                <key>Replace</key>
                <data>
                g32UD5CQkJCQkA==
                </data>
            </dict>
        </array>
Thanks bogdanw! The patch works and I have had my USB 3.0 ports back... :)
 
Joined
Apr 13, 2016
Messages
50
Motherboard
GA-H170N-WIFI-22e
CPU
i3-6100
Graphics
HD 530
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
LC, Power Mac, PowerBook
Mobile Phone
iOS
New patch needed:
Code:
<key>KextsToPatch</key>
        <array>
            <dict>
                <key>Comment</key>
                <string>USB 10.13.4+ by PMHeart</string>
                <key>Disabled</key>
                <false/>
                <key>Find</key>
                <data>
                g32UDw+DlwQAAA==
                </data>
                <key>InfoPlistPatch</key>
                <false/>
                <key>MatchOS</key>
                <string>10.13.x</string>
                <key>Name</key>
                <string>com.apple.driver.usb.AppleUSBXHCI</string>
                <key>Replace</key>
                <data>
                g32UD5CQkJCQkA==
                </data>
            </dict>
        </array>
Thanks! Worked on my Skylake mini.
 
Joined
Feb 28, 2014
Messages
115
Motherboard
GA-Z170X-UD5
CPU
Intel Core i7-6700K
Graphics
AMD RX560 4G
Mac
MacBook Pro
Mobile Phone
Android, iOS
Just to clarify:
Should one disable RadeonDeInit BEFORE or AFTER installing the update from the App Store?

Thanks
 
Joined
Apr 10, 2016
Messages
610
Mac
MacBook Pro
I don't use quiet boot so I got to see the bootable options every time the system restarted during. It changed every time.

Initial boot before update "macOS from ***"
During update Clover automatically selected "install macOS from ***" (I think) followed by "PreBoot from FileVault" (I think).
Yeah because both of your don't set default boot in Clover, so it will auto-detect the first boot loader
P/S
I don't own a real MAC, but I guess the installer will create a boot entry in its UEFI Bios.
 
Last edited:
Joined
Jul 19, 2016
Messages
175
Motherboard
Asus X79 Deluxe
CPU
E5-1680 V2
Graphics
RX 580
Mac
Mac Pro
Mobile Phone
iOS
updated via Appstore. no probs there. Nvidia needed a little touch though.
after updating i have no driver, i run the bash command from here (benjamin.dobell you rock man!) but it didn't work. so i uninstalled nvidia driver from NVIDIA driver manager, rebooted, run the bash script again and voila! all work perfect again and with the "good" .106 driver

the upate is a big one - nearly 2.5 gigs- but lets be honest, it is the iMac Pro wallpaper that makes it essential!! :p
 
Joined
Jul 31, 2012
Messages
19
Motherboard
GA-Z97X-UD3H
CPU
Intel i7-4790k
Graphics
GeForce GTX 760
New patch needed:
Code:
<key>KextsToPatch</key>
        <array>
            <dict>
                <key>Comment</key>
                <string>USB 10.13.4+ by PMHeart</string>
                <key>Disabled</key>
                <false/>
                <key>Find</key>
                <data>
                g32UDw+DlwQAAA==
                </data>
                <key>InfoPlistPatch</key>
                <false/>
                <key>MatchOS</key>
                <string>10.13.x</string>
                <key>Name</key>
                <string>com.apple.driver.usb.AppleUSBXHCI</string>
                <key>Replace</key>
                <data>
                g32UD5CQkJCQkA==
                </data>
            </dict>
        </array>
That was a quick fix, thanks, USB3 works like a charm now :thumbup:
 
Joined
Dec 5, 2013
Messages
57
Motherboard
ASUS ROG Maximus IX Hero
CPU
I7-7700K
Graphics
RX 580
Mac
iMac, MacBook Air
Mobile Phone
iOS
---- Interesting fact ----

I did never ever tried to fix iMessage on my Hackintosh but with 10.13.4 it started working out of the box. Out of nowhere I received messages and I also could reply to those (they're also reflected on my iPhone).
 
Top