Contribute
Register

macOS 10.13.4 Update

Status
Not open for further replies.
Joined
Sep 28, 2017
Messages
49
Motherboard
GIGABYTE GA-Z170X-Gaming 6
CPU
i7 7700
Graphics
Radeon ROG 560 4gb
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
New patch needed:
Code:
<key>KextsToPatch</key>
        <array>
            <dict>
                <key>Comment</key>
                <string>USB 10.13.4+ by PMHeart</string>
                <key>Disabled</key>
                <false/>
                <key>Find</key>
                <data>
                g32UDw+DlwQAAA==
                </data>
                <key>InfoPlistPatch</key>
                <false/>
                <key>MatchOS</key>
                <string>10.13.x</string>
                <key>Name</key>
                <string>com.apple.driver.usb.AppleUSBXHCI</string>
                <key>Replace</key>
                <data>
                g32UD5CQkJCQkA==
                </data>
            </dict>
        </array>

I did your method and nothing seems to work can you check my config.plist to see if I'm not doing anything wrong thanks in advance
 

Attachments

  • config.plist
    4.2 KB · Views: 271
Joined
Nov 9, 2011
Messages
9
Motherboard
GA-B360M-DS3H-F17
CPU
i5-8400
Graphics
RX 560
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. iOS
Succes.

Update from 10.13.3 to 10.13.4 via app store was a disaster on my GA-Z68X-UD3H-B3 ver. 2 and GA Geforce GTX 750 Ti
Suddenly there was a harddrive missing? Also al kind of other glitchy stuff was going on.
On top of that I was suddenly not able to boot any more.


So I put back the clone from a perfectly working 10.13.3 to try a different approach.
I basically did the Installation Guide again with the updated 8.3.1 UniBeast.

I did the installation without erasing and formatting the disk.
And that was it. A perfectly working 10.13.4 High Sierra boot disk.:thumbup:
Even MultiBeast wasn't needed. Everything was perfectly working after update of the Nvidia webdriver.
It was like updating a genuine Mac.

FYI: I'm still not using APFS because of a lot of trouble in the past.

After 7 years this board is still rocking it with a 2500k on 4.5 Ghz
 
Joined
Feb 20, 2011
Messages
10
Motherboard
Gigabyte Z390 Aurus PRO WIFI
CPU
3.6 Ghz 8 Core 9th Gen Core i7
Graphics
Radeon RX 580 8 GB
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
New patch needed:
Code:
<key>KextsToPatch</key>
        <array>
            <dict>
                <key>Comment</key>
                <string>USB 10.13.4+ by PMHeart</string>
                <key>Disabled</key>
                <false/>
                <key>Find</key>
                <data>
                g32UDw+DlwQAAA==
                </data>
                <key>InfoPlistPatch</key>
                <false/>
                <key>MatchOS</key>
                <string>10.13.x</string>
                <key>Name</key>
                <string>com.apple.driver.usb.AppleUSBXHCI</string>
                <key>Replace</key>
                <data>
                g32UD5CQkJCQkA==
                </data>
            </dict>
        </array>
Thanks for the update Sir. Can I ask how do I apply this patch. Sorry, for being a nude.
 
Joined
Feb 20, 2011
Messages
10
Motherboard
Gigabyte Z390 Aurus PRO WIFI
CPU
3.6 Ghz 8 Core 9th Gen Core i7
Graphics
Radeon RX 580 8 GB
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Thanks bogdanw! The patch works and I have had my USB 3.0 ports back... :)

Hi ichan7. How do I apply that patch please.

Thanks in advance.
 
Joined
Apr 14, 2014
Messages
45
Motherboard
ASUS ROG STRIX Z370-I GAMING
CPU
i7-8700K
Graphics
RX 580
Mobile Phone
  1. Android
  2. iOS
New patch needed:
Code:
<key>KextsToPatch</key>
        <array>
            <dict>
                <key>Comment</key>
                <string>USB 10.13.4+ by PMHeart</string>
                <key>Disabled</key>
                <false/>
                <key>Find</key>
                <data>
                g32UDw+DlwQAAA==
                </data>
                <key>InfoPlistPatch</key>
                <false/>
                <key>MatchOS</key>
                <string>10.13.x</string>
                <key>Name</key>
                <string>com.apple.driver.usb.AppleUSBXHCI</string>
                <key>Replace</key>
                <data>
                g32UD5CQkJCQkA==
                </data>
            </dict>
        </array>

i had to upgrade USBInjectAll.kext to 0.6.5, add XHCI-300-series-injector.kext and edit the config.plist like here: https://github.com/RehabMan/OS-X-USB-Inject-All/blob/master/config_patches.plist

I've an ASUS Z370-I
 
Last edited:
Joined
Jan 4, 2015
Messages
1
Motherboard
Asus
CPU
Intel
Graphics
Nvidia
New patch needed:
Code:
<key>KextsToPatch</key>
        <array>
            <dict>
                <key>Comment</key>
                <string>USB 10.13.4+ by PMHeart</string>
                <key>Disabled</key>
                <false/>
                <key>Find</key>
                <data>
                g32UDw+DlwQAAA==
                </data>
                <key>InfoPlistPatch</key>
                <false/>
                <key>MatchOS</key>
                <string>10.13.x</string>
                <key>Name</key>
                <string>com.apple.driver.usb.AppleUSBXHCI</string>
                <key>Replace</key>
                <data>
                g32UD5CQkJCQkA==
                </data>
            </dict>
        </array>

Worked on my PC ty.
 
Status
Not open for further replies.
Top